Previous 1 2 Next 26 Replies Latest reply: Aug 30, 2013 9:17 PM by marksto
XENiCraft Level 2 (265 points)

Hello All


I have a 2009 iMac which recently had the RAM replaced due to some issues. I have since gotten it back and installed a fresh copy of Mountain Lion and updated it to the latest version (10.8.4).

I have not been able to play any quicktime files, as Quicktime 7 just displays a blank player with 00:00:0 being the time reading, no playhead and no video. I have installed Perian and since removed that along with Flash, as Flash is usually the culprit. Then i recently discovered that Skype no longer works. Just yesterday I was using it fine and the day before yesterday Skype auto updated.

I had not restarted my computer in a while so I decided to do so after finishing up with Skype and when I started the computer up today and tried to open Skype, I got the following error. I even tried completely uninstalling Skype and reinstalling and I still get it.

I did some looking around on my mac. I looked in Quicktime 7 after uninstalling Perian and still could not play anything, it either locked up and beachballed or game me a strange error code. I then tried to open the same file in Quicktime X and just got an instant crash. So I went to the Finder and tried to quick look a video file and promptly received a crash. The same occurs with really any media file. Audio and video alike. And now I get this in iTunes.


Everything is updated in the updates section of the Mac App Store. I tried this command

plutil -p /System/Library/Frameworks/QuickTime.framework/Resources/Info.plist

which yields:

/System/Library/Frameworks/QuickTime.framework/Resources/Info.plist: file does not exist or is not readable or is not a regular file


I am now absolutely certain the QuickTime frameworks are damaged. Now I just need to know. Do I have to do a fresh clean install? Coz that would be a serious pain in the neck. Can I just reinstall Mountain Lion over the top?


It was also suggested to me to try and extract the Quicktime installer from the Mountain Lion installer. I cannot find a single package for quicktime, but I have found the Essentials package in the Install ESD and I just need to know which folders to copy. I will detail steps taken upon request.


This suggests that some changes were made to Quicktime, maybe some of them went wrong?



Many thanks in advance,


  • macjack Level 9 (51,639 points)

    Create a new account or log into your Guest user and test QT. Put some video files in Users/Shared first as you won't be able to get to them when logged into the other account.


    If QT works as expected in the other account, then you need to troubleshoot your user.

    If not, then re-install ML over the top. This will only replace system files and shouldn't touch anyt of your data or settings. That said, always have a backup.

  • XENiCraft Level 2 (265 points)

    I really wish it were that simple. But no it doesn't work. I noticed that in the /System/Library/Frameworks/QuickTime.framework/ directory the aliases were broken, but if i used the full path (/System/Library/Frameworks/QuickTime.framework/Versions/A/Resources/info.plist ), it displayed the file correctly.


    I have had experiences where doing a reinstall over the top doesnt fix things, but rather messes them up further. Especially as I have Final Cut Studio 3 and Adobe Master Collection CS6 installed.


    Do you have any other suggestions before i do this reinstall?

  • OneBlueSky Level 1 (25 points)

    Be careful. I am experiencing this issue with Skype/Quicktime as well, and I have reinstalled about 4 times. You're probably the one in the Skype thread too? We finally found ONE Mac where the issue seems to actually be Quicktime. It works for a day or so and then the problem appears all over again. There seems to be something that is breaking Quicktime either in this latest version of Skype itself, or some other software we may both have installed. Just saying, don't count on all the work of a reinstall sticking at all.

  • XENiCraft Level 2 (265 points)

    Thank you! That's what I call helpful.

    Ah i see.


    My MacBook Pro is running 10.8.3 and Skype and it works FINE. So does QuickTime. If it didn't I'd be in some trouble as I rely on it for work purposes. But it's still really annoying to have to switch computers purely coz Skype and Quicktime doesn't work.

    I really hope some Skype staff get on that thread...


    Please try this command in Terminal:

    plutil -p /System/Library/Frameworks/QuickTime.framework/Resources/Info.plist

    then try this:

    plutil -p /System/Library/Frameworks/QuickTime.framework/Versions/A/Resources/Info.plist


    Paste the results in a reply.


    The thing that stands out for me in the second command is this:

    "CFBundleSignature" => "????"

    Some thing tells me that's not right.


    and yes, im the guy in the skype forums




  • OneBlueSky Level 1 (25 points)

    Right, I can get the older versions to work as well, it's only the newest version of Skype with OS X 10.8.4 and the current version of Quicktime that seems to be breaking. Same here, Skype is necessary for work purposes. (Oh if only people would just move over to Facetime, haha! ) But right, it is annoying to have to revert to old versions of OS X or Skype (Skype 6.3 works on 10.8.4 even if you're getting the error with Skype 6.6) . I hope so too. I had communication with them via support emails, but they insisted it's a problem with OS X and Skype is perfectly fine and there's no issue and nothing they can help with. That's not true at all, as until THIS update to Skype, everything worked flawlessly and nothing broke Quicktime. If I reinstall and don't install Skype, the system works fine. Reinstall, then put in Skype 6.6, Skype is broken, Quicktime is broken... This is purely related to Skype, nothing changed except for Skype. They seem to insist on avoiding even looking into it at all.


    Anyway, I will try that when I get home and post the results! Not at that Mac right now, am out of town today but I'll post back tonight or in the morning with the results

  • Eric Root Level 9 (50,537 points)

    Do a backup.


    Try booting into the Safe Mode.  Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. When you reboot normally, the initial reboot may be slower than normal. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart by using the application uninstaller. For each disable/delete, you will need to restart if you don't do them all at once.


    Safe Mode


    Safe Mode - About


    General information.


    Isolating issues in Mac OS X


    Troubleshooting Permission Issues



    Step by Step to Fix Your Mac

  • XENiCraft Level 2 (265 points)

    I might have mentioned this before but it was only after I restarted that this started happening with QuickTime. Skype had updated to the latest version and it was fine and QuickTime work fantastic as usual, but then as soon as I restart, boom. D:

    Was this the case on any of your macs OneBlueSky?


    @Eric I have tried that but it doesn't work.

  • OneBlueSky Level 1 (25 points)

    Backing up/restoring didn't help here. Nor does reinstalling just Quicktime, or Skype, I've played with this SO many ways it's unreal. The only thing that gets it working again, is to completely reinstall OS X and Skype, or to just use an older version of Skype lacking some functionality of the current version. (some things on Skype 6.3 will not work anymore, 6.5 gives the same error as 6.6). Yes Xeni, everything works fine upon OS X reinstall and using Skype until the first time Skype is either closed, or the Mac is restarted. If I don't run Skype, nothing breaks no matter how many times I restart. First time I log in to Skype 6.6 and close it, Quicktime and Skype both are broken. I can duplicate this as often as I feel like reinstalling OS X for Skype alone (which is not often, I am so tired of doing that). It's not a fluke. Also, it does that whether I have all my apps reinstalled, or do a purely vanilla install of OS X and only adding Skype, which seems to say that it's not a combo of Skype and another app.


    It really seems we are going to have to wait for something from Skype. It's a weird issue as not everyone with a Mac seems to experience it. But all 4 of our Macs are (Mac Pro, Macbook Pro, Macbook Air, and iMac, all 10.8.4 ) are. It's something to do with Skype, as again, never had this problem with 6.5, and NOTHING else causes Quicktime to break. Skype is doing something on some of our machines.


    (Still not home, but I will post what you asked for soon as we are!)

  • XENiCraft Level 2 (265 points)

    What is the solution? Will 10.8.4 work with Skype 6.5? Or maybe another version?

  • OneBlueSky Level 1 (25 points)

    The results from the commands you asked me to run the other day -


    /System/Library/Frameworks/QuickTime.framework/Resources/Info.plist: file does not exist or is not readable or is not a regular file





      "CFBundleShortVersionString" => "7.7.1"

      "CFBundleIdentifier" => ""

      "CSResourcesFileMapped" => 1

      "CarbonLazyValues" => {

        "CodeFragmentManager" => {

          "QuickTime" => "CFMPriv_QuickTime"


        "Gestalt" => {

          "qtth" => "__QTInitializeGestaltValues"

          "qtrs" => 1

          "icmp" => 20

          "qtsf" => 0

          "qtvr" => 15

          "qtvv" => 124878848

          "qtst" => 124878848

          "qtim" => 124878848



      "CFBundleName" => "QuickTime Framework"

      "CFBundleSignature" => "????"

      "CFBundleInfoDictionaryVersion" => "6.0"

      "CFBundleDevelopmentRegion" => "English"

      "CFBundleExecutable" => "QuickTime"

      "CFBundlePackageType" => "FMWK"

      "CFBundleVersion" => "2599.31"




    So far I have found no solution. Once this happens, Quicktime cannot be reinstalled or restored from an earlier backup using Time Machine, or another backup application I use (Carbon Copy Cloner). Your only course of action from here so far, seems to be just reinstalling OS X, and making **** sure you don't close Skype or restart the machine, ever. At least until the Skype people get off their butts and do something about it. As far as 6.5, no it won't work, it gives the same error. With 10.8.4 you can use 6.3 or older, but some of the features no longer work so it's a bit of a handicap, but seems to work more or less.


    I am getting to the point I'd rather just find a way to substitute it. Facetime for video calls, some other client for text chatting. I don't know what to do, especially since Skype staff seem to be avoiding this issue they created like the plague.

  • XENiCraft Level 2 (265 points)

    Thanks, and I get the same results.


    You could try Viber as long as you have a mobile device.

    What are the issues with Skype 6.3?




  • OneBlueSky Level 1 (25 points)

    I'll check that out, thanks!


    Well, some people who are having this issue with 6.6/6.5 and 10.8.4 say that Skype 6.3 doesn't show avatars properly, drops chats/signs you out a lot, and various parts of the "chat" area are broken. But I only use it mainly for video calls, and have not noticed any serious issues there.


    I can avoid Skype for many things, but the part that is really getting under my skin is that Skype seems to quite literally be breaking a major part of the OS (iTunes won't even work properly without Quicktime, among other things) for people and they won't even say a word. Not a suggestion on what to do, no help troubleshooting at all, not even a "we're working on the issue". Terrible way to do things, makes me even more angry as I was subscribing to some of their pay services (and they won't refund the latest payments, though their application literally is breaking our machines' functionality).

  • XENiCraft Level 2 (265 points)

    It is indeed horrible, as Quicktime is a core component of OS X, and there is no "easy" way to reinstall it apart from reinstalling the entire operating system. Simply unacceptable.

  • XENiCraft Level 2 (265 points)

    Hello again,


    I have had Skype installed and it seemed to be working fine. I used it for a few days then out of the blue it said "We've updated Skype for you to the latest version". I was obviously extremely displeased. I had "Keep Skype up to date" in the preferences unchecked since the beginning, but it must have done it anyway as when I next launched Skype it said version 6.6 in the info panel. D: I promptly quit Skype and deleted it and all of its files in the system and reinstalled Skype 6.3, hoping no damage had been done. I then had to restart my mac as I had OS updates installed, so I did that and held my breath. Luckily Skype and Quicktime worked fine. Whew! All good. Or so I thought....

    That was two days ago, and yesterday when I tried to quick look a file, it said an error occured. I tried again on another file and went back, and it worked. Today, when I quick look it just crashes. I tried to open somehing and Quicktime it crashed. ARGH!!!

    So now I have to reinstall AGAIN and hamper my work. Here goes another hour to reinstall.......


    Dammit Skype!!

Previous 1 2 Next