13 Replies Latest reply: Apr 5, 2015 11:50 PM by yl82
Mouzy Level 1 (0 points)

Hello !

 

i am trying to connect to this site and i always get a Secure Connection Problem.

 

It is the site of my university where  i check my grades.

 

I always get the picture i attach.

 

It is very annoying tbh.

 

Any suggestions ? I dont have the same problem when using any other browser or i try to connect via iPad or iPhone.

 

Only Safari on ML has this issue.

 

I have switched off all my extensions and it didnot work.

 

Also i dont have Rapport (or how it is called).

 

Thanks in Advance for your help.

 

Screen Shot 2013-07-14 at 2.26.05 PM.png


MacBook Pro, OS X Mountain Lion (10.8.3)
  • Linc Davis Level 10 (192,335 points)

    That site requires a client certificate for access. Do you have the certificate?

  • Mouzy Level 1 (0 points)

    Yes i got the Certificates installed on my mac.

     

    Nothing happens.

  • Linc Davis Level 10 (192,335 points)

    I can't test the site, but it's presenting an expired server certificate. That may or may not prevent you from connecting to it. Here are some simple steps you can try.

    Check that the date (including the year) and time shown by your system clock are correct.

    Restart your router and broadband device, if different.

    Try another browser, such as Firefox.

    If you connect to the Internet through an HTTPS or SOCKS proxy server, follow the instructions in this support article, or deselect the proxy entirely.

    Boot in safe mode and try again.

    Follow the instructions in this support article to change your DNS settings.

    If possible, test on a different network, such as a public Wi-Fi hotspot or the cellular network of your phone.

     

  • Mouzy Level 1 (0 points)

    Here are the results.

     

    Date and Time are correct on system clock.

     

    I restarted the device but nothing changed.

     

    On other browsers (Firefox) i can see the page (Enter ID and PW).

     

    I tried reaching the page on Maverics DP from my external HDD and it worked perfect.

     

    I tried on cellural network and nothing changed (it still says the Secure Connection Thing)

     

    I dont use proxy server to connect so i avoided this step.

     

    In Safe Mode the problem Persists.

     

    I changed the DNS Settings but nothing.

     

    I have even done a clean install on my mac (about 20 days ago) and didnot load the settings from backup. I only loaded my libraries. wierd thing.

  • Linc Davis Level 10 (192,335 points)

    From the Safari menu bar, select

       

    Safari Preferences... Privacy Remove All Website Data

     

    and confirm. Test.

  • ablecom Level 1 (0 points)

    This problem really has only one solution.  Do not use Safari.

     

    I have been forced to use Google Chrome or Firefox when activating Glassfish on my server.

    My server which I shall call mydomain.com.au has SSL certificates which work just fine in every browser when I  use mydomain.com.au or www.mydomain.com.au or mydomain.com.au/myapp and in each case the https:// is prepended.

    However for Glassfish I need to use the port number, like this:  mydomain.com.au:9198 and the presence of the port numbers causes a real problem wirh Safari and a helpful warning from Chrome.

     

    Chrome will warn me but let me proceed, which in this case is quite safe for me to do.

    Safari locks me out and will never allow me through.  So Safari is useless for this purpose.

     

    I refer you to http://openradar.appspot.com/8696868  which is a thoughtful bug report now nearly 3 years old.  This report states that Safari does not support RFC5746 (has broken SSL renegotiation)

     

    The other browsers support RFC5746 but Safari users are locked out of certificate protected content on servers/directories requiring renegotiation. 

  • Jason P Garforth Level 1 (0 points)

    In Safari - "Safari" -> "Reset Safari...", make sure "Remove All Website Data" is checked; click "Reset"

     

    This should re-establish the "Show Certificate" dialog - so you can accept it and carry on.

     

    It seems Safari really doesn't like it when its saved caches doesn't appear to match what the Web server is sending back :-)

     

    There may be a way of just resetting that site; but the Cache.db and other files its uses are not trivial to manipulate.

     

    Works in Safari 6.0.7 (Lion) to Safari 7.0.2 (Mavericks)

  • Virtigo119 Level 1 (0 points)

    Set date and time on automatic

  • Rar08 Level 1 (0 points)

    This worked for me! Thanks!!

  • ccartmell Level 1 (0 points)

    I've been having trouble with both my Ipad and Iphone being able to establish a secure connection the to server.

  • cam3691 Level 1 (0 points)

    Virtigo is the Zen master.  Spot on.  Just set your time/date on automatic.  This is THE solution.

  • jwsadler Level 1 (0 points)

    This one may surprise you: if you have autologin turned on for your account, turn it off.

    Go to System Preferences, Users & Groups

    Click Login Options at the bottom of the left pane

    (Click the lock and enter admin credentials if necessary at this point to unlock the dialog)

    In Automatic Login, select OFF

  • yl82 Level 1 (0 points)

    Virtigo119's solution works on my ipad!  Thank you!  It was unable to connect to any of google services and now the problem is fixed instantly.