11 Replies Latest reply: Feb 14, 2014 3:36 PM by christina145
TomNYC Level 2 (340 points)

Just got a new iMac and have beent trying to get Facetime working for days. When I try to sign in with my valid Apple ID, I get the following error message:

 

The server encountered an error processing registration. Please try again later.

 

I've tried all of the suggestions I could find here and on other webistes, such as all the things listed on this site. I've also tried adding 8.8.8.8 and 8.8.4.4 to my DNS network settings. I also did everything suggested in this Apple Support document.

 

But I still get the above error message no matter what I do!

 

HELP! I need to get this working, I depend on Facetime to stay in touch with my family who live far away. I can no longer chat with them using Facetime since buying a new iMac.


iMac, OS X Mountain Lion (10.8.4), 27", 3.4 GHz, 16 GB RAM, NVIDIA 680
  • TomNYC Level 2 (340 points)

    Does anyone have any idea how to fix this? I'm at my wits end trying to make this work, ready to take this new iMac back for a refund at this point.

  • TomNYC Level 2 (340 points)

    I eventually talked to an Apple Support senior advisor about this, and the problem stemmed from corruption with Keychain files. Removing specific keychain entries did not work, it had to be reset back to "factory default" which means you will lose all the stored passwords for everything, but, it at least solved this problem.

     

    Here's how to reset the Keychain:

     

    1) In Keychain Access menu, select Preferences.

     

    2) On the General pane there is a button that says Reset My Default Keychain. Click that button.

     

    You should now be able to log in to Facetime and iMessage on your Mac if you were previously having problems, or if you were being prompted for the password over and over again.

     

    Hope that helps someone.

  • craigsm Level 1 (0 points)

    unfortunately this did not solve my problem. I've logged out, Reset Dafault Keychains and still getting the same message: The server encountered an error processing registration. Please try again later.

     

    Has anyone found anything else?

  • Snowjunkie Level 1 (5 points)

    I'm having the same issue.  In fact, it just started doing it after it was working fine.  Resetting the keychain does not solve it for me either.

  • styrrell Level 1 (0 points)

    Exact same problem. And I'm not happy about deleting my keychain passwords only to have the exact same problem. Not only did this happen "all by itself" but now I can't seem to do anything to correct it. VERY frustrated.

  • KU_House Level 1 (0 points)

    I had this same exact issue tonight but somehow got it working later on.  Not sure if one of these things fixed the problem or if I just got lucky.

     

    1.  I ejected my external hard drive and unplugged it from my iMac.

    2. Restarted my computer

     

    Good luck!!!

  • Mac Bubba 69 Level 1 (0 points)

    Had the same issue and (I hate to even say this cause Macs are not known for this only Windoz) rebooted my computer.  Voila, connected no problem.

     

    Rejoice!

  • Zenmasterz Level 1 (0 points)

    All I had to do was make sure my date and time was correct and it worked. I was trying for months to make it work and I just realized I had some peoblems with the app store and they told me to make sure my date and time was correct and the problem was fixed. I just did that and after months of trying seeing that stupid message I can finally log into my facetime as well as imessage. Hope this help someone.

  • tubetone Level 1 (0 points)

    same problem here...i changed my time zone to automatc and rebooted computer...signed in and it worked!

  • Nickster86 Level 1 (0 points)

    Hi

    Where can i find keychain at on my macbook?

  • christina145 Level 1 (0 points)

    Restarting just worked for me as well.