2 Replies Latest reply: Jan 21, 2014 12:46 PM by SuneR
samirullah Level 1 Level 1 (0 points)

I created a windows usb with bootcamp assistant, "Create a Windows 7 or later version install disk" with a windows 7 ISO image.

I went through bootcamp's "Install or remove Windows 7" option and partitioned 21GB from my harddisk for my windows partition (it's named "BOOTCAMP", MS-DOS (FAT)).

I plugged in my usb and restarted my laptop. I pressed option during boot to go into the boot menu. Somehow, my usb stick doesn't show up in the boot menu. I only see my normal boot partition and a recover partition. I tried removing the USB stick while I am still in that menu and plugging it back to see if that will fix the problem. It did not.

Strangely, I noticed that my USB stick does not light up when I unplugged it and reinserted it when my mac is in the boot menu. Normally the usb stick will light up when inserted into this usb port.

I thought my ISO is not bootable so I tried another windows 7 ISO and the results remain the same.

Is it possible that my model is too old such that it doesn't allow booting from USB during boot time? Is it possible that older ROMS do not check for USB drives during boot time (hence explaining why my usb doesn't light up)?

I can assure you that my usb port is functioning correctly


MacBook Pro, OS X Mountain Lion (10.8.4), Macbookpro can't recognize bootable
  • VictorLimeira Level 1 Level 1 (5 points)

    I did the same in an MBA mid 2013, same problem when tried to install windows 7. I gave up and installed windows 8. Sorry!

  • SuneR Level 1 Level 1 (0 points)

    I have the same issue on a late 2013 Macbook Pro 15inch. I booted into Recovery mode, and selected to install new Mavericks, and chose my USB drive as the target.

     

    The installer correctly downloads to the USB, and the bootable USB works fine on my old 2010 macbook pro. However, the USB drive does not show when i boot with option pressed. It is as if the Macbook just dont permit booting from USB - eventhough the drive was created on the very same mac.

     

    Anyone have a clue as to how to boot from USB?