Skip navigation

Bootcamp wifi not detecting networks after mac OSX wifi update

25781 Views 34 Replies Latest reply: Feb 5, 2014 2:55 PM by StephenZ_DE RSS
1 2 3 Previous Next
dijitak Calculating status...
Currently Being Moderated
Jul 22, 2013 6:09 PM

Did the OSX wifi update for the 2013 macbook airs change anything in the wifi adapters firmware? As since i have updated the wifi in OSX, Windows 7 no longer picks up any networds, the adapter installed fine.

 

Thanks.

MacBook Air (11-inch Mid 2013), Windows 7
  • AleSSANDRO NAPOLI Calculating status...

    I have the same exact issue with my bootcamp partition with windows 8 installed...

  • kkuhrt Calculating status...

    same problem with windows 8

  • AleSSANDRO NAPOLI Level 1 Level 1 (0 points)

    OK.

    I just uninstalled the wifi and ethernet adapter drivers from the Windows 8 side. Then I rebooted my machine into Windows and started using it. After a few minutes it began detecting the vailable wifi networks.

  • drifter29 Calculating status...

    Hey everyone. I have a HUGE issue which is the same as the original poster.  Long story short, I bought a 2013 11inch Macbook Air, and installed windows 8 via bootcamp.  Everything went through fine, got to the desktop, installed all the drivers.  Everything worked EXCEPT the wifi.  It had a red "X" over the wifi and said could not find any networks.  I would reboot and go to the OSX side and wifi would work fine.  I ended up returning that macbook for a 13 inch one and tried installing windows 7 64 bit via boot camp.  Same result. No wifi.  So i found out there was a wifi patch for OSX that I figured Id try for the heck of it, and still got the same result on the windows side.  Then my battery started draining 10% every 30 min, so I spoke to applecare for 2 hours and they determined it was a bad battery.  Brought it into the store, exchanged it for the same model.  Brought it home, tried installing windows 7 again, same result.  No wifi.  I tried different bootcamp versions, different USB keys, different sides of the mac, same result.  HOWEVER i did notice something very odd.  If I resbooted the computer FROM OSX, and held down the "option"key to select an OS, the network section at the bottom below the partitions would just spin for 20 seconds and then show a blank with a check and "X" in it. No networks.  So then if I chose the Windows partition, it would boot into windows, and there would be no wifi.  HOWEVER, if I was in windows, and rebooted the computer and held down the "option" key for the boot menu, the network section would work fine and show all networks.  It I then selected windows again from there, the wifi works fine in windows.  There seems to be some issue at the close of OSX and option key to the boot menu screen that cuts off the wifi or something.   I also notice that if I go to OSX from the boot menu screen, that when I go to shut down or restart OSX the screen turns white and I got a little circle at the bottom of the screen which spins for 20 seconds before it shuts down or restarts.  Normally it only take 1 second to shut down.  EVERY SINGLE TIME I see this white screen and reboot into the partition boot menu, the wifi doesn;t work and neither does wifi in windows.  I was on the phone with applecare for 4 hours about this and they think it has something to do with the partition screen cutting off the wifi.  They are sending it to the engineers and are supposed to call me back with an update.  This is horrible because I bought this 12 hour macbook to run windows and maybe get 8 hours from the windows side since I have so many programs that are windows based.  I hope they fix this because theres no use having windows with no wifi.

  • Mac_Win Level 1 Level 1 (25 points)

    Does it work if you do a cold boot in Windows? ie while in Windows, shutdown the computer completely and restart the system in Windows.

  • drifter29 Level 1 Level 1 (0 points)

    Yes If I am in windows and the wifi is working at the time, I can restart out of windows and go back into it 4 or 5 times and the wifi always seems to work. But if I ever go into the options boot menu screen and go into OSX and then windows, it doesnt work.  I am actually going to try something I read on here tonight.  Im going to wipe my whole hard drive, reinstall OSX, then run bootcamp and install windows.  And then restart the computer and hold down the "x" key during reboot to force it into mac OSX, and then download the bootcamp drivers from the assistant.  People were having the same kind of issue with windows 8, so I figure Ill give it a try.  Probably won't help but I really don't want to return this.

  • hoodyioreth Calculating status...

    Thanks so much for posting about this drifter29, I have the same issue and no joy from Apple to date.

     

    I have a max-spec mid 2013 Macbook Air, which I also purchased for using as a mac / win machine. It worked perfectly for the first month - using bootcamp for a win 7 machine natively when I need speed or within OSX using Parallels version 8.

     

    My problems with wifi began after Apple pushed out their firmware "fix" for the broadcom 802.11ac wifi (version 6.30.223.74.35 as reported by my machine). Although the wifi continued to work perfectly within OSX, when I ebooted into a win 7 machine it would usually not show any wireless networks. Apple diagnostics (rebooting the Air holding down the "D" key) would likewise give a "No Wi-Fi networks were detected (Reference code CNW007)" error, and the boot up (hold down OPTION key) gray screen would not show any wireless networks either.

     

    I tried many possible solutions in vain - deleting and re-installing the bootcamp from a winclone 4 image (http://twocanoes.com/winclone/ great software BTW), and OSx partition from carbon copy cloner image; reinstalling bootcamp drivers, etc.

     

    Took the device into my local apple repair / reseller, and of course it all worked perfectly in their store. Their AST diagnostics passed 100%, reset SMC etc tried... but the problem recurred at my home (timecapsule wifi) and work (university cisco network). I took photos of the Air at both work and home next to other Idevices all picking up the networks perfectly. I could get around the problem using parallels (which uses the osx wifi and tunnels it into a virtual wired port in windows machine) but speed was slow for graphically intense apps.

     

    I took it into the Apple store in Perth today and the response there was disappointing. Essentially, as it works in OSX, and Bootcamp isn't fully supported by Apple (his words) then it's a microsoft problem. I asked if there is a way to wind back the firmware update (eg: reflash with an older firmware that worked) but I was told that this isn't available. I think that it's disingenouse for Apple to provide Bootcamp as a part of OSX without taking some responsibility for it not working, using drivers that are downloaded form Apple itself.

     

    In despair I returned to work to rant about my woes, but was please so find this thread. I hadn't noticed the double option-key boot trick into windows 7, but it seems to work for me here and I pray that it also works at home tonight. I can also confirm the 15-20 second shutdown spinning waiting circle when rebooting from OS X now as drifter29 reports.

     

    I can live with this double reboot for now so long as it lets me run window reliably, awaiting updated bootcamp drivers from apple. Does Apple / Broadcom / Microsfot know that this is an issue? I'd dowbload and trial some non-bootcamp win 7 drivers for the "Broadcom 802.11ac network adapter; 0117106B&Rev3" but I can't tell whether or not these are available from anywhere other than apple? My driver in windows gives me version 6.30.223.75 currently.

     

    drifter29, please report on your progress with this also, did your wipe & reinstall OSX work?

     

    Cheers again,

  • hoodyioreth Level 1 Level 1 (0 points)

    I agree with you re it not being a microsoft issue - after all the error occurs in the mac gray boot volume screen which is before the machine has even looked at the windows partition. But try explaining this to the mac-obsessed Genius at the store.... ;-)

  • drifter29 Level 1 Level 1 (0 points)

    Well my update about this is as follows.  Its diffinantly NOT a microsoft issue.  I spoke with another apple tech person who told me he thought the reason behind this issue was the wifi update fix pushed to OSX a few weeks ago.  What I ended up doing was wiping the SSD completely, reinstalling OSX, and NOT doing the airport 1.0 update that was released to OSX.  I learned that if you wipe the SSD, and do internet recovery, it will install the version that came with the machine.  Lucky it was OSX 10.8.4, and the wifi update was never installed.  I did this, installed bootcamp rigth after I got to the welcome screen after reinstalling OSX.  And low and behold, the wifi worked in bootcamp 99% of the time.  I did 14 different reboot sequences, wrote them down, and then called apple to report this to the engineers.  The only time I was able to make it fail was by "Being in windows, restart the machine, hold the option key at reboot, then select OSX, wait for it to load, THEN restart in OSX from there, and then hit the option key again, and select windows"  this was the only fail.  However, after doing a bunch of other reboots, I tried this sequence again, and it worked fine.  So its definantly something with OSX leaving something running after an option reboot into windows.  I told apple and am still waiting for a phone call.  I actually ended up getting so irratated with not having the "peace of mind" machine that I sold it and bought a maxed out 2012 macbook air, and wifi works like a charm.  Hope this helped everyone to some degree.  If I get a call from apple Ill update.

  • drifter29 Level 1 Level 1 (0 points)

    I would also like to add, that after successfully installing windows and having wifi 99% of the time, I figured I would verify also if it was the OSX wifi update.  So I installed the update and rebooted into windows about 10 times, failed every single time.  "No Networks Detected"  , with a big red "X" over the wifi.  Apple needs to fix this asap.

  • Xfacter Calculating status...

    I am also having this problem. I have found it can be fixed by launching bootcamp setup and repairing the installation. Most of the time Windows will freeze and wifi will work again upon rebooting. This is a really stupid problem and solution, I hope Apple fixes it soon.

  • Mac_Win Level 1 Level 1 (25 points)

    Sounds like it's a MacOSX issue to me. The issue didn't happen until the update was applied. A cold boot in windows seems to fix the problem.

  • gordon142 Level 1 Level 1 (15 points)

    You people are awesome. This issue was driving me absolutely nuts - I was going to take my computer back to the Apple Store for replacement today, which I see now would have been a complete waste of time.

     

    The easiest way to avoid this until Apple fixes the issue in OS X seems to be to just do a complete shutdown rather than a restart (As noted by the previous poster). This seems to avoid the issue on two counts: The shutdown happens instantly, without the 15-20 second hang, and the Wifi adapter works properly in Windows. As others have noted, it does indeed appear that OS X is failing to release control of the adapter at a very low level when rebooting.

     

    Thanks again everybody. You guys have saved me hours of aggravation.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.