Previous 1 2 Next 15 Replies Latest reply: Jul 28, 2013 12:13 PM by Ralph Johns (UK)
Lazrhog1 Level 1 (0 points)

So I got one of the new 27" iMacs (with the rounded back) at xmas 2012.  I restored from my Macbook backup at the time, and have since created family accounts etc.   Everything was working fine.   Then one day iMessage and Facetime stopped working.


I have been struggling for a few months now, trying every method ever posted related to this issue.  I think I have probably made things worse, what with deleting plists, keychain keys, DNS entries in the router etc.   iMessage/Facetime doesn't work in any account on the iMac.


I am at the end of my tether. 


If I get iMessage to get past the 'An internal Messages error occurred. There was a problem with Messages.  You need to quit and open Messages again', then it just sits there forever trying to login.  Facetime does exactly the same thing, if it gets past the ''.


I am nervous about re-installing OSX using the CMD+R reboot, as I don't want to lose all my accounts and developer keychains etc


please help.

  • Lazrhog1 Level 1 (0 points)

    Hmm, reading that back, I should probably supply some more info.


    OSX 10.8.4

    Original account for iMessage is an old, but since it stopped working I have used a new AppleID I created for testing it, and tried my itunes AppleID that I use on the iphone.  iPhone Facetime and Messages work fine.  All accounts have been verified at

  • Linc Davis Level 10 (192,529 points)

    Launch the Console application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ Open LaunchPad. Click Utilities, then Console in the icon grid.


    Make sure the title of the Console window is All Messages. If it isn't, select All Messages from the SYSTEM LOG QUERIES menu on the left. If you don't see that menu, select

    View Show Log List

    from the menu bar.


    Click the Clear Display icon in the toolbar. Then try the action that you're having trouble with again. Select any messages that appear in the Console window. Copy them to the Clipboard (command-C). Paste into a reply to this message (command-V).

    When posting a log extract, be selective. In most cases, a few dozen lines are more than enough.

    Please do not indiscriminately dump thousands of lines from the log into this discussion.

    Important: Some private information, such as your name, may appear in the log. Anonymize before posting.

  • Ralph Johns (UK) Level 9 (71,111 points)



    When did you update to OS X 10.8.4 and what was the computer running before that ?


    Also in the Apple Icon menu > About this Mac click the line with the current OS twice.

    This should show you the Serial Number.

    In some cases of repair or refurbishment this gets "forgotten" to be "flashed" back to the new Board.

    Messages makes use of this Serial Number in registering iMessages (And FaceTime).


    Can you be a bit more precise about which .plists you deleted ?

    I take it you restarted Messages  in most cases ?





    11:10 pm      Wednesday; July 24, 2013


      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Lazrhog1 Level 1 (0 points)

    To answer Ralph, The iMac was brand new in December 2012 (one of the new ones) so it came pre-installed with Mountain Lion.  I upgraded to 10.8.4 when it was available (can't remember exactly)


    The serial number in the 'about this Mac' is showing up just fine


    The plists I deleted were in the Library/Preferences area, and were anything with iMessage or iChat in it.



    To clarify, iMessage and Facetime were working fine originally, and I had no problems, then just one time I went to use them they had stopped.  They have never worked since.   Yes, I have tried to restart iMessage many times

  • Lazrhog1 Level 1 (0 points)

    To answer Linc. 


    The run of iMessage tonight showed the login screen (at least it didn't crash).  I type in my id and password and it just sits there signing in for a long long time.


    Whilst doing that, the console Log didn't really output anything of any consequence


    25/07/2013 21:04:17.813 parentalcontrolsd[567]: FCCreateAppSignature [853] -- *** SecCodeSignerAddSignature returned: -50 on pass: 2

    25/07/2013 21:05:18.805 parentalcontrolsd[567]: FCCreateAppSignature [853] -- *** SecCodeSignerAddSignature returned: -67049 on pass: 1

    25/07/2013 21:05:28.967[1]: (com.adobe.fpsaud[745]) Exited with code: 210

    25/07/2013 21:07:18.866 parentalcontrolsd[567]: FCCreateAppSignature [853] -- *** SecCodeSignerAddSignature returned: -50 on pass: 2

    25/07/2013 21:08:21.776 parentalcontrolsd[567]: -[FCApp

    25/07/2013 21:11:49.373 ReportCrash[758]: DebugSymbols was unable to start a spotlight query: spotlight is not responding or disabled.

    25/07/2013 21:11:49.578 ReportCrash[758]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    25/07/2013 21:11:49.578 ReportCrash[758]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    25/07/2013 21:11:49.624[1]: ([567]) Job appears to have crashed: Segmentation fault: 11

    25/07/2013 21:11:49.830 ReportCrash[758]: Saved crash report for parentalcontrolsd[567] version 26.1 to /Library/Logs/DiagnosticReports/parentalcontrolsd_2013-07-25-211149_imac.crash

    25/07/2013 21:12:00.029 apsd[80]: <APSConnectionNotificationQueue: 0x7f96eb900d60>: outstanding count -1 for



    seems to be a lot of parental controls stuff (which is strange as this is the admin account)


    What is interesting is if I look at the Activity Monitor, 3 processes are hogging a lot of CPU time


    securityd is cycling from ~50% to ~125%

    imagent taking ~70%

    parentalcontrolsd ~50%


    these numbers seem a bit high ....  but then I don't know what the normal picture is.


    After typing all this, iMessage is still trying to log in.  I will post another console log if anything interesting happens when it finally gives up   [Post edit - it gave up with the message 'The server encountered an error processing registration.  Please try again later']




    By the way, Linc and Ralph,  thanks for helping me out on this.  I have no idea where to go from here

  • Ralph Johns (UK) Level 9 (71,111 points)



    Linc may be able to better interpret the Console info than I can.


    However has this account ever been a Non Admin Account ?

    Mountain Lion allows you to change User accounts back and forth


    Screen Shot 2013-07-25 at 22.06.03.png


    Also has the Messages account info even been used on a Mac User Account that has had Parental Controls set ?

    For instance if you had a second Mac User account and set up Messages with an AIM Name and logged in and then set Parental Controls your whole Buddy list is then Blocked until you start adding Buddies to the Allowed List in the Parent Controls settings.  (Your Buddy List at AIM is flagged).

    When you then Log in your AIM Account back in again (No matter which computer or Mac User account) your AIM account login is effected.

    It also effects Jabber account in a similar way.

    I have not tried it with iMessages.
    It turns the Bonjour Account off completely  (which I have never understood)




    10:11 pm      Thursday; July 25, 2013


      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Linc Davis Level 10 (192,529 points)

    Turn off Parental Controls and test.

  • Lazrhog1 Level 1 (0 points)

    Its possible that the messages account was used on an account with parental controls. 


    The admin account that I was using never has.  I have disabled all the parental controls, and that specific error has gone away, however, it still doesn't work.


    Facetime decided to start up today, so this is the error message produced by Facetime (over 500 of the same error)


    26/07/2013 14:45:54.038 FaceTime[230]: Keychain sandbox consume extension error: s=-1 p= Cannot allocate memory


    along with the following possibly related errors


    26/07/2013 14:47:07.552 locationd[64]: NOTICE,NETWORK: no response from server, reachability, 2, queryRetries, 4

    26/07/2013 14:47:07.553 locationd[64]: NOTICE,NETWORK: requery, 0, 0, 0, 13, items, fQueryRetries, 5, fLastRetryTimestamp, 396539211.6

    26/07/2013 14:47:07.553 locationd[64]: NOTICE,NETWORK: query, cells, 0, 0, 0, wifis, 13

    26/07/2013 14:47:20.000 kernel[0]: Sandbox: sandboxd(273) deny mach-lookup

    26/07/2013 14:47:23.097 sandboxd[273]: ([271]) WebProcess(271) deny file-read-data /Users/CaseyMacbook/Library/Preferences/

    26/07/2013 14:47:23.553 locationd[64]: NOTICE,NETWORK: no response from server, reachability, 2, queryRetries, 5

  • Linc Davis Level 10 (192,529 points)

    Please read this whole message before doing anything.


    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.


    Step 1


    The purpose of this step is to determine whether the problem is localized to your user account.


    Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”


    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.


    Test while logged in as Guest. Same problem?


    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.


    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.


    Step 2


    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, by a peripheral device, or by corruption of certain system caches.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including sound output and Wi-Fi on certain iMacs.  The next normal boot may also be somewhat slow.


    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    Test while in safe mode. Same problem?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • Lazrhog1 Level 1 (0 points)


    Step 1

    Had to create a new account to test.  Same result, just hangs logging in forever until it gives up



    Step 2

    No difference in safe mode (other than annoyingly safe mode wouldn't restart - had to hard reset)


    No difference once rebooted from safe mode either



    I tried to get the 'set date/time' to get my location and it couldn't get it.  went into settings, and it claimed no apps had requested a location ?   strange.  Don't know if any of the location stuff is related or not.

  • Linc Davis Level 10 (192,529 points)

    Back up all data, then reinstall the OS. You don't need to erase the startup volume, and you won't need your backup unless something goes wrong. If your Mac was upgraded from an older version of OS X, you’ll need the Apple ID and password you used to upgrade.


    If you installed the Java runtime distributed by Apple and still need it, you'll have to reinstall it.

  • Lazrhog1 Level 1 (0 points)

    Am I going to lose my developer certificates in the keychain if I reinstall the OS ?


    I have a recent time machine backup so hopefully that will suffice for my data ....


    Bit gutted that the iMessage and FaceTime managed to get into this state without me doing anything strange as a user  !


    Thanks for your assistance though.  Much appreciated.

  • Ralph Johns (UK) Level 9 (71,111 points)



    The User Info should be untouched which includes the Keychain.

    However it is best to make sure you have a fresh Back up that is up to date.


    The OS is now so inter-related it is very difficult to tell what effects what in some cases.

    For instance some people turn Off Bonjour (they don't have any other Macs on their LAN and you used to be able to turn it off separately)

    Now it is  closely linked to DNS and can cause a host of Internet related issues and one of those can be iMessages and FaceTime and the Messages app in general.


    Linc has lead you through a series of tests and checks and has offered his considered opinion on what to do next.



    8:23 pm      Friday; July 26, 2013


      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Lazrhog1 Level 1 (0 points)

    reinstalling the OS solved the issue, and had no adverse effects.  Thanks Linc and Ralph. 

Previous 1 2 Next