Previous 1 6 7 8 9 10 Next 348 Replies Latest reply: Nov 29, 2015 4:05 AM by arrowheadit Go to original post
  • Mully1720 Level 1 Level 1

    This seemed to help me. I wish Apple would hurry up and fix this problem it ***** to do this way

  • ron7624 Level 1 Level 1

    I also am having this problem on my iPad mini. I show 4 apps need to update but I have the white screen.  My iPhone 5 is updating just fine. This has started happening today. I have followed all of the recommended suggestions on how to fix it, but no joy.

  • Mully1720 Level 1 Level 1

    Yeah it's got to be on Apple's end. I just wish they would hurry and fi it.

  • jesseluke Level 1 Level 1

    The solution from Apple to RESTART every time there is a big issue is getting OLD!!!!!!  when I do this, I am basically starting over with EVERYTHING!!!!  I have spent hours and hours of time setting passwords, getting all the details just right, and tweaking everything.  Which is a BIG selling point for Apple ... until there is a little problem that they simply do not want to take the time to fix.  It's frustrating and BAD customer service.


    They can not use "ease of use" as a selling point if they insist the fix is to start over with everything.  deleting and reloading all the 100's of apps and resetting all the details is BS.


    get it together APPLE!!!!!!!

  • Mully1720 Level 1 Level 1

    This is how I was able to do my updates: 1. Go to App Store 2. Go to purchases 3. Scroll down and than look at the right and it will say update instead of open, hit update and it will update the app 4. Than switch from ipad app to iPhone app and scroll down doing the same thing as in step 3

  • MiguelOKC Level 1 Level 1

    The number that keeps popping up is "2". That seems to be the update number that sticks when no updates are shown on the update page.  Have done the purchased thing and found one update and noticed that the number changed to "3" then after this was done on the purchased page "2" still pops up. 


    Have tried ALL "fixes" and can't get rid of the TWO. 


    Sent in a suggestion to apple that maybe good customer service might be to monitor this site for issues that they may be proactive ( you think they know what the word means?) in fixing. 


    My first real problem I couldn't figure out after years of owning.  Any wonder Apple is slipping?

  • Biogoddess76 Level 1 Level 1

    I second (actually third) the recommendation to start flooding the iPad feedback site:


    I've sent them my two cents worth. I encourage everyone to do the same!

  • krodieck Level 1 Level 1

    I am having the same problem. I tried all the recommended fixes and none worked. As an older non tech savvy Apple afficionado, I appreciate that Apple fixes glitches like this. Hoping the fix happens soon. Until then, I am moving my App Store icon to the third screen and doing my best to ignore the update flag.

  • WLW7734 Level 1 Level 1

    My wife and I just started having the same problem 2 days ago with our iPad minis.  We tried all the recommended fixes and none worked.  The only fix was to sync and update using my PC.  What would Steve Jobs think about reliance on a microsoft product.

  • PrelateDetroit Level 1 Level 1

    I am having the same problem. I tried all of the suggested fixes, and none of them worked. I have 7 updates available. I am adding my reply to the list. Apple needs to get on the ball about this.

  • kalel2000 Level 1 Level 1

    I'm having the same problem with mine and my wife's ipad 2s.  Could this have anything to do with apples developer site being hacked?  Just a thought.

  • juergenH Level 1 Level 1

    Same issue here, on an iPad 3 WiFi.

    Contacted support by email, this is the response :


    Lauren here from the iTunes Store. I see that your iPad shows you have three app updates but when you open the app store, no updates are listed. I can certainly understand how you would like to get this sorted out so you update your apps and I would be more than happy to help you out with this today.

    I have looked into this for you and I suggest restarting your iPad. I also located a particular thread from the Apple Discussion forums that contains information specific to your problem:


    THis was on July 26, at 15:16. Wrote them back that none of the suggestions worked, no response!

    this is lame on Apple's side. We spent a lot of money to buy their products, and that's what we get?

    at least an acknowledge that there is a problem or SOMETHING.

  • AFear Level 1 Level 1

    Lie everyone else I am having this same issue but only n some of my iPads. My 4th gen iPad has this issue but my ipad 3rd gen aren't having it. All are using the same apple App Store account.


    Very frustrating!

  • w@ll Level 1 Level 1

    SOLVED IT!!  Through lots of trial and error on these forums and via iTunes interface with iPad, I've found what caused my Updates screen to be completely blank.  It turns out that I had downloaded 3 apps when I had logged into iTunes store using an older ID.  With the iPad connected via cable to iMac, in iTunes>Apps section, there is an 'Updates' tab.  I was updating everything I saw there and then was prompted saying some of these were downloaded via a different iTunes account.  Voila.  I logged out of iTunes with my current ID, changed to the old ID, then updated the apps.  After synching with the iPad, the red 3 on the Apps icon disappeared.  Hope this helps someone out there!!

  • ron7624 Level 1 Level 1

    Mine has had a white page for 2 days. I've followed all suggestions -as I stated earlier with 'no joy'.

    Here at home, I'm using AT&T wifi.

    I just went to my in laws house with Comcast wifi and I thought I'd check just for grins, and the updates populated instantly

    Not sure why, but connect on a different wifi system/provider if you can.

Previous 1 6 7 8 9 10 Next