Previous 1 9 10 11 12 13 Next 347 Replies Latest reply: Mar 21, 2015 11:37 AM by SuperSonic45 Go to original post
  • juergenH Level 1 Level 1 (0 points)

    Well, nobody here suggested it is an easy fix. And the point about not knowing if they are working on it, is exactly the point. Apple could communicate something more than standard response "restart your iDevice" and point to this support forum, putting the blame on users' devices. THAT is the lame part!

  • Templeton Peck Level 9 Level 9 (59,390 points)

    Yes. They could communicate something but unfortunately they haven't, so accept it and move on.   Complaining here won't get you anywhere.

  • leprekhan Level 1 Level 1 (0 points)

    None of those worked for me methods worked for me.   I called AppleCare and they were not able to resolve my issue either.     Still have a blank screen on Updates in the App Store.     Have tried every reset possible including router reboots and removing firewalls in hopes that that would resolve the issue.   Please Apple fix this server issue!    

  • livermoremacuser Level 1 Level 1 (0 points)

    Worked for me - Thanks

  • Asaye001 Level 1 Level 1 (0 points)

    Don't make excuses for the Man! if the iPods and iPhones are working, then the iPads should, too.

    And with what we pay for these gadgets, they'd better have some darned good tech standing by like a doctor on OB rotation.

    Not too mention the weekend only just started, and the problem has been going on since at least Wed night on my ipads.

    Also, scan the web, as many of us did in looking for a solution, and you'll see this isn't a first time issue.

    and don't bring God into this--he's probably got a Kindle

  • krodieck Level 1 Level 1 (0 points)
  • Jimmy Wong WH Level 1 Level 1 (0 points)

    Same blank updates issue with my iPad Mini with iOS v6.1.3.  Stuck with 6 updates. It was observed that my issue started around the same time when the Apple Developer Center hacked news got out.

  • Rootberg Level 1 Level 1 (0 points)

    Having the same issue on 2 identical iPad 2s: blank update screen. Also tried the recommended work around but this did not work.

  • Templeton Peck Level 9 Level 9 (59,390 points)

    Asaye001 wrote:

     

    the iPods and iPhones are working, then the iPads should.

     

    Yes it should work for the iPad. But it isn't. So until this becomes a life and death situation, accept it and move on with your life until its fixed. I'm sure you have better things to worry about.

  • TSwiftFan82 Level 1 Level 1 (0 points)

    Having the same issue. Started 7/27. Gets annoying seeing a 1 on my App Store icon.

  • Judy Level 4 Level 4 (2,235 points)

    My iPad 2 is running iOS 6.1.3, and has the blank update screen problem.

    I also realized that the App Store app has been crashing a lot lately.

     

    My iPad 1 is running iOS 5.1.1 and does not have the blank update screen problem.

  • mariacc2 Level 1 Level 1 (0 points)

    This worked for me... Thanks!

  • Judy Level 4 Level 4 (2,235 points)

    Here is where you can send feedback to Apple:

     

    http://www.apple.com/feedback/ipad.html

  • RaySam Level 1 Level 1 (0 points)

    Same problem here. Tried all the prescribed "fixes"...none worked. I am an iPad owner since the beginning and never had this issue before. Hope apple reads these posts.

  • Andrew J. Campbell Level 1 Level 1 (0 points)

    The solution that worked for me looked like the other solutions others have posted with one big difference. Many had said to log off your Apple ID under settings then try the Update window to see if it helped. I originally read it as "log off the Apple ID. RELOGIN to Apple ID, then try updates." What worked for me was when I read someone say to stay logged off the Apple ID when you check the updates.

     

    Here is the process that worked for my iPad:1) Go to Settings -> iTunes & App Stores and tap on your Apple ID then select "log off". 2) Go to App Store and tap on the Updates tab WITHOUT logging back into your Apple ID. (Not sure if I had the app running or had quit it and opened it fresh when I logged out of the Apple ID. )

     

    For me though my iPad thought for a few seconds then cleared the blank screen and showed the now beautiful words "All Apps are up to date"

     

    I had tried every recommendation on this thread previously including power down, power up, force quit App Store App, etc. except a full backup and restore before this finally worked for me. At least for now. Hopefully it sticks.

     

    Good luck everyone, Hope this helps.

Previous 1 9 10 11 12 13 Next