Previous 1 2 3 Next 39 Replies Latest reply: Oct 13, 2015 10:13 AM by theelysium
tls161 Level 1 (0 points)

When installing an app purchased through the VPP onto an iPad using configurator it came up completed with error and unable to redeem code. I downloaded the spreadsheet again and reinstalled the app but it's now saying I have no codes left even though it is not installed on any device.

iMac (27-inch Mid 2010), OS X Mountain Lion (10.8.4)
  • nsdjoey Level 3 (930 points)

    Hey tls161,


    Strange that re-downloading the spreadsheet didn't take care of it (usually it does). Did you try removing the app from Apple Configurator and re-adding the app to Apple configurator and then re-importing the spreadsheet into Apple Configurator?



  • tls161 Level 1 (0 points)

    Hi Joe,


    I tried deleting the app in configurator, re-downloading the spreadsheet & then reinstalling the app. This is when it said I had no redemption codes left. I tried your sugesstion with the same result. Should I try unsupervising the iPad?



  • nsdjoey Level 3 (930 points)

    Yeah, that's what I would try next... unsupervising and re-supervising. Note that if you have any existing data on your supervised iPad it will be wiped when you unsupervise it so back it up.


    Just to confirm... In iTunes, did you authorize iTunes to download apps with the same Apple ID as the one you used in Apple Configurator? Below is the workflow that you should be following to make it all work. I wrote this a while ago for an older version of AC, but the process is pretty much the same... thought you could go through it to make sure you've completed each step properly.


    If unsupervising and re-supervising doesn't work and if you've followed the correct workflow in the post below, my next step would be to call VPP for Education Support at 1-800-800-2775.


    Hope this helps!




    ---a post I did on a previous thread---


    First, go into iTunes and authorize with an Apple ID (iTunes -> Store -> Authroize this computer). It doesn't have to be a VPP Apple ID…just an ordinary Apple ID used to associate with the app. Then download the app(s). They will go to ~/Music/iTunes/Mobile Applications. These apps will be linked to the Apple ID you authorized in iTunes. Next go into Apple Configurator and add the apps on the Prepare -> Apps screen. When you try to add the app in AC (clicking on the "+" at the bottom of the screen), you should be prompted to enter an Apple ID and password (see screenshot below).


    Screen Shot 2012-08-31 at 2.12.34 PM.png


    It will say that "This Apple ID will be used to redeem VPP codes…" It is NOT the Apple ID used to purchase the VPP codes… The VPP codes can be redeemed by any Apple ID.


    You must enter the same Apple ID and password that you used to download the app in iTunes, and you should be good to go.


    Hope this helps!! Good luck everyone.


  • theelysium Level 1 (15 points)

    Cat Hat Error.pngNumber unable to redeem.png


    I have the same error and more.  There is nothing wrong with my Auth, Apple ID, etc.  Everytyhing on my Configurator is perfect.  Re-importing spreadsheets does not fix this.   (Sometimes the iTunes error will go away with a spreadsheet re-import, but not all situations will be fixed.) These errors are from Apple's iTunes Store.  If you are getting these you most likely have done nothing wrong.


    Think about it, if your credentials or authorizations were wrong, then why do some apps have checkmarks and other don't, when these codes are all from the same spreadsheet?  Its Apple's error and we are suffering.


    You have to call into support and have codes re-issued to you.

  • Ilia Dybounov Level 1 (0 points)


    I have similar problem. Paid apps pushed by Apple Configurator to iPads are loosing redeem codes. In one case out of 20 copies 4 licenses were lost, in another case 2 ouf of 10, in yet another 5 out of 20. It happened on different computers in different schools. All computers run OSX 10.8.5, iTunes 11.1.3 and Apple Configurator 1.4.2.

    Apparently Apple is aware of the issue and they are working on a fix.

  • mcdermk1 Level 1 (0 points)

    I have found that if I apply free apps first, then close configurator.  Reopen and add the paid apps (VPP) you will be pormpted to log into the App Store.  I have been able to redeem all my codes this way.

  • mcdermk1 Level 1 (0 points)

    I forgot to mention I did this after receivng new codes to use.

  • Torsty Level 1 (0 points)

    Thank you this tip ended days of frustration.

    You are a  legend!!!!

  • Downsjun Level 1 (0 points)

    That worked.  Thanks!

  • ReediPad Level 1 (0 points)

    Yes - This worked for me too!  Thanks for the tip.

  • cvctech Level 1 (0 points)

    Unfortunately, I am not having any luck with this method. The errors I get are


    Code 38: Unable to redeem code with the iTunes store (

    Code 5103: Please enter your Apple ID and password to redeem your code. If you do not yet have an account click create account. (


    All software is up-to-date. I'm running OSX 10.9.1 (13B42), iTunes 11.1.3 (8), AC version 1.4.3 (373), and all iPads are on iOS 7.0.4 (11B554a). I'm authorized in iTunes, and although mcdermk1's method will force AC to prompt me for the AppleID password, I still receive this error on any new paid app I try to install. I've tried downloading the codes from the VPP store and importing them, and that does not do anything to the following screenshot:


    Screen Shot 2014-01-14 at 12.32.48 PM.png


    This happens on iPads that are already supervised with AC, and with new devices thath have never been connected to this computer before. The difference is I can't add ANY paid apps to the new device, whereas I just can't update or add new apps to the iPads that are already supervised.


    I think I first encountering this error last week, or maybe in December, but I've had a hard time finding other posts on these particular errors. Has anyone else encountered (or conquered) this?

  • nps jh Level 1 (0 points)

    I am experiencing the same problem.   Updated new apps on one iPad just fine, but failed on 2nd and 3rd.  Getting the code 38 and 5103 error noted above.  I tried uninstalling apps from AC and downloading the SS from apple and reinstalling it to no avail.  Very frustrating!  I am doing some prep work for updating 240 iPads later this week....ugh!  It is going to be a long week if each gives me this problem.Any info would be helpful!  Thanks!

  • theelysium Level 1 (15 points)

    Before I get started Apple Configurator Support is free for ALL school districts.  1-800-752-7753


    Welcome to my he-ll, folks! I have 5,000 + iPads in my school district that I have to support sll of them pretty much by myself.  I have ran the gamete of errors and I also have an Apple Engineer at my disposal.  So, I feel that I have it a little better off then most.


    1st make sure all of the software is updated.  OS 10.8 +, newest iTunes, newest AC.  (The newest AC fixes VPP code bugs.)


    2nd Make sure that you are using the correct Apple ID.  I know it sounds elementary, but I have 100 school sites and all of them have their own Apple ID, so does each department, such as After School, ELL, Special Ed, etc. I have  SHiZZA load of Apple IDs.  I assume you do to and sometimes we get confused or make mistakes, so just double check.


    3rd Close AC, open iTunes, Click store deauthorize and logout of iTunes store, open AC just so it can see that you are not logged in, close AC, Go back to iTunes log backin and re-auth.  - Try again with AC


    4th Download your spreadsheet again and reimport it.


    5th You may simply have corrupted codes.  Call support above to check or email for a re-issue.


    6th Quit all apps, Run repair permissions


    That's all I got.  If I was there I could probably fix it.  Seriously, though... call for your free support Apple needs to make case logs to document how ****ing crap* AC is.

  • nps jh Level 1 (0 points)

    Thanks, theelysium!  Wow!  My situation is nothing compared to yours, but I really appreciate your empathy!


    I will try each of your steps and if it doesn't work, I will call apple...I, too, have access to an engeneer.

Previous 1 2 3 Next