11 Replies Latest reply: Jul 28, 2013 12:03 AM by nbar
cfoughty7 Level 1 Level 1 (15 points)

My Macbook Pro Early 2010 model shuts down when I'm using it and sometimes gives me the gray screen telling me to restart. Most everytime I shut the lid and open it back up, it doesn't wake up, but I can feel and hear the hard drive spinning, and the LED on the front keeps blinking. The laptop seems to heat up worse than it use to, and sometimes when I try to turn it on, I get the three beeps. I know that means something's wrong with the RAM, so I tried different RAM and switched ports trying every configuration possible. 3 years ago, I dropped it and had to get the screen replaced. It was working fine until about a month ago when the issues started coming up. I also tried updating it from Snow Leopard to Mountain Lion to see if it was a system error, but that didn't help. HELP!!! Any suggestions would be awesome!


MacBook Pro, Mac OS X (10.6.8)
  • clintonfrombirmingham Level 7 Level 7 (29,975 points)

    There was no early 2010 model - the mid-2010 began to be sold in April of that year.

     

    Although your symptoms don't seem to suggest that you have a machine with the faulty NVIDIA GPU found on some 15" mid-2010 models, you might want to look at -> http://support.apple.com/kb/TS4088?viewlocale=en_US&locale=en_US.

     

    You're right, three beeps usually just indicate 'bad' RAM (or badly seated RAM) but I'm flummoxed as to why you're having that problem if you've tried different RAM. Are you having actual kernel panics? See -> http://support.apple.com/kb/HT2546.

     

    Call back,

     

    Clinton

  • cfoughty7 Level 1 Level 1 (15 points)

    I think then that it is a late 2009 model? It's a 13 inch Macbook as well. I'm sorry, I couldn't figure out how to check for the kernel panic. Could you explain in further detail?

  • clintonfrombirmingham Level 7 Level 7 (29,975 points)

    Look at the top level Library folder (the one on your hard drive, NOT your user Library folder) and look under /Library/Logs/DiagnosticReports. If you've had kernel panics, there will be a file (or files) with the extension ".panic". Double-click to open the file in the Console app (the latest) and copy and paste any information into a reply here.

     

    Clinton

  • cfoughty7 Level 1 Level 1 (15 points)

    Ok, but I want to quick add, I checked for software updates and installed one, and when it restarted, it gave me one long beep. Doesn't that mean that there is no ram installed? So after three attempts to restart, it finally did.

  • cfoughty7 Level 1 Level 1 (15 points)

    This is what I got.

     

     

     

     

     

     

     

     

    Fri Jul 26 20:59:29 2013

    panic(cpu 0 caller 0x2abf6a): Kernel trap at 0x0022f87a, type 6=invalid opcode, registers:

    CR0: 0x8001003b, CR2: 0x01002018, CR3: 0x00100000, CR4: 0x00000668

    EAX: 0x0086012c, EBX: 0x00000000, ECX: 0x00000000, EDX: 0x00869f20

    CR2: 0x01002018, EBP: 0x0010bed8, ESI: 0x098f7b7c, EDI: 0x0022f878

    EFL: 0x00010002, EIP: 0x0022f87a, CS:  0x00000008, DS:  0x00810010

    Error code: 0x00000000

     

     

    Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)

    0x10bca8 : 0x21b837 (0x5dd7fc 0x10bcdc 0x223ce1 0x0)

    0x10bcf8 : 0x2abf6a (0x59e3d0 0x22f87a 0x6 0x59e51b)

    0x10bdd8 : 0x2a1a78 (0x10bdf0 0x843eb7c 0x10bed8 0x22f87a)

    0x10bde8 : 0x22f87a (0xe 0x48 0x100010 0x10)

    0x10bed8 : 0x298e82 (0x81e050 0xc571b751 0xc 0x11625bb)

    0x10bf28 : 0x2aa26c (0x0 0x2ad11b 0x0 0x1104911)

    0x10bf48 : 0x2b32f2 (0x59283cf0 0x0 0x10bf78 0x2aa21d)

    0x10bf78 : 0x2ab423 (0xde 0x59283cf0 0x12d 0x1)

    0x10bfd8 : 0x2a1c2e (0x59283cf0 0x2a2a00 0x0 0x2a2a5b)

    0x59283d88 : 0x225bba (0x84bf3c 0xc569ac0b 0xc 0x84bf28)

    0x59283de8 : 0x22698c (0x1 0x91f87a8 0x823fc58 0x0)

    0x59283e58 : 0x2275b0 (0x91f87c4 0x2198ae 0x0 0x0)

    0x59283ec8 : 0x227654 (0x0 0x0 0x0 0x0)

    0x59283ee8 : 0x2199ab (0x0 0xc 0x59283f08 0x30d0c0)

    0x59283f18 : 0x535562 (0x5 0xf4240 0x59283f78 0x852980)

    0x59283f38 : 0x30d17f (0x5 0x10c000 0x1 0x3)

    0x59283f78 : 0x4f8436 (0x1 0x8ee2b08 0x91d0cd4 0x1)

    0x59283fc8 : 0x2a251d (0x8ee2b04 0x0 0x10 0x8ee2b04)

     

     

    BSD process name corresponding to current thread: makewhatis

     

     

    Mac OS version:

    10K549

     

     

    Kernel version:

    Darwin Kernel Version 10.8.0: Tue Jun  7 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386

    System model name: MacBookPro7,1 (Mac-F222BEC8)

     

     

    System uptime in nanoseconds: 54852427538

    unloaded kexts:

    (none)

    loaded kexts:

    com.apple.driver.AppleHWSensor          1.9.3d0 - last loaded 40351030080

    com.apple.filesystems.autofs          2.1.0

    com.apple.driver.AppleTyMCEDriver          1.0.2d2

    com.apple.driver.AGPM          100.12.31

    com.apple.driver.InternalModemSupport          2.6.2

    com.apple.driver.AppleMikeyHIDDriver          1.2.0

    com.apple.driver.AppleUpstreamUserClient          3.5.7

    com.apple.driver.AppleMCCSControl          1.0.20

    com.apple.driver.AppleHDA          2.0.5f14

    com.apple.driver.AppleMikeyDriver          2.0.5f14

    com.apple.driver.SMCMotionSensor          3.0.1d2

    com.apple.driver.AudioAUUC          1.57

    com.apple.Dont_Steal_Mac_OS_X          7.0.0

    com.apple.driver.AudioIPCDriver          1.1.6

    com.apple.driver.AppleIntelYonahProfile          14

    com.apple.driver.AppleIntelPenrynProfile          17

    com.apple.driver.AppleIntelNehalemProfile          11

    com.apple.driver.AppleIntelMeromProfile          19

    com.apple.driver.ACPI_SMC_PlatformPlugin          4.7.0a1

    com.apple.GeForce          6.3.6

    com.apple.driver.AppleLPC          1.5.1

    com.apple.driver.AppleGraphicsControl          2.10.6

    com.apple.driver.AppleBacklight          170.0.46

    com.apple.kext.AppleSMCLMU          1.5.2d10

    com.apple.driver.AppleUSBTCButtons          201.6

    com.apple.driver.AppleUSBTCKeyEventDriver          201.6

    com.apple.driver.AppleUSBTCKeyboard          201.6

    com.apple.driver.AppleIRController          303.8

    com.apple.driver.AppleUSBCardReader          2.6.1

    com.apple.iokit.SCSITaskUserClient          2.6.8

    com.apple.BootCache          31.1

    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib          1.0.0d1

    com.apple.iokit.IOAHCIBlockStorage          1.6.4

    com.apple.iokit.AppleBCM5701Ethernet          3.0.5b8

    com.apple.driver.AirPortBrcm43xx          423.91.27

    com.apple.driver.AirPortBrcm43224          428.42.4

    com.apple.driver.AppleFWOHCI          4.7.3

    com.apple.driver.AppleUSBHub          4.2.4

    com.apple.driver.AppleSmartBatteryManager          160.0.0

    com.apple.driver.AppleAHCIPort          2.1.7

    com.apple.driver.AppleUSBEHCI          4.2.4

    com.apple.driver.AppleUSBOHCI          4.2.0

    com.apple.driver.AppleEFINVRAM          1.4.0

    com.apple.driver.AppleRTC          1.3.1

    com.apple.driver.AppleHPET          1.5

    com.apple.driver.AppleACPIButtons          1.3.6

    com.apple.driver.AppleSMBIOS          1.7

    com.apple.driver.AppleACPIEC          1.3.6

    com.apple.driver.AppleAPIC          1.4

    com.apple.driver.AppleIntelCPUPowerManagementClient          142.6.0

    com.apple.security.sandbox          1

    com.apple.security.quarantine          0

    com.apple.nke.applicationfirewall          2.1.14

    com.apple.driver.AppleIntelCPUPowerManagement          142.6.0

    com.apple.driver.AppleHDAHardwareConfigDriver          2.0.5f14

    com.apple.driver.DspFuncLib          2.0.5f14

    com.apple.driver.AppleProfileReadCounterAction          17

    com.apple.iokit.IOFireWireIP          2.0.3

    com.apple.driver.AppleSMBusController          1.0.10d0

    com.apple.nvidia.nv50hal          6.3.6

    com.apple.driver.AppleProfileTimestampAction          10

    com.apple.driver.AppleProfileThreadInfoAction          14

    com.apple.driver.AppleProfileRegisterStateAction          10

    com.apple.driver.AppleProfileKEventAction          10

    com.apple.driver.AppleProfileCallstackAction          20

    com.apple.iokit.IOSurface          74.2

    com.apple.iokit.IOBluetoothSerialManager          2.4.5f3

    com.apple.iokit.IOSerialFamily          10.0.3

    com.apple.iokit.IOAudioFamily          1.8.3fc2

    com.apple.kext.OSvKernDSPLib          1.3

    com.apple.driver.AppleHDAController          2.0.5f14

    com.apple.iokit.IOHDAFamily          2.0.5f14

    com.apple.driver.AppleSMBusPCI          1.0.10d0

    com.apple.iokit.AppleProfileFamily          41

    com.apple.driver.IOPlatformPluginFamily          4.7.0a1

    com.apple.NVDAResman          6.3.6

    com.apple.driver.AppleBacklightExpert          1.0.1

    com.apple.iokit.IONDRVSupport          2.2.1

    com.apple.driver.AppleSMC          3.1.0d5

    com.apple.iokit.IOGraphicsFamily          2.2.1

    com.apple.driver.BroadcomUSBBluetoothHCIController          2.4.5f3

    com.apple.driver.AppleUSBBluetoothHCIController          2.4.5f3

    com.apple.iokit.IOBluetoothFamily          2.4.5f3

    com.apple.driver.AppleUSBMultitouch          207.7

    com.apple.iokit.IOUSBHIDDriver          4.2.0

    com.apple.iokit.IOSCSIBlockCommandsDevice          2.6.8

    com.apple.iokit.IOUSBMassStorageClass          2.6.7

    com.apple.iokit.IOSCSIMultimediaCommandsDevice          2.6.8

    com.apple.iokit.IOBDStorageFamily          1.6

    com.apple.iokit.IODVDStorageFamily          1.6

    com.apple.iokit.IOCDStorageFamily          1.6.1

    com.apple.driver.AppleUSBMergeNub          4.2.4

    com.apple.driver.AppleUSBComposite          3.9.0

    com.apple.driver.AppleFileSystemDriver          2.0

    com.apple.driver.XsanFilter          402.1

    com.apple.iokit.IOAHCISerialATAPI          1.2.6

    com.apple.iokit.IOSCSIArchitectureModelFamily          2.6.8

    com.apple.iokit.IO80211Family          320.1

    com.apple.iokit.IONetworkingFamily          1.10

    com.apple.iokit.IOFireWireFamily          4.2.6

    com.apple.iokit.IOUSBUserClient          4.2.4

    com.apple.driver.AppleMCP89RootPortPM          1.11

    com.apple.iokit.IOAHCIFamily          2.0.6

    com.apple.iokit.IOUSBFamily          4.2.4

    com.apple.driver.NVSMU          2.2.7

    com.apple.driver.AppleEFIRuntime          1.4.0

    com.apple.iokit.IOHIDFamily          1.6.6

    com.apple.iokit.IOSMBusFamily          1.1

    com.apple.kext.AppleMatch          1.0.0d1

    com.apple.security.TMSafetyNet          6

    com.apple.driver.DiskImages          289.1

    com.apple.iokit.IOStorageFamily          1.6.3

    com.apple.driver.AppleACPIPlatform          1.3.6

    com.apple.iokit.IOPCIFamily          2.6.5

    com.apple.iokit.IOACPIFamily          1.3.0

  • clintonfrombirmingham Level 7 Level 7 (29,975 points)

    That's certainly a hardware issue. Best thing I can suggest at this point is to take your machine to your local Apple Store or an AASP and have them run hardware diagnostics on the unit. Could be bad RAM/bad seating/broken RAM seatings, etc.

     

    Good luck,

     

    Clinton

  • cfoughty7 Level 1 Level 1 (15 points)

    I have already taken it to an Apple certified store and they ran diagnostics on it. They said that the RAM was fine, and that they think it could be a logic board issue, which I apologize, I forgot to mention before. I just know that a lot of times, this can be a false diagnosis.

  • clintonfrombirmingham Level 7 Level 7 (29,975 points)

    Your kernel panic certainly indicates a hardware failure of some sort so I wouldn't be surprised if you do need a logic board replacement. That, of course, can be very expensive. Since it's an older model, you may want to take it back and ask about Apple's Flat Rate Repair Pricing scheme.

     

    Clinton

  • cfoughty7 Level 1 Level 1 (15 points)

    Alright. Thanks for your help!

  • clintonfrombirmingham Level 7 Level 7 (29,975 points)

    You're welcome - and good luck. Be certain to ask about the flat-rate pricing!

     

    Clinton

  • nbar Level 5 Level 5 (6,955 points)

    cfoughty7 wrote:

     

    I have already taken it to an Apple certified store and they ran diagnostics on it. They said that the RAM was fine, and that they think it could be a logic board issue, which I apologize, I forgot to mention before. I just know that a lot of times, this can be a false diagnosis.

     

    There was criticism regarding the Apple Hardware Test (available to the user at home) detecting logic board issues. If you took it in to the Apple store and they ran a diagnostics test, this includes testing your logicboard. It would be odd for them to say "could be logic board issue." It either would show up clean or not.

     

    I am joining the bandwagon to bet that this is an issue with the logicboard, specifically your discrete GPU. It stinks that you need to replace the whole logic board if the issue is due to a "discrete" component-the term is misleading-but that is the case.