10 Replies Latest reply: Dec 14, 2013 9:08 AM by Hardbread
moplu Level 1 (0 points)

I cannot send photos via iPhoto 11 by mail.
The following message appears : check your internet connexion....etc...
But all is ok but it refuse to send photo via iphoto...


MacBook Pro (13-inch Mid 2012), OS X Mountain Lion (10.8.3)
  • LarryHN Level 9 (77,114 points)

    in the iPhoto preferences ==> accounts delete the account and re-enter it - you may need to contact tech support for your email service for settings

     

    or IMHO the better solution is to set Mail as your email client in the iPhoto preferences

     

    LN

  • June Higgins Level 1 (15 points)

    I've been having the same problem. Can't send photos from iPhoto, and I get the same message blaming it on my internet connection or "the server did not reply." I've checked the preferences and Mail is my email client as far as I can tell. Guess I'll have to try LarryHN's suggestion.

  • LarryHN Level 9 (77,114 points)

    If mail is your email client then you need to correct your account setting in mail accounts - you use the iPhoto account setting is you are using iPhoto for your email client

     

    LN

  • Marion Dobbs Level 2 (175 points)

    I've been tearing my hair out all morning trying to figure out this same problem. I have my email client set to Mail in iPhoto. Looking in account preferences in Mail I saw that they were different from the preset preferences in iPhoto account preferences. The differences were the ports and whether or not the SSL box was checked. I tried changing the iPhoto ports to the same ones that were in Mail. I tried different ports entirely. I tried checking and unchecking the SSL box.

    Port in Mail was 993. SSL was checked.

    Default port in iPhoto was 587, SSL unchecked.

    What finally worked for me in iPhoto was leaving the port at the default - 587 - and checking the SSL box.

    Go figure.

  • LarryHN Level 9 (77,114 points)

    THose setting a very specific to yoru email service and are not general to all - for specifics on your service you need to contact tech support for your service

     

    LN

  • Marion Dobbs Level 2 (175 points)

    I understand that. This was merely an example, and my point is that the settings for the two are not necessarily the same, nor are the default settings for iPhoto the correct ones. Trying different combinations worked for me and may for others.

  • LarryHN Level 9 (77,114 points)

    It may - tech support for your email service will always work

     

    But it is important to remember that thousands of people read these posts and if you post something that is specific to you and not general you should note it so others do not try to copy you blindly

     

    LN

  • Marion Dobbs Level 2 (175 points)

    Point taken.

  • theshredshedinc. Level 1 (0 points)

    iPhoto email - "Your email did not go through because the server did not reply. "

     

    "(Port in Mail was 993. SSL was checked.

    Default port in iPhoto was 587, SSL unchecked.

    What finally worked for me in iPhoto was leaving the port at the default - 587 - and checking the SSL box.)"

     

    WORKED!

    I have had this problem ever since upgrading my OSX. I didn't delete accounts but rather compared mail to iphoto setting. I found they were the same. Nothing seemed to work untill I changed the port in iPhoto to 587 vrs. the default port  993. It works great. The SSL is also checked.

    Thank you MD

     

    theshredshedinc.

  • Hardbread Level 1 (0 points)

    theshredshedinc. wrote:

     

    iPhoto email - "Your email did not go through because the server did not reply. "

     

    "(Port in Mail was 993. SSL was checked.

    Default port in iPhoto was 587, SSL unchecked.

    What finally worked for me in iPhoto was leaving the port at the default - 587 - and checking the SSL box.)"

     

    WORKED!

    I have had this problem ever since upgrading my OSX. I didn't delete accounts but rather compared mail to iphoto setting. I found they were the same. Nothing seemed to work untill I changed the port in iPhoto to 587 vrs. the default port  993. It works great. The SSL is also checked.

    Thank you MD

     

    theshredshedinc.

    Great!

     

    This worked for me as well. My original port was set to 2525 with SSL. I just changed it to port 587 and it works like a charm:-)

     

    Thanks guys!!

     

     

    Hardbread