1 Reply Latest reply: Jul 30, 2013 4:44 PM by Bob Timmons
AppleExtreme Level 1 Level 1 (0 points)

I just bought an airpot extreme a week ago. After I configured it, my macbook pro can connect the wi-fi flawlessly. However, my iphone 5 was unable to join the airport extreme network. It sees the network, just can't join it. It doesn't say unable to join, I choose my network on my iphone, it shows it is trying to join, and never successfully joined. I've been trying miliion's way to fix this problem. I reset my iphone completely, reset my airport extreme, and reset the model, still never worked. Any idea?


iPhone 5, iOS 6.1.4
  • Bob Timmons Level 10 Level 10 (90,740 points)

    Was one of the million ways that you tried.....changing the name of the wireless network on the AirPort Extreme and also changing the wireless network password?

     

    If not.....

     

    Keep the wireless network name simple

    Use only letters and numbers.....no special characters (like an apostrophe or asterisk, etc)

    Limit of 20 characters or less in the name....8-10 would be ideal.

    No blank spaces

    Same rules for the wireless network password

     

    If that does not work, I can only conclude that the operating system on the iPhone has become corrupted....and this is an iPhone problem....not an AirPort Extreme problem.

     

    Best to post in the iPhone support area to let the experts over there have a crack at things....but in general you will need to reset the iPhone back to its original default settings, then restore it again from your backup. If that does not work, the iPhone needs to be replaced.

     

    Using iPhone