Previous 1 2 Next 26 Replies Latest reply: Oct 9, 2015 10:45 AM by fodriscoll1
Josh2000 Level 2 (325 points)

Hi -


I just got a Chromecast and the set up seemed to be going well until the home screen (on my TV) said:

"Chromecast connected to MyHomeNetwork, but can't access the Internet"


When I checked under the WiFi icon in the menu bar Chromecast was selected but MyHomeNetwork was de-selected.


I did this a few times - first getting online with MyHomeNetwork.  Every time - during the CCast set up - it switches to Chromecast under WiFi.


It is supposed to work this way?


Is there something wrong with my Airport Express (latest version)?  Should I change a setting on it?


When I checked the Airport Utility it shows when I'm connected and when I'm not.  Under "Other WiFi Devices" there is nothing listed - "No new wifi devices detected".


Im using a MBPro 2011, running OS X 10.7.5.


Suggestions please.



  • LaPastenague Level 8 (48,899 points)

    This popped up just recently.



    Is your network wireless name and name of the AEx all smb compatible.. short no spaces and pure alphanumeric.


    If your network name is MyHomeNetwork then that should be fine.


    It is short enough.. as long as the AEx name is also short, no spaces and pure alphanumeric.


    Beyond that I cannot help sorry. But the OP in the other thread might be able to give you his setup info. 

  • Josh2000 Level 2 (325 points)

    Thanks for the response.  That other post was about Chromecast problems with Windows.  I'm using a Mac.  He said it worked on his Mac.  Mine isn't.

    As you say - all the names are OK.

    I think this might be a lesson to just keep my Apple "ecosystem" pure.

  • LaPastenague Level 8 (48,899 points)

    I think this might be a lesson to just keep my Apple "ecosystem" pure.

    LOL!! The other user.. did get it working with his Mac though.. you haven't..


    Although I have to say I am not surprised. You are supposed to use ATV obviously and iTunes.. otherwise Apple misses out.. clearly a disaster for them. Expect more controls and restrictions to ensure you stay in the walled garden.


    I don't want to answer your other thread since I do not have and likely will never have a chromecast..


    The isolation mode means the wireless clients are not able to communicate with wired clients (or even other wireless clients).. ie wireless is isolated.. internet only.. no connection to the rest of the network or even the router in all likelihood.. guest network on the express may do this.. in fact I am sure it will.. but the main wireless setup has no isolation on it.

  • Josh2000 Level 2 (325 points)

    I found this answer here:



    For the AirPorts, the Guest Network is disabled by default. You would enable it using the AirPort Utility, as follows:


    • AirPort Utility > Select the AirPort > Edit > Wireless tab > Enable Guest Network


    Unless you are planning on supporting guest wireless clients, this should remain disabled. When enabled, the overall available wireless bandwidth must be shared thus potentially impacting performance. A Guest Network does not require a user to know a password. This is similar to Wi-Fi networks provided in coffee shops and is known as a "open" network.

  • Josh2000 Level 2 (325 points)

    Update -

    although the Guest Network seemed like the correct move - the Chromecast still did not work.  I returned it to the store.  File it under SDW (S%!t Don't Work).

  • LaPastenague Level 8 (48,899 points)

    Which it did you return?? The airport or the Chomecast.. I am not clear on which was the SDW..


    Isn't Apple supppsed to be "just works"

  • Happy_Pappy Level 1 (0 points)

    I have a Chromecast working with a 6th gen AE without issue. I didn't need to enable a guest network. You may have received a DOA unit.

  • Josh2000 Level 2 (325 points)

    Happy_Pappy - now I'm jealous.


    To be honest I don't know why I couldn't get CC to work.  It just didn't.  I tried every move I learned of from this forum and others.


    The CC would get stuck at the point in the set up where it would say "CC is on your Home network but can't get on the Internet."  I reset it and tried again with no luck.


    I followed all their Help trails and just today got responses to my appeals.  (Their advice is to call their support team at 855-836-3987.  I won't be doing that but maybe someone else can use this number.)


    In the end I just brought it back to the store and bought an Apple TV.... which just works.


    Thanks again all for the input.

  • iRaj Level 1 (0 points)

    Happy_Pappy - I have an Airport Extreme and it's not connecting to the chomecast.  The chromecast software thinks it has has something to do with the uPnP settings but I know Apple doesn't really support this and has their own protocol.  Do I need to open any ports?

  • Happy_Pappy Level 1 (0 points)

    Make sure you have NAT-PMP enabled. It'll automatically open the required ports.

  • iRaj Level 1 (0 points)

    Thanks, I'm pretty sure I had that enabled but I will double check tonight.

  • iRaj Level 1 (0 points)

    NAT-PMP is enabled and I still can't connect.  I do have an older Airport Extreme (3-4 years) but I don't think that should matter.  I also have two networks going, 2.4ghz and 5ghz and i'm using the 2.4ghz.

  • bill editor Level 1 (0 points)

    OS X 10.8.4

    AirPort Utility v 6.3.1

    AirPort Extreme v 7.7.1


    Fixed my Chromecast Setup problems by using AirPort Utility 6.3.1 / Network tab / Network Options button / check the box to Allow Teredo tunnels / click Save button / click the Update button.  Wait for AirPort to reset.  Run the Chromecast setup again.  It worked for me.  I have no idea why.

  • bill editor Level 1 (0 points)

    I forgot to say I also made sure the names of my WiFi network and Chromecast were 7 or less alphanumeric characters in length.

Previous 1 2 Next