2 Replies Latest reply: Sep 19, 2013 2:00 AM by www.airtet.in
teothunder Level 1 (0 points)

My iPhone 4 got overheated while it was charging, I pressed the home button, but it didn't turn on but I thought nothing of it (it has happened before). So I just put it off to the side and waited about 10 minutes and tried again. It was still very hot and did not want to turn on. I took it off it's case and that's when I really noticed how hot it was. I could barely touch it because of how hot it was. I tried connecting it to the computer, and it doesn't even detects the device at all. Like I did not plug anything in. So now I do not know what to do, please help!

iPhone 4, iOS 6.1.3
  • sheila_m. Community Specialists (3,280 points)

    Hello teothunder,


    Thank you for providing the details about the issue you are experiencing with your iPhone.  I found a couple of resources that may help address this issue. 


    First, I recommend following these steps if your iPhone still will not power on:

    Will not turn on, will not turn on unless connected to power, or unexpected power off

    1. Verify that the Sleep/Wake button functions. If it does not function, inspect it for signs of damage. If the button is damaged or is not functioning when pressed, seek service.
    2. Check if a Liquid Contact Indicator (LCI) is activated or there are signs of corrosion. Learn about LCIsand corrosion.
    3. Connect the iPhone to the iPhone's USB power adapter and let it charge for at least ten minutes.
    4. After at least 15 minutes, if:
      • The home screen appears: The iPhone should be working. Update to the latest version of iOS if necessary. Continue charging it until it is completely charged and you see this battery icon in the upper-right corner of the screen Full battery with outlet image inside it.. Then unplug the phone from power. If it immediately turns off, seek service.
      • The low-battery image appears, even after the phone has charged for at least 20 minutes: See "iPhone displays the low-battery image and is unresponsive" symptom in this article.
      • Something other than the Home screen or Low Battery image appears, continue with this article for further troubleshooting steps.
    5. If the iPhone did not turn on, reset it while connected to the iPhone USB power adapter.
      • If the display turns on, go to step 4.
      • If the display remains black, go to next step.
    6. Connect the iPhone to a computer and open iTunes. If iTunes recognizes the iPhone and indicates that it is in recovery mode, attempt to restore the iPhone. If the iPhone doesn't appear in iTunes or if you have difficulties in restoring the iPhone, see this article for further assistance.
    7. If restoring the iPhone resolved the issue, go to step 4. If restoring the iPhone did not solve the issue, seek service.

    You can find the full article here:

    iPhone: Hardware troubleshooting



    You can also find useful information about the iPhone's operating temperatures in this article:

    When troubleshooting temperature, please refer to the following article:


    iPhone, iPad, and iPod touch (4th generation): Keeping device within acceptable operating temperatures


    When using the device or charging the battery, it is normal for it to get warm. The exterior of the device functions as a cooling surface that transfers heat from inside the device to the cooler air outside.


    If the interior temperature of the device exceeds the normal operating range, the device will protect its internal components by attempting to regulate its temperature. If this occurs, you may notice the following:


    • The device stops charging.
    • The display dims or goes black.


    If the temperature continues to be a concern, you can isolate the issue by restoring your iPhone as new:

    iTunes: Restoring iOS software



    Thank you for using Apple Support Communities.



    Sheila M.

  • www.airtet.in Level 1 (0 points)

    try to reboot your device ibooty softwre its worked for me if you are stuck in recovery mode and don't want to restore try tinyumberilla tool to fix recovery