Previous 1 2 3 Next 31 Replies Latest reply: Sep 1, 2013 4:12 PM by pymason
pymason Level 1 Level 1 (0 points)

Dear all, have just installed Leopard Server on my imac G5 PPC 20 inch (pre isight). I was upgrading from the client (non server) of 10.4.11

It was a erase and install job (the only way it would have it). Did it last night. Worked fine then. Have 10.4 bootable copy with my Data back up on an external HD (firewire connected).

This morning I chose to start up from the previous 10.4 OS boot disk to check it was working - it was. I then selected to boot up from the new install of Leopard via Startup disk in System Prefs and after startup it would not go past the Login screen - It just would not accept my details. I'm pretty sure I remember them - I only put them in last night!


I then trawled the support pages to find a workaround. Nothing works. I can't start in safe mode, can't switch OS, can't enter single user mode, can't start up from the install CD. It appears that no keyboard commands are being accepted!


From the support pages I can see that Leopard has issues at Login, however, I've not seen anything like this there!

I can't work out what on earth to do next.


Are there any nice geniuses out there that can shed any light on this issue?


I await any replies with anticipation!




P Mason...

iMac, Mac OS X (10.5.4)
  • BDAqua Level 10 Level 10 (121,185 points)

    Hello, does holding Option or alt key at bootup show any boot options?


    Might you have this setup?


    Firmware password protection in Mac OS X ...



    It would block usage of all the startup keys, like C, N, T, D, CMD+s, CMD+Option+p+r, CMD +v, Option boot will show a lock, and Shift, as well as booting from anything but the Hard Drive.

  • pymason Level 1 Level 1 (0 points)

    Dear BDAqua, Hi, and thanks for replying. In answer to your question, yes I had tried the Option key to switch Startup disks. I tried it several times - like you do (not quite believing it isn't going to work!), and spent all day on it...

    However, last night when I picked up your message, I thought I'd try it one last time just to definitively be able to tell you it wouldn't work and...

    ...It worked! I couldn't believe it! And didn't understand why this time it did work!

    I knew that was an entry point back into my G5 so I didn't take it any further then, I just planned what to try the next day.

    In retrospect I think it appears to be very time-sensitive as to when you depress the keys after the startup sound - not too soon after the sound or it doesn't appear to work. That appeared to be the only difference.


    So the following day (today), I tried it again and it wouldn't work the first few times - then it did, allowing me access and I switched startup disks first to the 10.5 install boot DVD, and from there I switched to my External HDD with my old 10.4 bootable system back up on (if I tried to start up with the External HHD attatched the keyboard commands wouldn't work).


    Once past the first entry hurdle all went as planned and I could gain entry to the mac albeit running my old 10.4 system.

    I tried to gain access to the new 10.5 systems account pref pane but couldn't open it directly. I then went hunting on the net to see if there were other ways to access the info (I was looking to see if I could change the Server Administrator Account - the account I had set up, or check it, or adjust any other settings). I tried a fix in Terminal, but it would find the relevant file (the GUID). One involved going into Single User Mode, but it appeared you had to restart in the OS you wanted to access. I tried this and just hit the 10.5 Log in screen several times. So, instead of bashing my head against the wall any further, I thought I'd get back to you and see what you would suggest at this point.

    As an afterthought, I've never installed Firmware Password Protection on any mac or OS of mine knowingly -  I work from home and our family has full access through just the one account.


    Well, that's about it right now, I'll look forward to hearing from you when you have a moment.

    Best wishes and thanks again...

    Yours, P Mason...

  • pymason Level 1 Level 1 (0 points)

    Sorry BDAqua, One small typo on re-reading.I meant to write it wouldn't find the GUID in Terminal, not would...


  • BDAqua Level 10 Level 10 (121,185 points)

    Let's see if we can make a new admin user to get into 10.5, make sure it's set to try to boot from 1.5 first.


    Reset OS X Password Without an OS X CD...



    Admin Hack...



    Starts up like the first time you buy a new Mac, but after filling in all that info again, you should have access to the computer and the other Users & files will still be there... give the new User a different name than an existing one.

  • pymason Level 1 Level 1 (0 points)

    Hi BDAqua, Thanks for getting back. I've looked at the links you suggested, thanks for that. I've previously looked them up - I don't know if I mentioned before, but the Single User Command (Command+S) and therefore Terminal, doesn't appear to be accessible on the 10.5 system during boot up.


    So that leaves the option of getting into the back of the machine and changing the RAM etc to unlock and access Single User Mode...


    Before I start delving into the innards of the machine, are there any other options that I could try?


    Also FYI, I've found that the whole keyboard command acceptance is very hit and miss, sometimes it does accept the Option key, sometimes it doesn't. It still seems to be about timing. Any idea what gives?


    Let me know what you think...

    Thanks again.

    Yours, P Mason...

  • BDAqua Level 10 Level 10 (121,185 points)

    I think it's likely a flaky KB right now. Is it USB or Wifi KB?


    If you can boot into 10.4.11, you could hand delete that file on the 10.5 drive, then reboot to the 10.5 drive.


    Of course it's a hidden file, do you know how to use Terminal to navigate & such?


    10.5 Drive/private/var/db/.AppleSetupDone

  • pymason Level 1 Level 1 (0 points)

    Dear BDAqua, Good News!  While switching Startup OS's yesterday I looked at all the Utilities the 10.5 install disk comes with, just to see if there was anything there I could use. There was the usual stuff.. I also repaired Permissions etc just incase it made any difference. Then I checked the Change Password Tool.


    Previously it looked as if it just gave you the generic type of account (not the specific name), for which you could change the password. That obviously wouldn't help much in gaining access via Login, ie if you didn't have the specific name and password.

    However, when I looked closer, it became clear that the names given were the exact account names (checking against other boot discs I knew the details of). So, I changed the password, rebooted, came up against the login pane, entered the details as they appeared in the change password tool, and Hey Presto, it let me in!


    But here's the weird bit - the account name wasn't the name I entered in the install. Somehow it had defaulted to a standard setup name of just 'System Administrator', like I had never entered my account details!

    Anyway, after gaining entry I entered details for the new Aministrator Account and everything appears to be working now without any problems!


    So in my case the issue seemed to centre around the account name being mysteriously changed that denied entry at login. I wonder if that is the case for some of the other login issues reported with 10.5 installs?


    Anyway, it appears that that little bombshell is sorted, it only leaves me with the original query I had with this install.

    In every install I've done previously, Mac have supplied a Migration Assistant to get your info over onto the new OS/Machine. With this install (10.5 Server), there appears to be no migration help at all.

    Am I missing something basic here? Apparently there is an option in the install to keep your settings and data on the HD and the install would just upgrade to 10.5 around them. However, this option was greyed out when I installed.

    Do you know if there is an option like Migration Assistant that works with 10.5 Server to help move settings etc after the install, or am I going to have to move everything manually now? It's not the end of the world (like not being able to login to your own machine), but it will be more time consuming than I would like...

    So, first of all thanks so much for all your useful suggestions with the login issue BDAqua, I really appreciate that you took the time to help, and if you do know of any easy ways round the migration issue I'd be really grateful to hear them.

    Best Wishes.

    Yours, P Mason...

  • BDAqua Level 10 Level 10 (121,185 points)

    Great work so far!        :)


    Check the Accounts pref pane or Users folder at root to sse how many users are there... any chance that user's home folder got renamed?

  • pymason Level 1 Level 1 (0 points)

    Hi BDAqua, Haven't looked at it since, but when I reset the Accounts in 10.5, there were 2 accounts set up, both generically named, one as System Administrator, the other as Local Administrator (I think), neither of which had I entered! There was also an empty/unused guest account lower down the preference pane. I Added a new System Administrator account with my chosen details on (which seemed to remove the previous generic one), and I think I removed the local admin account, thinking that there would be 2 System Admin accounts left, which as previously said wasn't the case as one seemed to remove itself when my new named/detailed System Administrator account was entered.

    So this left one account, the new system Administrator account I had entered.

    However, in the process of doing this, I did notice that the generic System Admin account had created its own users folder and home named 'root', which also doubled as the short version of this account name. In the process of setting up the new account I created a (short) name for the User/Home folder for this account.


    So I think now that there is only one user, as the System Administrator, with my files/docs from my previous OS manually copied across to the home folder.

    What i'm wondering is do I have to manually do the same with my apps and all the settings (Libraries, Preferences etc) I had previously, or is there a easier way, like Migration Assistant does with single user upgrades/installs?


    It would be nice if I didn't have to do it all piece by piece!


    Anyway, I hope that answers your question, and I hope there might be an easy answer to migrating the rest of my stuff across!

    Thanks for helping BDAqua, Let me know what you think when you have a moment...

    Regards, P Mason...

  • pymason Level 1 Level 1 (0 points)



    Just booted up in 10.5 to check what I put above was correct and found this:


    1) Accounts in System Prefs are as above (my one new account), plus a disabled guest account...


    2) But in Server accounts there are the 2 original accounts I set in the install, but now they're registered as Server Users!


    With my lack of knowledge of 10.5 Server (never used Server before this install), and servers in general, I could do with some intelligent input here as I seem to be at the end of mine...


    What I'm looking to do is migrate my main account and files/settings etc from 10.4 to 10.5 server on the same (G5) mac, and then use this as a server for 2 or 3 other macs situated around the house on a local ethernet network, through a wired router...


    Apologies for any confusion/stupidity!


    Thanks again BDAqua. Speak to you soon.

    Yours sincerely,  P Mason

  • BDAqua Level 10 Level 10 (121,185 points)

    Use Migration Assitant to import all the old stuff, it'll be a new Admin user when done that you'll need to log into to use all the old stuff.


    I'd leave the admin account you just made for emergency use.

  • BDAqua Level 10 Level 10 (121,185 points)

    No apologies beeded!


    So, have you used Migration Assistant yet?

  • pymason Level 1 Level 1 (0 points)

    Hi BDAqua, thanks for the info about importing my old stuff. Makes sense...


    Regarding Migration Assistant - I've looked for it among my files, thinking it would ship with the OS (old or new install), but couldn't find any trace of it...??? That puzzled me a little bit, because I know I've used it before on previous migrations...


    Do you know how I could find it, or get hold of a copy?



    Regards, P Mason...

  • BDAqua Level 10 Level 10 (121,185 points)

    Have  you looked in Applications>Utilities for it?

Previous 1 2 3 Next