Previous 1 2 Next 15 Replies Latest reply: Aug 11, 2013 10:13 AM by J Miller1
J Miller1 Level 1 Level 1 (10 points)

When mounting drives from other computers and external hard drives on my home network, the names of the drives mount incorrectly.  They show as older drive names, which I no longer use.

 

For instance, from my iMac I can access my Mac Book Pro, the MBPs external drive is named "Drive Alpha", but it mounts to the iMac as "Drive Bravo" sinced it used to be call that.  I recently renamed it Drive Alpha from Drive Bravo.  How can I have the drive so it mounts as "Drive Alpha"?  I have multiple drives Alpha - Delta.

 

I have looked for solutions to this including rebuilding drive directories, running scripts, removing the drives from the /Volumes folder manually, but none have worked.

  • Linc Davis Level 10 Level 10 (146,960 points)

    Triple-click anywhere in the line below on this page to select it:

    { diskutil list; echo; diskutil cs list; } | open -f -a TextEdit

      

    Copy the selected text to the Clipboard (command-C).

     

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    Paste into the Terminal window (command-V).

      

    A TextEdit window will open with the output of the command. If the command produced no output, the window will be empty. Post the contents of the TextEdit window (not the Terminal window), if any — the text, please, not a screenshot. The title of the window doesn't matter, and you don't need to post that.

  • J Miller1 Level 1 Level 1 (10 points)

    /dev/disk0

       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:      GUID_partition_scheme                        *1.0 TB     disk0

       1:                        EFI                         209.7 MB   disk0s1

       2:                  Apple_HFS Desktop HD              999.3 GB   disk0s2

       3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

    /dev/disk1

       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:      GUID_partition_scheme                        *2.0 TB     disk1

       1:                        EFI                         209.7 MB   disk1s1

       2:                  Apple_HFS NED                     1.0 TB     disk1s2

       3:                  Apple_HFS 3AM Backup              999.5 GB   disk1s3

     

    No CoreStorage logical volume groups found

     

    "Desktop HD" is the drive in question.  When accesed from other computers it mounts with different names.  "NED" and "3AM"  are external and seem to mount correctly.

  • Linc Davis Level 10 Level 10 (146,960 points)

    The only way I know of that a sharepoint could be mounted under a modified name would be that you created an fstab entry or otherwise altered the default mount map on the client. Is there a file at /etc/fstab on the clients?

  • J Miller1 Level 1 Level 1 (10 points)

    I do not even know what those items are.  But will do some research to see if something was changed.

  • Linc Davis Level 10 Level 10 (146,960 points)

    Please post the output of the following command on one of the clients:

    df -l | open -f -a TextEdit

  • J Miller1 Level 1 Level 1 (10 points)
    Filesystem   512-blocks   Used  Available Capacity   iused ifree %iused  Mounted on
    /dev/disk0s2 1951845952  191843800 175949015210%  24044473 219936269   10%   /
    /dev/disk1s3 1952191032 1599219848  35297118482% 199902479  44121398   82%   /Volumes/3AM Backup
    /dev/disk1s2 1953904168  199892992 175401117611%  24986622 219251397   10%   /Volumes/NED
  • J Miller1 Level 1 Level 1 (10 points)

    3AM and NED are one 2TB partitioned.  3AM is for Time Machine and NED is just regular storage.

  • Linc Davis Level 10 Level 10 (146,960 points)

    Sorry, that was the wrong command. It should be this:

     

    df -T afpfs | open -f -a TextEdit

     

    And it has to be run on the filesharing client, not the server.

  • J Miller1 Level 1 Level 1 (10 points)

    This turned up a blank text field.  Run on the client, ie the desktop I am trying to mount or the laptop?

  • Linc Davis Level 10 Level 10 (146,960 points)

    The client. The share must be mounted in order for the command to produce output.

  • J Miller1 Level 1 Level 1 (10 points)

    OK, so this is from the laptop, trying to mount the drives on the iMac.  The drives are "NED" (external) and "Desktop HD" the main iMac hard drive.  You can see in this that "Desktop HD" is mounting incorrectly as "DUSTY".

     

    Filesystem                          512-blocks  Used  Available Capacity  Mounted on
    afp_1d1tNe1b5wVt3Z5dW81jdwoT-1.2d000003 1951845952 192364240 175948171210%/Volumes/DUSTY
    afp_1d1tNe1b5wVt3Z5dW81jdwoT-2.2d000004 1953904168 199893008 175401116011%/Volumes/NED

     

    DUSTY is an old drive name I once used.

     

    Now, when I run the same on the iMac, mounting the laptop's hard drive "Laptop HD", it also shows as "DUSTY"

     

    Filesystem                                      512-blocks  Used Available Capacity  iused   ifree %iused  Mounted on
    //J%20Miller@MacLaptop._afpovertcp._tcp.local/DUSTY  233769824 157345904  7642392068% 19668236 9552990   67%   /Volumes/DUSTY

     

     

    So the issue is that there is no "DUSTY" any longer, but both primary computer harddrives mount on the other with that name.  This is the central issue.

  • Linc Davis Level 10 Level 10 (146,960 points)

    According to that output, you have a sharepoint named "DUSTY" exported by "MacLaptop." It's mounting on the iMac as "DUSTY," which is what it should do.

     

    You also have a sharepoint named "DUSTY" mounted on the laptop. It's exported by the same machine as "NED," so that must be the iMac. It's not the same as the other "DUSTY."

     

    You seem to be saying that you have no knowledge of either of these network volumes. It's not obvious how that can be possible, so what I suggest as a next step is to delete all the sharepoints on both machines and recreate them. See whether there's any change.

     

    If there is no change, please post the output of the following command on both machines:

    sudo sharing -l | open -f -a TextEdit

      

    You'll be prompted for your login password. Nothing will be displayed when you type it. If you don’t have a login password, you’ll need to set one before you can run the command. You may get a one-time warning not to screw up. Confirm. You don't need to post the warning.

       

    If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator. Log in as one and start over.

  • J Miller1 Level 1 Level 1 (10 points)

    I know the drives and their contents, the mount names are just incorrect, ie I have changed the drive names from "DUSTY" to "Desktop HD" and "Laptop HD".  You mention deleting the sharepoints and recreating them, how do I do so?

  • Linc Davis Level 10 Level 10 (146,960 points)
Previous 1 2 Next