Skip navigation

Wi-fi off and will not turn on - MacBook

24494 Views 48 Replies Latest reply: Mar 31, 2014 11:30 AM by pnju RSS
1 2 3 4 Previous Next
Patricia Henwood Level 3 Level 3 (925 points)
Currently Being Moderated
Aug 5, 2013 11:43 PM

I have a MacBook aluminum unibody (late 2008) with OS 10.7.5.  This morning when I turned it on,  the wifi icon in the Menu bar was 'empty' (i.e. no bars) - clicking on the icon gave me the info that 'wifi is off' - I clicked 'turn wifi on'- nothing happened.  I opened System Preferences - Network.  Status showed Wi-Fi is off.  I clicked on the 'turn wifi on' button - nothing happened.  I restarted the MacBook - repeated the above steps - six times now - always the same result :-(

 

Can anyone suggest some other trouble shooting steps to take?

 

I've also unplugged and re-started the modem/router.  AIl other devices in the house can connect to the network without any problems - my MacBook is the only device having problems!

 

Cheers,

Tricia

MacBook (13-inch Aluminum Late 2008), Mac OS X (10.7.5)
  • Bob Timmons Level 9 Level 9 (75,400 points)
    Currently Being Moderated
    Aug 6, 2013 6:39 AM (in response to Patricia Henwood)

    I had the same symptoms on my early 2008 MacBook Pro.

     

    The "fix" was a new internal wireless card. That is a job for a service shop.

     

    You might want to follow this post to see if there might be a miracle cure, though:

     

                     Re: No airport card installed            

  • Bob Timmons Level 9 Level 9 (75,400 points)
    Currently Being Moderated
    Aug 6, 2013 7:17 AM (in response to Patricia Henwood)

    About $175 as I recall....mostly labor.

     

    Hopefully, the wireless card will hold on a bit longer.

  • AtlantaElise Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 2, 2013 3:08 PM (in response to Patricia Henwood)

    I just had this similar problem happen to me! Although you have probably resolved your issue by now, this is what I ended up doing to fix it.

    1. Go to System Preferences and open 'Network' - or click your wifi triangle along the top tool bar and select 'open network preferences'.

    2. Click your wifi on the left hand side from the list, and then click the small cog at the bottom of that box, and click 'Make Service Inactive'.

    3. Once you've done that, click the minus to delete your wifi as an option from this box.

    4. APPLY!!

     

    All other instructions I read said to click the plus and add your wifi again and then restart. Well that did nothing for me, infact it did nothing about 7 or 8 times, soooooo...

     

    5. Restart your computer now, without any wifi configuration setup.

    6. Once restarted, go back into system preferences, into network, and use the + button to add a wifi connection back into your computer.  With any luck, you will be able to click on 'Turn wifi on' and it will actually work!

  • ChrisZam Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2013 11:07 AM (in response to AtlantaElise)

    Hi,

     

    I had the same problem as Tricia and took your advice, only I am unable to figure out how to add a wifi network. The list does not give me a wifi option when I press the add sign. Suggestions, Elise?

     

    Best,

    Chris

  • Smokeyp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2013 12:39 PM (in response to AtlantaElise)

    i was having same issue today (first time ever happened)and tried your tip and after restarting it worked.thanks

  • Smokeyp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2013 12:43 PM (in response to ChrisZam)

    once you hit the plus u should see select interface and name for new service and beside iterface it shows bluetooth pan.dont know if u tried or not but click little arrows on bluetooth pan and wireless option is there.if u just mean its not showing up after doing this sorry fo not helping

  • Greg Beaton Level 1 Level 1 (35 points)
    Currently Being Moderated
    Oct 3, 2013 6:49 PM (in response to AtlantaElise)

    Thank you Elise! This solved my problem

  • AtlantaElise Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 3, 2013 9:43 PM (in response to ChrisZam)

    Hi Chris,

     

    Sorry I don't have any suggestions! I'm so technologically challenged I'm surprised I was able to fix my own let alone actually help some other people! Maybe a call to Apple might be in order?

     

    Sorry again!

     

    Elise

  • AtlantaElise Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 3, 2013 9:48 PM (in response to Patricia Henwood)

    Good to hear Patricia! Mine did the same thing the next day so I'm hoping this isn't going to become a regular occurrence... My MacBook is also one of the first released unibodies and is still pushing on like a trooper so I have no doubts that mine cracks it every now and again purely because it's old!

  • alexinfla Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 6, 2013 5:27 AM (in response to AtlantaElise)

    Thank you, Elise! Your suggestion worked for me! I'm thinking I need to do as Tricia did and upgrade memory (I still have the original 2GB) as well as keeping a watchful eye on my wireless card ...

     

    All the best ... -alex

  • DavidinWilliamsburg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 6, 2013 8:53 AM (in response to AtlantaElise)

    Dear AtlantaElise,

       Many thanks for posting - your solution worked perfectly for me... I was fearing the need to replace

    my Airport Exterme card. Now all is well again!

      cheers,

        David

  • alexinfla Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 6, 2013 10:01 AM (in response to AtlantaElise)

    I wrote too soon ... Shut down the bitbox to attend to a few honey-do projects and when I powered back up the wi-fi was off again. Elise's procedure brought it back online (great relief).

     

    A trip to a fix-it shop is on my short list for the first of the week to check configuration and (probably) install a new wireless gizmo. I don't want to push my luck.

     

    Thanks to Tricia for posting the question originally, to Bob for his hardware answer and to Elise for a great temporary work-around.

     

    -alex

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.