2 Replies Latest reply: Jan 27, 2014 1:51 PM by AppleNathanj
Drather Knott Level 1 Level 1 (0 points)

I just set up a new workspace, running my MBA in clamshell mode on a Sylvania tv.  All worked well.  I had everything hooked up, and when I closed my MBA the external monitor would go blue, then come back with my desktop.  I made a lovely stand for the closed MBA from a cardboard whiskey bottle tube, and everything looks good and runs perfectly.

 

At some point today, I went into System Prefs and played with the resolution and arrangement of the external monitor.  (I learned that the monitor only supports 480i, 480p, 720p and 1080i.  Not any of the 'number x number' resolutions.  When I changed it to the 1024 x 768 res, e.g., the external monitor when dark, thought for a moment, and let me know it was unhappy: "Format Not Supported".  Just experimenting to see what things do.)  Then I stopped playing with the system prefs.  I exited clamshell mode and did other things with my day.  But when I returned and tried to get to work using this same arrangement, things didn't go so smoothly.

 

Now I can use the Sylvania tv just fine as an additional or mirrored monitor.  But when I attempt to enter clamshell mode by closing the MBA, instead of returning to my desktop after turning blue, the external monitor tells me "Format not supported."  But I can open the MBA back up and the desktop comes right back!  So *something* has changed, but I don't really have a clue what it is. And it's driving me nuts!

 

I've followed all of the basics for clamshell mode: power, mouse and keyboard.  The external display is clearly connected and working because it behaves as expected up until the MBA lid is closed.  And the MBA is in clamshell mode once it's closed -- even though the image isn't displaying on the external monitor.  All I can think of is that somehow the resolution settings for the external monitor change to what's set for the MBA screen when I close the lid.

 

I've restarted.  I've shut down and rebooted.  I've reset the NVRAM.  I've reset the SMC.

 

I don't know what else to try. Any suggestions?

 

This really shouldn't interfere with my work, because I can just leave the MBA open and turn the brightness down all the way.  But that lacks elegance!  Plus I have this nifty whiskey-tube stand going to waste.  Please help!


MacBook Air (11-inch Mid 2011), Mac OS X (10.7.5)
  • Drather Knott Level 1 Level 1 (0 points)

    After much monkeying around, I got this solved. For now. We'll see if it stays solved tomorrow. I'm not going to exit clamshell mode until absolutely necessary in case it's such a pain next time.  I notice lots of my mac brothers and sisters had similar problems, so I'll note how I got it to work in case it helps anyone else. Or to remind myself in case I forget.

     

    Basically I solved the problem thusly:

    1. Set everything up for using the external display

    2. Set the external display as the main monitor in the "arrangement" tab in sys pref (if you don't have mirroring turned off, you'll have to do that first)

    3. Have only the resolution selection window open on the external display

    4. Cleverly hover the mouse over a display resolution that you know works, then lift it from the desktop to keep it there

    5. Close the laptop -- the external display goes blue, then claims to not know how display the format from the MBA

    6. Click with the mouse on where you know the functioning resolution is. Hit enter to apply the new resolution (blindly).

    7. Click a few more times, randomly, for good measure.

    8. When the external screen comes back to life and clamshell mode is working again, stop drinking to drown sorrows, and start drinking to celebrate!

  • AppleNathanj Level 1 Level 1 (0 points)

    This worked!

    I didn't give it enough time to work at first, I ended up searching for like another hour on other forums, and came back to this. It works, you just have to wait for a couple seconds after you choose the resolution for the screen to respond, don't me impatient!

    Thank You So Much!!!!!!

    Tons of people have the same problem and I hope they all ended up here too.

    (Another forum said paid apple support didn't know how to solve this.)