1 Reply Latest reply: Aug 6, 2013 11:29 AM by MrHoffman
Lyn Janosik Level 1 Level 1 (0 points)

In sending an email with an attachment I received this message:  "Cannot send message using the server road runner. The server ""smtp-server.wi.rr.com"" refused to allow a connection on the default ports."

How do I fix this so I can send emails? I receive emails just fine.


MacBook Pro, Mac OS X (10.6.8)
  • MrHoffman Level 6 Level 6 (13,255 points)

    Mail has two parts, the sending and receiving paths.  You have the receive path working (POP, apparently), and problems with the sending (SMTP) path, and your provider doesn't appear overly fond of documenting the generic requirements for the POP/IMAP and SMTP details for mail clients.

     

    It appears that your ISP requires you to configure the sending path to use TCP port 25 (with SSL disabled?), which is an unusual and problematic choice; that port is commonly blocked outbound by various other networks, though your provider's available documentation is lacking.  Here is some more detail from another part of your ISP's web site (indicating there's no security?) on these ports.

     

    Based on what's posted and if you're not on your local ISP's network, then you may have issues reaching your email provider's servers.  It's common practice to block outbound connections to port 25 on a number of networks.

     

    To get to the SMTP server (outbound) configuration in Apple Mail.app, select Mail > Preferences > Accounts and then select the associated account, and switch the Select Outgoing SMTP Server to its Edit SMTP Server setting, then select the matching SMTP server for your ISP, then turn off SSL security, and switch to port 25.

     

    After you get this working and strictly as a test, I'd also see if SSL can be enabled, and still allow a connection.  (This to determine if the ISP's documentation is incorrect or outdated, and if security can be enabled.)

     

    FWIW, I'd make very certain you never re-use the password that's set with your ISP's email password anywhere else; not having SSL enabled on both the sending or the receive path means that your credentials are transmitted in cleartext.