6 Replies Latest reply: Nov 25, 2013 5:12 AM by middlefromnc
tech-itunes-MDS Level 1 Level 1 (10 points)

Some Background:

 

There was some serious confusion last year as the school started setting up iPads using Configurator. For some reason the ipad person then used their personal iTunes AppleID to download the apps - the paid ones are the only ones i'm having problems with.

 

their personal AppleID was NOT used to purchase the apps - but a second one.

 

This year we switch the machine to using an institutional AppleID - have purchased additional codes using the correct VPP account. Successfully imported the codes into Apple Configurator.

 

When trying to push the app onto the ipads, I'm getting a error code #36 - "Unable to redeem code for XXXX. Sign in with your [?] and password or create a new Apple ID to redeem your Gift Certificate or Prepaid Card."

 

I went so far as to unsupervise a device and start from scratch - same issue.

 

iTunes **IS** authorized for the institutional account.

 

SO.....

 

  1. is is possible that the codes are tied into the personal VPP account used for part of last year?
  2. Really - we could have codes tied to TWO AppleIDs?
  3. Can iTunes be authorized for two different AppleIDs?
  4. anyone know of any way to resolve this situation?

 

 

 

Sigh...........


iPad 2, iOS 6.1.3
  • imhm Level 1 Level 1 (0 points)

    We are having the same problem. However, how did you get the VPP itunes account to be authorized?

  • tech-itunes-MDS Level 1 Level 1 (10 points)

    In iTunes there's a menu item to 'authorize this computer'. that's where you put the VPP account AppleID in.

     

    We have one AppleID for paid apps, and one for freebies and iTunes. That protects the credit card from....ah....overuse.

  • cherybeth Level 1 Level 1 (0 points)

    I was under the impression that you could not use the VPP account in iTunes, but had to have a separate apple ID to tie iTunes and Configurator together. The VPP account was specifically for purchasing the codes.

     

    We have having identical problems with our VPP codes. When I unsupervise an iPad not all of the codes are not being 'checked back in'. Then when we try to push them out we get the error 36 message.

     

    At this point I will only install FREE apps. It has been too costly of a learning curve these past couple of years.

  • Mark Hasd Level 1 Level 1 (0 points)

    I had this same issue just now, after configurator had been open for a number of hours.  I closed configurator and reopened it and tried again.  It popped up a prompt for the password of the Apple ID and after entering it, it allowed the apps to be installed.  My guess is that it has something to do with the account authorization timing out and you aren't being prompted for the password.

  • mvest20 Level 1 Level 1 (115 points)

    I'll attempt to answer the questions that you posed in the OP and also explain what I have discovered as a workaround (albeit a very annoying one) for the issue.

     

    1.  It is entirely possible that the VPP codes are tied to the older, personal VPP account.  VPP codes do not have to be downloaded by the same account that they are purchased with, in fact, in my experience, you cannot create an Apple ID for use in the iTunes Store with the account that you use to purchase VPP codes.

    2.  You also could have codes associated with two Apple ID's, though again, I have never been able to use an Apple ID it iTunes that I used to purchase VPP codes.

    3.  iTunes can be authorized by multiple Apple ID's.  I assume that there is an upper limit to the number of accounts that can be authorized on a single library, but I do no know what that number is.

    4.  There is no way to truly "resolve" this situation.  One of the major problems with the Apple ID system is that there is no way to transfer purchases between Apple ID's.  That being said, if the old VPP codes have already been used, be advised that you never actually have those codes opened back up, as they have already been redeemed in the store.  You will simply have additional licenses of an app available through Configurator to install to devices.

     

    As far as the issue described, I too ran into the problem of getting the error code 36.  I discovered that before I deploy paid apps, if I open iTunes (with Configurator closed) and choose "Authorize this Computer" from the Store menu, I can re-authorize the system (I get a message stating that the computer has already been authorized.)  Once that is complete, I open Configurator and start a deployment, and once I start that Configurator will prompt me for the Apple ID password to complete the app deployment.  The really unfortunate part of the process is that I have to perform this process every single time I start a new deployment of paid apps, even if no changes have been made in Configurator between installations.  It appears to me that plist is not getting updated, but I am not familiar enough with Configurator to confirm this is the case.  It is certainly annoying, but this workaround is at least allowing me to get devices deployed.

  • middlefromnc Level 1 Level 1 (0 points)

    I've had many of these issues with the VPP as well, it has been a thorn in my side all semester.  I followed the directions on this support site (http://support.apple.com/kb/ht5188) to the letter and would be able to get one or two apps loaded before it stopped working.  We have 10 iPads available for teacher checkout that I was loading individually at the time.  I realized that I had to restart my computer every time I wanted to put apps purchased through the VPP onto an iPad.  It worked then.

     

     

    We also have 120 iPads on four carts, I haven't tried loading paid apps onto them recently so I'm not sure if restarting the computer would allow me to push paid apps to all 30 iPads on a cart at one time or not.  Being able to get two paid apps onto each of the teacher iPads made me want to do backflips through the hallways!