7 Replies Latest reply: Jan 3, 2015 12:22 AM by manjula90
worldgeoworld Level 1 Level 1

hi, I've been trying to figure this one out. when i type a song in the itunes search feature it shows up as usual but when i click it so it'll play nothing happens. I tried uninstalling and reinstalling itunes. previous versions allowed users to play songs directly from the search feature just by clicking on it once it appears on the the results right? but the recent updates including the newest one Itunes 11.0.4.4 don't, at least for my case.  i was on itunes 11.0 i think, then i updated it last night hoping it will fix it but it didn't. i still need to manually search for a song by scrolling up and down on my library instead of just typing the song title on the search bar then clicking on it to play. AND the weird thing is sometimes it works, but there's like a one in a million odd that it will. sometimes i had to do something with itunes like changing the page orientation through page set up, removing the arrow on the "search entire library" in the search feature then it will magically work but most of the time it doesn't. i'm on windows vista starter. hoping to get some help on this. thanks!

  • imeron27 Level 1 Level 1

    I have this same problem, however, my search feature consistently works as long as I do not input more than one character. For example: if I search for "ani" it finds Ani Difranco but I won't be able to click any of the search results. If I search for "a" I will receive search results that are clickable. I am also running the latest iTunes version and cannot resolve this issue.

  • EdgarGz Level 1 Level 1

    I'm also having the same issue with my iTunes. If anyone has a solution to this it'll be very helpful, thank you.

  • bazero Level 1 Level 1

    I also have this problem. Can anyone please advise me how to fix it? Thanks!

  • hdgslgfef Level 1 Level 1

    There should be a magnifying glass at the start of he search bar, click on this and un tick the search entire library option this should work,hope this helps

  • Airion Level 1 Level 1

    Thanks so much hdgslgfef!

  • worldgeoworld Level 1 Level 1

    Sorry everyone for the very late reply i was very busy. anyway after updating to a newer version of itunes, the problem went away. it was probably an application glitch? i'm not sure but it has been working well for me for probably over 3 months now? and the magnifying thing didn't worked out the way i wanted it to, only updating to a newer version did.

  • manjula90 Level 1 Level 1

    I had the same problem. No matter how many updates I installed this problem never went away. The only solution everyone provided was to untick the search entire library option. I just found a simple solution to it today. After searching a song, use the down arrow and the search songs/results get highlighted. After that you can click on anything with your mouse.