3 Replies Latest reply: Aug 14, 2013 6:14 PM by Linc Davis
zacharyfunk Level 1 Level 1

Not loading webpages a lot of the time and not loading images on sites such as Facebook, Twitter, etc. I'm new to Mac and I'm running Safari on a Mac Mini. Help? Also deleted ~/Libraries/Safari and it didn't work.

Mac mini, OS X Mountain Lion (10.8.4)
  • Carolyn Samit Level 10 Level 10

    If you see Develop in the Safari menu bar click Develop > Disable Images


    That should un ✔. If you don't see Develop in menu, ignore this part.



    Try emptying the Safari cache. Command + Option + E. Quit and relaunch Safari to test.



    If that doesn't help, try troubleshooting Safari extensions and plugins.



    From your Safari menu bar click Safari > Preferences then select the Extensions tab. Turn that off if there are any installed. Quit and relaunch Safari to test. If that helped, turn extensions back on then uninstall one a time to test.


    If it's not an extensions issue, try troubleshooting third party plug-ins.


    Back to Safari > Preferences. This time select the Security tab. Deselect:  Allow all other plug-ins. Quit and relaunch Safari to test.


    If that made a difference, instructions for troubleshooting plugins here.




    message edited by:  cs

  • zacharyfunk Level 1 Level 1

    Absolutely none of that did anything to help.

  • Linc Davis Level 10 Level 10

    Please answer as many of the following questions as you can.

    1. Have you restarted your router and broadband modem since you first noticed the problem? If the answer is no, do that now and see whether there's any change.

    2. Are any other web browsers installed, and are they also slow?

    3. What about other Internet applications, such as iTunes and the App Store?

    4. Are there any other devices on the same network that can browse the Web, and are they also slow?

    5. If you can test Safari on another network, is it slow there too?

    6. If you connect to your router with Wi-Fi and you can also connect with Ethernet, do that and turn off Wi-Fi. Any difference?