7 Replies Latest reply: Feb 2, 2014 6:00 AM by kevlam3
ILaux Level 1 Level 1

Hello people.


I have a problem and i wish if you could help me with.


I have an iMac Early-2009 ( 2.66ghz C2D / 4GB 1333mhz RAM / GeForce 9400 256mb ) with Mountain Lion 10.8.4


The problem is that, i can't install the drivers from the bootcamp app ( the one from the bootcamp itself app, where you need a USB to download it)

i've already partitioned the HDD, and installed succesfully a Windows 7 Ultimate 64bit.


But there's one little issue, when i try install the drivers i downloaded before on my USB, it says that "Bootcamp x64 is unsupported on this computer model".


BUT, what? i've installed correctly the Windows 7 64bit on the iMac.


I can't install anything, but only graphics driver. ( manually)


I searched in every forum trying to resolve my problem, i've read that you can install it from de DVD with Snow Leopard that came with the computer

but that disk is broken; it's annoying because it seems that is the only solution , with that resulting on a dead end.


I could install my NVIDIA drivers, using the ones from bootcamp drivers, BUT USING THE WIN_32 version because the WIN_64 was unsupported by my machine. ok, i could install the drivers and was the 263.03 i think.

Now i want to upgrade to my lastest drivers ( 320.14 WQHL ) and says that can't detect my gpu. but the old driver that came with recognized it with no problems. I tried also auto detect GPU, and the same drivers but no result.


Anyway, the main problem is that is "Bootcamp x64 is unsupported on this computer model". with a Windows 7 64bit copy installed on the bootcamp partition. this is ******* me off


I sucessfully installed on my Macbook Pro Late 2008 ( C2D 2.06ghz / 8 GB RAM / 9600m GT ) and everything fine, a Windows 7 64bit. installed the drivers and everything fine, even accepted the lastest drivers (320.14 WQHL) from nvidia. but that was on Mountain Lion 10.8


but since 10.8.3 only lets you install only 64bit, i can't search for a copy of win32bit and install it because, it's going to be the same problem anyways.


So if you could help me out with this *** problem.

iMac, OS X Mountain Lion (10.8.4), bootcamp
  • Literatus Level 1 Level 1

    I have an iMac (24-inch, Early 2008) — iMac8,1 and I have exactly the same issue.  Now, I'm running Mavericks, unfortunately.


    On the one hand, from http://support.apple.com/kb/HT3986, I see:


    "Do all Intel-based Macs support Windows 7?

    All Intel-based Macs support Windows 7 using Boot Camp 3.1 or later except these:

    • iMac (17-inch, Early 2006)
    • iMac (17-inch, Late 2006)
    • iMac (20-inch, Early 2006)
    • iMac (20-inch, Late 2006)
    • MacBook Pro (15-inch, Early 2006)
    • MacBook Pro (17-inch, Late 2006)
    • MacBook Pro (15-inch, Late 2006)
    • MacBook Pro (17-inch, Early 2006)
    • Mac Pro (Mid 2006, Intel Xeon Dual-core 2.66GHz or 3GHz)"


    So, I should be good.



    However, from http://support.apple.com/kb/HT5634, my iMac is not supported in Boot Camp requirements, which would have been nice to know before I purchased a copy of Windows 7.  I cannot get the Windows drivers to download from Boot Camp, and when I download them manually, whether version 4 or 5, I get the "Bootcamp x64 is unsupported on this computer model" message, which makes the HT3986 information unhelpful.  I even tried a Snow Leopard CD while in Windows, and it gave me the same message.  I tried one of the 3.x Bootcamp files, and still no good.


    The funny thing is, I ran Bootcamp to create the partition for Windows 7, and it even popped up a message stating that Windows 7 was the latest Windows I could install on that machine, and the installation went fine.  However, I am missing who knows what drivers, etc, because Apple won't provide the Windows support software for a machine that evidently can run the software.  The graphics drivers appear to be fine, as the aspect ratio corrected itself, something that didn't happen on my MBP without having the Windows Bootcamp software.  I also have wi-fi, which is better than some experience.


    I even cannot get the little Boot Camp Windows icon/software that should be accessible in the system tray, so I can set preferred system to boot in, tell it to boot into OS X, etc.  So, for that, I would have to rely on rebooting while holding down the ALT key, and my non-Apple keyboard for some reason won't do that (but that's another subject).


    I guess there is nothing to do other than just do everything manually, piece by piece, unless someone has a solution that is eluding me.

  • Literatus Level 1 Level 1

    You are right about using a Snow Leopard DVD.


    http://michael.anastasiou.me/boot-camp-x64-is-unsupported-on-this-computer-model /


    This worked like a charm, but only since I had the disc. 

  • trmacbook Level 1 Level 1

    I am also having this issue. I am running Mavericks on a mid-late 2009 MacBook. After installing windows I inserted my original mac install disk and clicked "set-up." It asked if I wanted to install bootcamp on this computer and when I clicked "yes" it gave me the same message - "bootcamp x64 is unsupported on this computer model."


    Has anyone been able to resolve this issue?

  • t.moe Level 1 Level 1

    Check http://support.apple.com/kb/HT5634.


    Are you trying to install the 64-bit or 32-bit version of Windows?


    From the above article it appears that a mid-2009 MacBook will only support 32-bit Windows via BootCamp.  The late-2009 model will do both 64-bit and 32-bit, however.

  • t.moe Level 1 Level 1

    Also, note the link in Literatus's post for a workaround.

  • Griffter18 Level 1 Level 1

    See if anything in this thread is of use as the user was installing Win8 on an older MBP and found work arounds for Bootcamp & Drivers etc


  • kevlam3 Level 1 Level 1

    I had the same problem too with my Unibody Macbook late 2008 model with Windows 7 64bit.

    I tried troubleshooting compatibility and all that and it still wont run.


    The way i got around it was:

    1) Copy the BootCamp data onto my desktop

    2) to basically disable UAC (User Account Control) setting in control panel to "never notify" and make sure you are in administrator account, then restart windows.

    3) I then navigate BootCamp\Drivers\Apple\BootCamp.msi -> and run the installer. Voila! everything installs.


    BTW, I used Boot Camp 4 downloaded from Apple website. Not sure if it works running BootCamp from pendrive.


    Hope that helps