0 Replies Latest reply: Aug 15, 2013 4:58 PM by Harrisvillesat
Harrisvillesat Level 1 Level 1 (0 points)

I keep receiving an error message when trying to update my apps.   I am assuming this because I have a gen3 touch and I will need to purchase a new ipod if I want the newer versions - is this correct or does anyone have any other options?   Thanks


iPod touch, iOS 4.2, GEN3