9 Replies Latest reply: Aug 16, 2013 8:46 PM by sberman
lburech Level 1 Level 1 (0 points)

My wife and I each have iPhone 4s with different mobile numbers.  She has a MacBook Air and I have a MacBook Pro.  When I send an iMessage on my MacBook Pro to another with iMessaging, the message shows that it is from my wife, not me.  What do I need to do to correct this so the message reflects it is from me?


MacBook Pro, OS X Mountain Lion (10.8.2)
  • sberman Level 7 Level 7 (27,245 points)

    Open the Messages app on your Mac.  Open Preferences (under Messages in the menu bar), click the "Accounts" tab and set everything up using your information.

     

    Hopefully you and your wife each have separate Apple IDs.

  • lburech Level 1 Level 1 (0 points)

    We have the same apple ID.

  • sberman Level 7 Level 7 (27,245 points)

    Well, that's often a problem.

     

    Anyway, if you plan to keep it that way (which I would not recommend), just make sure that Apple ID does not appear anywhere in Messages Accounts under the possible identification methods.

  • lburech Level 1 Level 1 (0 points)

    I went to accounts in Messages under preferences but do not see my wife's name anywhere. 

     

    Screen Shot 2013-08-15 at 10.20.07 PM.png

     

     

    Yet in Messages it shows her as the sender with my picture.

     

    Screen Shot 2013-08-15 at 10.14.30 PM.png

  • sberman Level 7 Level 7 (27,245 points)

    Try this first:

     

    • Under Apple ID (in Accounts under Messages), click "Details...".  Change the first name shown there (from your wife's to yours).
    • You could also go to "Change My Picture ..." (under Messages in the menu bar) and change your photo there.

     

    If that doesn't work, consider this:

     

    In that "Accounts" screen shot, note you have a "mac.com" email checked and a "gmail.com" email checked.  You might consider unchecking both those to force your messages to only deal with your telephone number.

     

    UPDATE - Sorry, you said the picture is correct, so please ignore my "Change My Picture" suggestion above.

     

    Message was edited by: sberman

  • lburech Level 1 Level 1 (0 points)

    There is no "first name" when I click details under messages only the ID and password which leads to the account information that nowhere contains my wife's name.

    I need the gmail account (she has a separate one) when we screen share, which we do frequently from messages.  Of further interest on her MacBook Air Messages does not contain her name after the message, just her picture.  If I could do the same on my computer--eliminate her name after my picture and replace it with my picture, that would be great.  It looks like this now on my computer. (notice her name after the messaes in the blue bubble.

     

    Screen Shot 2013-08-15 at 10.15.21 PM.png

  • sberman Level 7 Level 7 (27,245 points)

    lburech wrote:

     

    If I could do the same on my computer--eliminate her name after my picture and replace it with my picture, that would be great.

    You can do that in the Messages app by doing View > Messages > [set the appropriate option(s)].

  • lburech Level 1 Level 1 (0 points)

    When I go to View>Messages>show names it shows my wife's name.  If I select show picture it changes it to my picture.  If I choose names and pictures it keeps my picture and shows the name of the person I am messaging with.  The picture of me is not one that I have in my address book but one I have in my Preferences>Messages in the Message app.  I can't seem, however to find any place where I might have my wife's name, so that it would show up when I select View>Messages>show names.  Anyway, eliminating her name and replacing it with my picture was a big help.

  • sberman Level 7 Level 7 (27,245 points)

    What happens if in Messages you go to Buddies > Show Info > Address Card and Buddies > Show Info > Profile?  Does that help unfurl the mystery a bit further?