Previous 1 2 3 Next 171 Replies Latest reply: Apr 18, 2016 8:59 AM by Ktimilsina Branched to a new discussion.
TnD1w Level 1 Level 1

Just wanted to share a solution to my charging problem.  Very quickly my phone developed a problem where I couldn't get it to charge.  The connector didn't feel sloppy, but if I twisted it to the side, I could get it to make a connection.  However, if I let go or bumped the phone it would immediatly disconnect.  Sometimes it would take a easy dozen tries to get the phone to establish a connection.  Often I'd come back only to find that it had lost the connection and stopped charging.  Took it to the Verizon store and it worked fine on their cords.  Could be the cord, but I have multiple cords stashed in different locations and they all went bad at the same time.  That suggests to me that it's the phone and not the cord.  I tried to fish for some lint in the port and that definetly seems to be part of the problem.  I used a bent paperclip with no ill effects, but I'd be more comfortable with a flat toothpick.  Just stay away from the sides of the port as I don't know how fragile the connection wires are.  In my case, I was going for the bottom of the port.  Reach into the port and try to scrape out any packed in lint from the back of the port.  I'm thinking the lint may prevent the plug from fully seating thus creating a poor connection.  This helped a fair amount, but the connection still needed improvement.  Last night I bought a can of electrical contact cleaner and thought I'd give it a try.  I'd admit that I was a bit nervous to spray this into my phone, but I needed to try something.  Using the included tube, I sprayed a tiny amount of cleaner into the port.  The cleaner will get outside the port, but I don't see any signs of damage to the Belkin case, phone body, screen or disposable screen protector.  While the port was still wet, I grabbed a cord and plugged it in several times hoping to agitate the solution and mechanically clean the connection.  A mini q-tip would work even better.  Instantly I found a signficantly improved connection.  Plug it in and boom, good connection.  First try every time.  No wiggling necessary.  I did this last night at home and I just plugged the phone in at work; again got a good connection.  Now, I only tried this last night, but it certainly looks like the problem is dirt, grime and maybe a touch of corrosion that's causing the problem.  Clean the port out to remove any debris and then apply a quick shot of contact cleaner and you should be good to go!

Reply by C_GREC on Jan 16, 2014 5:06 PM Helpful
Thank you so much !! i have been having a problem charging my phone for tha last few weeks and this worked like a charm i took out almost a half cap full of dust and muck.
Reply by scsmith631 on Jan 17, 2014 5:56 AM Helpful
After 16 months I too was having issues with the cable and purchased another and still had the same issue.  The cable is a little loose in the connector when it is working and I discovered that moving it to the left or right will show charging or not.  After reading this I cleaned out the port several times and discovered a pile of lint about the size of half a dime in there!  All is well now and I have a spare cable to keep in the car.
Reply by wegras on Aug 16, 2013 6:58 AM Helpful
I also regularly use an air duster spray can ,no moisture but it keeps the ports clear of debris that inevitably seems to collect Not sure I would risk a liquid spray but has worked for you

All replies

Previous 1 2 3 Next