10 Replies Latest reply: Aug 20, 2013 4:19 PM by BPWMorro
jonezee Level 1 Level 1 (0 points)

I have a new Panasonic TZ30 camera and I find that although I can transfer my still photos on to my iMac  with iphoto version '09 my movies will not. I used to be able to transfer them all from my TZ5. Can anyone tell me why this is and is there a way to work around it?


Mac OS X (10.5.8), Leopard
  • BPWMorro Level 1 Level 1 (70 points)

    jonezee,

    please (1) add the recording format for the TZ30 -- avchd (and detail) or mp4 --

         (2) identify your version of iPhoto -- is it 9.4.3?

    I have, almost overnight, also started having problems importing avchd format movies .... 

  • jonezee Level 1 Level 1 (0 points)

    Yes the format is avchd and the iPhoto version is 8.1.2

  • BPWMorro Level 1 Level 1 (70 points)

    I suspect your problem is the older OS and iPhoto -- but I do not know -- hopefully some of the more expert users (Terrence, Old Toad, Larry) will join in and make suggestions. Many of them are in Europe -- wait until tomorrow before you do anything so they can perhaps offer suggestions. (But I still can't get my avchd in iPhoto 9.4.3, either...)

  • jonezee Level 1 Level 1 (0 points)

    Thanks for the comments and for taking an interest.

  • BPWMorro Level 1 Level 1 (70 points)

    You're welcome. I have been amazed at the help the others have provided in the past.

    I forgot -- do not format/erase your cards. Try to use other cards and keep these safe so you can still get the movies. And, I have set my cameras back to MP4 format for now....

  • Old Toad Level 10 Level 10 (125,490 points)

    You need iPhoto 9.3 or later: Using AVCHD video with iPhoto '11 and Lion 10.7.4 or later.

     

    iPhoto 9.3

     

     

     

    OT

  • BPWMorro Level 1 Level 1 (70 points)

    Joneze,

         Your 8.1.2 probably isn't going to do it, based upon the KB Old Toad has found ... but, try changing to MP4 format first, as a test, and see if it works....that, at least, would allow you to further postpone the decision to upgrade software (although, I always recommend updates -- a few days after they are issued -- and OS upgrades (like to OS 10.8) a few weeks after issued).

     

    Old Toad,

         Great to hear from you again and thanks for linking to the KB -- I am curious, however, why my MBProRet has decided, seemingly overnight, not to import direct thru iPhoto when it used to....I don't recall any iPhoto updates in the past few days....I suppose the answer is simply "some things are not to be known," right? Hopefully it will straighten out.

  • Old Toad Level 10 Level 10 (125,490 points)

    Could be a number if small issues. One could be a damaged preference file or cache. Try the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/com.apple.iPhoto folder (Snow Leopard and Earlier).

     

    home.PNG

     

    or with Lion and Mt. Lion from the User/Library/Containers/com.apple.iPhoto/
    Data/Library/Caches/com.apple.iPhoto
    folder

     

    iP11mtlioncache.png

     

    3 - launch iPhoto and try again.

     

    NOTE 1: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

     

    Another could be issues with overall system preferences.  Run Disk Utility and repair disk permissions.  Also boot into another user account on your Mac and see if iPhoto can import from there.  If it can then there's something in your account that's awry.

  • jonezee Level 1 Level 1 (0 points)

    I have tried all the suggestions. Though I found it a litle complicated. The best result has been format MP4 [HD} This seems to be working for me. Many thanks.

  • BPWMorro Level 1 Level 1 (70 points)

    Old Toad,

        Thanks for the "cure," I have kept.

         It worked....

              except.....

        (1) I had to take a photograph first on the newly formatted card, before recording an AVCHD movie (I saw somewhere else that might be required, in order to create the proper receptacle folder on the card; its a Sony camera), and

       (2) while the jpg recorded with the proper time in metadata, the video is one hour off -- I guess that gremlin doesn't realize we don't do daylight savings in Arizona...or else he's Hopi, 'cause they do have it....or... that doesn't matter; I'll just say "

                Thanks, Again, for your help!"