Skip navigation

Transfering movies from camera

375 Views 10 Replies Latest reply: Aug 20, 2013 4:19 PM by BPWMorro RSS
jonezee Calculating status...
Currently Being Moderated
Aug 17, 2013 4:24 PM

I have a new Panasonic TZ30 camera and I find that although I can transfer my still photos on to my iMac  with iphoto version '09 my movies will not. I used to be able to transfer them all from my TZ5. Can anyone tell me why this is and is there a way to work around it?

Mac OS X (10.5.8), Leopard
  • BPWMorro Level 1 Level 1 (70 points)
    Currently Being Moderated
    Aug 17, 2013 4:32 PM (in response to jonezee)


    please (1) add the recording format for the TZ30 -- avchd (and detail) or mp4 --

         (2) identify your version of iPhoto -- is it 9.4.3?

    I have, almost overnight, also started having problems importing avchd format movies .... 

  • BPWMorro Level 1 Level 1 (70 points)
    Currently Being Moderated
    Aug 17, 2013 4:47 PM (in response to jonezee)

    I suspect your problem is the older OS and iPhoto -- but I do not know -- hopefully some of the more expert users (Terrence, Old Toad, Larry) will join in and make suggestions. Many of them are in Europe -- wait until tomorrow before you do anything so they can perhaps offer suggestions. (But I still can't get my avchd in iPhoto 9.4.3, either...)

  • BPWMorro Level 1 Level 1 (70 points)
    Currently Being Moderated
    Aug 17, 2013 5:21 PM (in response to jonezee)

    You're welcome. I have been amazed at the help the others have provided in the past.

    I forgot -- do not format/erase your cards. Try to use other cards and keep these safe so you can still get the movies. And, I have set my cameras back to MP4 format for now....

  • Old Toad Level 10 Level 10 (113,450 points)
    Currently Being Moderated
    Aug 18, 2013 10:42 AM (in response to jonezee)

    You need iPhoto 9.3 or later: Using AVCHD video with iPhoto '11 and Lion 10.7.4 or later.


    iPhoto 9.3





  • BPWMorro Level 1 Level 1 (70 points)
    Currently Being Moderated
    Aug 18, 2013 3:21 PM (in response to Old Toad)


         Your 8.1.2 probably isn't going to do it, based upon the KB Old Toad has found ... but, try changing to MP4 format first, as a test, and see if it works....that, at least, would allow you to further postpone the decision to upgrade software (although, I always recommend updates -- a few days after they are issued -- and OS upgrades (like to OS 10.8) a few weeks after issued).


    Old Toad,

         Great to hear from you again and thanks for linking to the KB -- I am curious, however, why my MBProRet has decided, seemingly overnight, not to import direct thru iPhoto when it used to....I don't recall any iPhoto updates in the past few days....I suppose the answer is simply "some things are not to be known," right? Hopefully it will straighten out.

  • Old Toad Level 10 Level 10 (113,450 points)
    Currently Being Moderated
    Aug 18, 2013 4:59 PM (in response to BPWMorro)

    Could be a number if small issues. One could be a damaged preference file or cache. Try the following:


    1 - delete the iPhoto preference file,, that resides in your

         User/Home/Library/ Preferences folder.


    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/ folder (Snow Leopard and Earlier).




    or with Lion and Mt. Lion from the User/Library/Containers/




    3 - launch iPhoto and try again.


    NOTE 1: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.


    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.


    Another could be issues with overall system preferences.  Run Disk Utility and repair disk permissions.  Also boot into another user account on your Mac and see if iPhoto can import from there.  If it can then there's something in your account that's awry.

  • BPWMorro Level 1 Level 1 (70 points)
    Currently Being Moderated
    Aug 20, 2013 4:19 PM (in response to Old Toad)

    Old Toad,

        Thanks for the "cure," I have kept.

         It worked....


        (1) I had to take a photograph first on the newly formatted card, before recording an AVCHD movie (I saw somewhere else that might be required, in order to create the proper receptacle folder on the card; its a Sony camera), and

       (2) while the jpg recorded with the proper time in metadata, the video is one hour off -- I guess that gremlin doesn't realize we don't do daylight savings in Arizona...or else he's Hopi, 'cause they do have it....or... that doesn't matter; I'll just say "

                Thanks, Again, for your help!"


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.