3 Replies Latest reply: Dec 7, 2013 7:27 AM by Neil Youngson
Iphonefarmer Level 1 Level 1 (0 points)

In aperture 3.4.5, I get unsupported file error when exporting version of photo I've edited using plugins. I have try reinstalling aperture three times, deleting plists a few times, reinstalling plugins, restarting my MacBook Pro many times. Everything I've tried may fix the problem for a very short while and I can export a few photos before it returns. The problem happens with topaz and photomatrix pro plugins after I edited and try to export version.

Aperture 3, OS X Mountain Lion (10.8.4)
  • Allan Eckert Level 8 Level 8 (48,570 points)

    Please provide the workflow of how you are using the plugins to edit this photos. The exact steps used to get the photos to the plugin and then back to Aperture will help us to figure out what is going wrong for you.



  • Iphonefarmer Level 1 Level 1 (0 points)

    I select the two exposures I capture using the TruHDR app on my iphone or three Canon raw files / exposures I capture with my Rebel T1i. Select Photomatix plugin first to merge and tonemapped the exposures making a new version. Then I select topaz plugin adjust for that image, use my preset then click ok. Next I use the topaz plugin detail to do my final sharping of the image, click ok. Most of the time I have no problem till this point but a few times the problem will show up after using the photomatix plugin before the topaz plugins, Most of the time the problem shows up when I select export version from the menu. I choose the location I wish to save/export the image too, then click the export versions button, a box pops up saying file save with errors and I get a black image saying unsupported file error.

  • Neil Youngson Level 1 Level 1 (0 points)

    I had the same problem with the Photomatix plug-in and this solved it for me. I realised it only happened with Photomatix and not other plug-ins so I checked where the plug-ins were installed. The Photomatix plug-in was installed in


    ~/Library/Application Support/Aperture/Plug-Ins/


    where ~ is the home location for the current user account. All the other plug-ins however were installed in


    Macintosh HD/Library/Application Support/Aperture/Plug-Ins/


    which is the location that makes them available to all user accounts on your Mac. Moving the Photomatix plug-in to this location solved the problem for me.


    Note that the Library directory under the first location is normally hidden, to get to it hold down the Option (Alt) key and select it from the Finder Go menu.