8 Replies Latest reply: Oct 29, 2006 12:24 PM by IreneKafie
Matt Ma Level 4 Level 4 (1,270 points)
I have 4900 songs on my 30GB photo iPod and iTunes. There is one song that I imported myself from a CD that can play in iTunes, but it won't play on the iPod. I imported this song with the same exact settings that I use for all other songs that I import. What could be wrong?

G5 iMac 1.8Ghz 1GB; G4 iBook 800Mhz 640MB, Mac OS X (10.4.6)
  • Matt Ma Level 4 Level 4 (1,270 points)
    Anyone else ever come across this problem?
  • sugar2s Level 1 Level 1 (0 points)
    I am having almost the exact same problem, but can't help with a solution since I haven't figured one out. I have a song that plays fine in iTunes, but on my iPod it stops playing about 2 minutes into the song. I hope someone has an answer!
    I have 4900 songs on my 30GB photo iPod and iTunes.
    There is one song that I imported myself from a CD
    that can play in iTunes, but it won't play on the
    iPod. I imported this song with the same exact
    settings that I use for all other songs that I
    import. What could be wrong?
  • sugar2s Level 1 Level 1 (0 points)
    Hey, try this (it worked for me):
    Highlight the song in iTunes, then go to Advanced and select Convert Selection to AAC.

    Now the song plays just fine.

    Good luck!
  • Matt Ma Level 4 Level 4 (1,270 points)
    If the song is already AAC, and I use the command Convert to AAC, won't that degrade the quality?

    Right now I'm using this workaround to get the song to play on my iPod: rip it again from the original CD, but this time using MP3. For some reason for these few songs, it plays fine as MP3, but refused to play when it was AAC.

    I'd prefer to keep all my songs as AAC, but at least now I can listen to all my songs on the iPod.
  • Pakhet Level 1 Level 1 (0 points)
    I'm having this same problem however I converted the songs to AAC and they play fine in itunes, but on my 30gb ipod they show up but won't play.

    The ipod just cycles thru them one by one at mach 10 and then goes back to the music menu.....I don't know what else to try and I had hoped to use them in a presentation this thursday.....

      Windows XP  
  • longsathome Level 1 Level 1 (0 points)
    I'm having the exact same problem - songs play fine in iTunes, and it just skips thru them on the iPod. I went to apple last night and they replaced my iPod, and the same thing is happening on the new iPod. Makes me thing it is something related to the itunes or authorizations or something, not the iPod itself.
  • Jnev33 Level 1 Level 1 (0 points)
    Im having the same problem...new ipod, newest itunes version..how do you fix it!??!?!
  • IreneKafie Level 1 Level 1 (0 points)
    That happens to me too! Since I authorized my computer, every song that I download from iTunes doesn't play on iPod (I have iPod Photo). But when I burn these songs on a cd and then import them on iTunes, they play normally on iPod. But burning cd is not the solution...