Previous 1 2 Next 19 Replies Latest reply: Nov 15, 2013 4:06 AM by Philip Kalina1 Go to original post
  • aaron chambers Level 1 (5 points)

    Yep. That's what I used to see. But not anymore.


    I'll give your suggestions a try making a new user etc.

  • aaron chambers Level 1 (5 points)

    Interesting update:


    I have noticed that if I am dragging JPEGs then this action works.


    Also, if the photo was shot with my Canon 40d it will work.


    If photo was shot with 7d or 5d3 the it doesn't.


    Very strange.

  • phosgraphis Level 2 (330 points)

    Aaron...Your post above suggests this has something to do with file size.


    Now for the weird part...while attempting to test this theory, my Aperture is now behaving exactly like you have won't switch to the library panel when dragging. This previously worked fine. Other than the normal adding projects, editing images, etc., the other things I have done is to mess with my keyboard command set, and test some preferences settings.


    Unfortunately, I won't have time to troubleshoot for a day or two, but will report what I find.

  • Philip Kalina1 Level 1 (5 points)

    Aaron, I was wondering if you have solved this. I have noticed this issue for some time now (over a year). I just upgraded to AP 3.5.1 and was hoping the problem was solved. I don't think your jpeg theory is key, because I observe the 'problem' with both raw and jpeg.

    Here is another head scratcher. I have a project with 110 items in it, mostly raws from my 7d. Some are psd's from Photoshop. One of the psd's does the automatic switching. None of the others do it. I also found that one of my raws does the auto switching. These shots were all from a photoshoot I did in a single day with the same camera. They are all referenced files, and I see no other distinction that makes 2 of them 'work' and 108 of them not!

    The above test was done on my iMac.


    The following test, I did on my MBA. I found a project where all 101 images/movies were taken with my G15. In this case, all the movie files did the auto switch. None of the jpegs did the switch (except 1, hmm...) and almost all the CR2 raw files caused the switch, except a few.


    So, I really don't think this is an issue based on a single type of Mac, or a corrupt preferences file. I've even tried to repair/rebuild the database with no changes. And, I think most AP users, like Phosgraphis, discover that all their images don't cause the auto switch, even 'tho they thought they did. So this may be a bug in AP that Apple hasn't yet discovered.


    I'm with you...this is a time-saving feature, when it works. It would also be VERY nice if it would snap back to the Adjustments panel after you dropped your image(s) into the Library.

  • Philip Kalina1 Level 1 (5 points)

    Dang, if I didn't find the solution to this! The key is the Preview, or lack of one. If an image does not initiate the auto switch, then right-click on it and select Update Preview. It will then work. I've tried this on several images and it works every time. The reason why this started happening, my guess, is when Apple put the 'New Project Automatically Generates Previews' checkbox in the Previews preferences. Mine is unchecked, so most of my images do not have generated previews. The few that do would cause the switch. Whether or not this is a 'bug' is debateable, but we now know the solution.

Previous 1 2 Next