8 Replies Latest reply: Jun 23, 2006 7:50 AM by pafoliver
iruhkoi Level 1 Level 1 (15 points)
Hi everyone, I'm having a bit of trouble with OS Mail. I've set it up to use an IMAP account, and have set my preferences such that Mail should save all my sent messages in the Sent folder (I assume the Sent folder on my computer, not the one on my IMAP server). Regardless, neither my IMAP server's sent folder nor my computer's sent folder contain any messages that I've sent, and I have confirmed that these messages have in fact been received by the recipients (therefore successfully sent). I am unsure of how to resolve this issue, as there is no obvious setting change for me to persue. I just received this computer (new) a few days ago, so I wouldn't expect this problem to be due to disk maintenance/management, etc.

Also, I have noticed that Junk messages remain highlighted and in my inbox. I changed my prefs to have these messages be placed in my Junk Mail folder. Mail asked me whether I wanted to apply that preference to older messages marked as junk that have yet to be put in the folder; I indicated yes. Nothing happened, and the Junk Mail folder remained empty (until I manually moved the messages to it). Any ideas?

I have searched the forums for related issues and could only find problems that had an associated error message with it; my issue is different in that there are no error messages; Mail is simply ignoring my preferences. Thanks in advance,

Vic

MacBook Pro 15", Mac OS X (10.4.6)
  • David Gimeno Gost Level 7 Level 7 (20,775 points)
    Hi Vic.

    I've set it up to use an IMAP account, and have
    set my preferences such that Mail should save all my
    sent messages in the Sent folder


    I don't understand. There is no such setting in Mail.

    (I assume the Sent folder on my computer,
    not the one on my IMAP server).


    Interestingly enough, this setting does exist, so I don't understand either why are you assuming anything here. Either you've checked Store sent messages on the server or you haven't.

    Regardless, neither my IMAP server's sent
    folder nor my computer's sent folder contain any
    messages that I've sent,


    Where do you see those Sent folders in Mail? Do they have a generic folder icon or a special icon that indicates their purpose?

    Also, I have noticed that Junk messages remain
    highlighted and in my inbox. I changed my prefs to
    have these messages be placed in my Junk Mail folder.


    Where do you see the Junk folder in Mail? Does it have a generic folder icon or a special icon that indicates its purpose?
  • iruhkoi Level 1 Level 1 (15 points)
    Hi David, thanks for your response. To clarify, I have selected "Store sent messages on the server" and this is what I assumed would lead me to save my sent messages for access later. The "sent" folder I am talking about is an icon that appears underneath my "Inbox" icon and looks like a folder paper airplane. This icon changes to "sending" when e-mails are being sent. Perhaps this isn't really a folder and I am simply misunderstanding? If so, please let me know what the "store sent messages on the server" preference actually does.

    As for the Junk folder, it is a similar icon underneath the "Sent" icon, and looks like a brown paper bag with a Recycle image on it along with some papers inside. It appeared only after I enabled the preference "When junk mail arrives...Move it to the junk mailbox (Automatic)." Again, if I am misunderstanding this icon's purpose (i.e., if it is not a folder, but something else) please let me know, as well as what actions the preference I enabled will be taking.

    Thanks again for your help
  • David Gimeno Gost Level 7 Level 7 (20,775 points)
    OK. Some clarifications first:

    1. Under normal operation, Mail always saves your sent messages, either locally or on the server, depending on whether you have disabled or enabled Store sent messages on the server. That is, the setting determines where your sent messages should be stored, not whether they should be stored. For some reason, you're currently not "under normal operation", and we have to find out what's wrong.

    2. What you were calling folders is what Mail calls mailboxes. Even when Mail displays them as generic folder icons, they are still mailboxes for all intents and purposes. There is nothing wrong with thinking about them as if they were folders. Actually, in Mail, each mailbox has a corresponding folder in the filesystem.

    Back to your problems. In your first post, you talked about two sent folders, the "IMAP server's sent folder" and the "computer's sent folder", yet your second post implies that there is only one Sent mailbox in Mail. Could you please clarify this?

    If you select either Sent or Junk in the mailboxes list in Mail, then choose Use This Mailbox For from the Mailbox menu, do the options there appear selectable or grayed out? If selectable, choose Sent with the Sent mailbox selected, and Junk with the Junk mailbox selected. In that case, your problems should be fixed now. If not, we'll have to look at other things.

    I'm assuming this is the only account you've set up in Mail so far. Is that correct?
  • iruhkoi Level 1 Level 1 (15 points)
    My IMAP account is mapped to have a "Sent" folder; when I use the web-based client provided by my IMAP provider to send/receive messages while away from my primary workstation, all sent mail is saved there. In OS X Mail, this sent folder appears as a subdirectory (sub "mailbox"?) under my "Inbox" mailbox along with other folders that are mapped on my IMAP account.

    I tried selecting Sent and Junk mailboxes and then using the menus to make the changes you indicated, however, the options are in fact grayed out and unselectable. So it looks like we might have to try something else. And yes, this is the only account I have set up in Mail thus far.

    I should probably mention (just realized) that in my account settings, my outgoing SMTP server is set to be my ISP's server (which is different from my IMAP provider). In other words, my IMAP provider is imap.[provider].net while my SMTP is mail.[ISP].net. My IMAP provider will not provide authentication for its own SMTP unless I try to send mail directly on their intranet or through a VPN connected to their intranet, so in the past I have used my ISP to send mail. I wonder if, by selecting "save messages on server" I am saving these messages somewhere on my ISP? When I uncheck this option, perhaps my mail will be stored on my local computer instead?

    Thank you again for your time and concern

    MacBook Pro 15"   Mac OS X (10.4.6)  
  • David Gimeno Gost Level 7 Level 7 (20,775 points)
    In OS X Mail, this sent folder appears as a subdirectory
    (sub "mailbox"?) under my "Inbox" mailbox along with
    other folders that are mapped on my IMAP account.


    This means you haven't set up your account properly. You probably should set Preferences > Accounts > Advanced > IMAP Path Prefix to INBOX, or something like that.

    After putting the right string in the IMAP Path Prefix field, either the IMAP folders will appear somewhere else in Mail (i.e. not as subfolders of Inbox), or your problem will have already been fixed. Let me know what happens.

    I should probably mention (just realized) that in my
    account settings, my outgoing SMTP server is set to
    be my ISP's server (which is different from my IMAP
    provider).
    [...]
    I wonder if, by selecting "save messages on server"
    I am saving these messages somewhere on my ISP?


    Mail should still save the sent messages where you've told it to. It's Mail, not the SMTP server, that stores the sent messages. The SMTP server has no bearing on this, but it was a good idea to consider that possibility, nevertheless.

    When I uncheck this option, perhaps my mail will
    be stored on my local computer instead?


    Yes, that's what would happen, but don't uncheck that option if you really want your sent messages to be stored on the IMAP server, or do it temporarily, so that Mail does at least save them somewhere until we fix the problem, but I believe I already know what the problem is.
  • iruhkoi Level 1 Level 1 (15 points)
    Perfect! That IMAP Path Prefix change did the trick; my sent messages are now appearing in the Sent folder. Just out of curiousity, what does the IMAP Path Prefix actually mean, and why do you think its (mis)configuration caused this problem (ie where do you think my sent mail was being saved previously)?

    David, thank you so much for your help!
  • David Gimeno Gost Level 7 Level 7 (20,775 points)
    You're welcome. Glad it worked.

    what does the IMAP Path Prefix actually mean, and why do you
    think its (mis)configuration caused this problem (ie where
    do you think my sent mail was being saved previously)?


    The IMAP specification allows the server to organize mail however it wants using "namespaces". The particular IMAP server you're using makes the standard folders (mailboxes) appear as if they were subfolders of INBOX to a mail client that doesn't support IMAP namespaces. Note: Other servers use other conventions; putting INBOX in the IMAP Path Prefix field is only appropriate when the mailboxes on the server appear in Mail as subfolders of Inbox.

    Mail doesn't properly support IMAP namespaces, but it lets you help it handle them by means of the IMAP Path Prefix field. This is a workaround, but it works in most cases if you know what has to be put there. In your case, when that field was empty, Mail was "confused" as to where the sent messages should be stored. I believe Mail just wasn't storing them anywhere.

    Selecting the Sent subfolder of Inbox, and doing Mailbox > Use This Mailbox For > Sent would also have "solved" your problem, but that would have just addressed the symptoms. You would have had to do the same for every other mailbox with a predefined meaning. Worse yet, you would only have been able to create new folders (mailboxes) on the server as subfolders of Inbox, if at all.
  • pafoliver Level 1 Level 1 (0 points)
    Selecting the Sent subfolder of Inbox,
    and doing Mailbox > Use This Mailbox For >
    Sent
    would also have "solved" your problem


    Have been struggling for weeks with same problem as Vic, whereby all my freedom2surf IMAP mailboxes were appearing as a subset on Inbox, and Sent mail from my IMAP account was not being stored on the server, and was not accessible via Mail's paperdart icon (although sent mail from my dotmac account was being stored, and did appear under the paper dart icon).

    Moreover, none of the other discussion group suggestions on this topic worked for me. So am delighted to find it solved at last by Dave's suggestion of typing INBOX into the Mail> Preferences> Accounts> IMAP path prefix box.

    But dont think that opting for the Use this Mailbox alternative would solve the problem because those submenu options were greyed out, and there was no IMAP account icon in the sidebar pane, until AFTER I'd entered 'INBOX' into the IMAP path prefix box, at which point the IMAP account icon(s) magically appeared and the submenu became useable...

    Anyway - grateful thanks for the idea that did work! pafoliver