Previous 1 2 3 Next 42 Replies Latest reply: Oct 6, 2014 8:39 AM by tallyt Go to original post
  • Terence Devlin Level 10 Level 10 (135,020 points)

    iPhoto has always had this problem, but it affects people intermittently. I'm on this forum since iPhoto 5 or 6 or thereabouts and there have been a steady trickle of folks who post with these issues and the resolution was moving the Library to an local, correctly formatted disk. Some folks had issues the first day they moved the Library, others had it working for years and then one day it started to give trouble. No idea why it would suddenly give up but once it did there is no going back.

     

    In recent years that trickle has grown to the point that a couple of years ago I made a boiler plate snippet of that answer because it was needed often enough to be tedious to type it:

     

    iPhoto needs to have the Library sitting on disk formatted Mac OS Extended (Journaled). Users with the Library sitting on disks otherwise formatted regularly report issues including, but not limited to, importing, exporting, saving edits and sharing the photos.

     

    The rest I added this week when I saw the technote.

     

     

    All Apple have done is (finally) issue a tech note that points it out now. They have a similar one for Aperture since 2009.

  • Old Toad Level 10 Level 10 (130,305 points)

    Are you connected wirelessly to the Mini and EHD  or hard wired?

  • Createbnd Level 1 Level 1 (5 points)

    Hard wired on gigabit network, gigabit switch etc.

  • Createbnd Level 1 Level 1 (5 points)

    understand your frustration, I have been working commercially with Apple equipment since '88 & each upgrade has its little 'improvements'............

  • Createbnd Level 1 Level 1 (5 points)

    going to AP Extreme as router

  • Createbnd Level 1 Level 1 (5 points)

    Ok, moved the iPhoto library from the EHD to the internal drive of the mac mini server (which takes away any format compatibility).

     

    Same problem that it cannot recognise .mov files.

  • Dolphster Level 1 Level 1 (0 points)

    I'm watching this thread and hope to hear a response, as this is the same issues that I am facing.

     

    My setup is near exact to @Createbnd.

  • spoiled gradient Level 1 Level 1 (15 points)

    Guess no one has solved this?

     

    I have encountered the same issue on iPhoto 9.5, but the oddest thing is that I'm importing photos and videos from my Lightroom library (because my wife prefers to use iPhoto), and 99% of the .mov files (iphone videos) imported fine, but those at the end of my import session failed.

     

    Because I have a huge Lightroom library, I broke it up into iPhoto libraries by calendar year. For the year 2011, every iphone video up until Nov 6 imported fine, and then every iphone video after Nov 6 was rejected. I can play the files just fine in Quicktime, and they seem to be formatted identically to those before Nov 6, so I have no idea why they aren't being recognized properly.

     

    My libraries are being set up on an external hard drive connected by USB to my early 2009 MBP running Mavericks. The EHD is formatted Mac OS Extended (Journaled). All of my other libraries imported without any problems, including every single iPhone video.

     

    Given that most of my videos imported without a hitch, this doesn't seem to be related to formatting of the host drive...

  • spoiled gradient Level 1 Level 1 (15 points)

    Just tried something: created a new iPhoto Library and imported one of the video files that wouldn't import to my 2011 library, and it successfully imported. This makes me wonder if iPhoto has a limit on how many videos it can import into any single library, or maybe there is a limit to how large a library can be? My 2011 library is over 130 GB, so maybe I need to split it in half?

     

    Guess that's the route I'll take for now. What a pain.

  • LarryHN Level 9 Level 9 (70,995 points)

    That is not the problem. Mine is over 220 GB with over 55,000 photos

     

    LN

  • spoiled gradient Level 1 Level 1 (15 points)

    @LN does your library contain a lot of .MOV files? Maybe there's a limit to how many .MOV files a library contains? I can still import jpg and dng files, just no more mov files.

     

    If I get a chance, I'll see if I can figure out how many .mov files I had in this library.

     

    Anyway, breaking the libraries up seems to solve the problem, and I'll use iPhoto Library Manager to manage all of these "small" libraries.

  • Terence Devlin Level 10 Level 10 (135,020 points)

    There is no such limit. We see this when there is minor damage in the database.

     

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Repair Database. If that doesn't help, then try again, this time using Rebuild Database.

     

    If that fails:

     

    Option 2

    Download iPhoto Library Manager and use its rebuild function. (In early versions of Library Manager it's the File -> Rebuild command. In later versions it's under the Library menu.)

     

    This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.

     

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one.  

     

    Regards

     

     

    TD

  • spoiled gradient Level 1 Level 1 (15 points)

    @TD, thanks, but I've already deleted the library that was giving me problems. It was a brand new library that had just undergone its first import, so I don't see how its database could have already been damaged, but who knows.

  • creudelsud Level 1 Level 1 (0 points)

    Hello to all the community.

     

    I think I found the "manual" solution to that problem.

     

    My personal situation was similar: I had an imovie librabry that I wanted to incorporate to the iphoto11. Thus all or almost all files where .mov coming from iphones and other sources.

     

    I have to say that Library manager helped me in the previous steps of merging several iphoto libraries but failed to incorporate the imovie one as it is not an iphoto structure.

     

    I don't want to bore you so the result to the problem is: DELETE ALL SUBFOLDERS "movie cache" and "movie thumbnails" that appear on each event folder. Then the result is that inside each only the raw .mov files remain.

     

    Then you can incorporate all the events!!! Without problems!

     

    I hope this will help you

     

    Thanks

     

    Roger

  • JimBurnett Level 1 Level 1 (0 points)

    Try this:  https://discussions.apple.com/thread/5898882

     

    Create new library. Switch to it. Switch back to main library. Try reimporting videos.