Previous 1 2 3 Next 42 Replies Latest reply: Oct 6, 2014 8:39 AM by tallyt Go to original post
  • LarryHN Level 9 (76,810 points)

    JimBurnett wrote:

     

    Try this:  https://discussions.apple.com/thread/5898882

     

    Create new library. Switch to it. Switch back to main library. Try reimporting videos.

    Thsi suggested solution loses all edits and metadata updates as well as all books, slideshows and other information - The likely better solution is Back up your iPhoto library, Depress and hold the option (alt) and command keys and launch iPhoto - rebuild your iPhoto library database

     

    LN

  • JimBurnett Level 1 (0 points)

    If you cant open iPhoto at all, even with option + command, then you really dont have a choice.

  • Createbnd Level 1 (5 points)

    The original problem is linked to the library being on external drive (via server) & it would seem that iPhoto 11 no longer supports .mov files (whereas it DEFINATLY did in all previous versions) from network externals.

     

    I have a workaround for this (Dolphster you mentioned that you have a similar setup to mine so this may help): launch iPhoto (option held down to choose lib) from the mac that is serving the volume & choose the users library that you wish to import to & plug device in direct & import.

     

    Not ideal, but untill Apple change iPhoto11 to work like all the previous versions is the only way I have got around the problem.

     

    Hope that helps.

  • Terence Devlin Level 10 (137,883 points)

    iPhoto has never supported the Library on a Server or on a networked connection. You've been lucky in that it ahs worked for you until now, but you've just run out of luck.

     

    launch iPhoto (option held down to choose lib) from the mac that is serving the volume & choose the users library that you wish to import to & plug device in direct & import.

     

    Never import one Library to another. Every version and thumbnail is imported like a distinct photo, you lose all your Albums, Keywords etc., the link between Original and Previews is destroyed, the non-destructive editing feature is ruined and so on. In summary: it's mess.

     

    You want to move the Library not import it.

  • Createbnd Level 1 (5 points)

    All Albums, keywords etc. remain.

     

    In summary: it works.

  • Terence Devlin Level 10 (137,883 points)

    No it doesn't. If all that remains then you didn't do

     

    launch iPhoto (option held down to choose lib) from the mac that is serving the volume & choose the users library that you wish to import to & plug device in direct & import.

     

    You did something else. In summary you need to provide accurate instructions.

  • Createbnd Level 1 (5 points)

    Well it obviously does as its works as I have instructed.

     

    Maybe I'm just lucky again.

  • MacHeadVB Level 1 (0 points)

    createbnd, if this is this still a concern of yours... recently i did a fresh install of mavericks on my imac.  before the new install i moved the iphoto\masters folder to an external drive. the masters folder contained about 10 years of pix and videos. from a previous experience, i knew that iphoto would not be able to handle the import of the masters folder at one time. so i attempted to import 1 year at a time. i started getting not enough drive space errors and the error that .mov files are not recognized format and can not be imported. so then i went more granular by importing 1 month at a time.  result... i did not get either of the .mov errors or the drive space errors anymore. so, my non-genius opinion/conclusion is that there is a memory/file/thread import threshold with iphoto.  maybe a new mac pro would chew this process up with no hiccups.

     

    good luck guys! -tom

  • MacHeadVB Level 1 (0 points)

    !please disregard my posting... i started having the same issue with .mov files further into my process... sorry!

  • MacHeadVB Level 1 (0 points)

    turns out i had to use a combination of suggestions listed in this thread to resolve the original iphoto errors of "insufficient disk space" and .mov files are an unrecognized format. you have to be more granular when importing folders containing lots of videos and pictures. from my masters folder, i started with each year until an error, then each month until an error. at each error, i would close iphoto reopen holding option+command to repair db. normally after that, i could import the month that gave me the error. if not, drilling down to the actual file/files and importing them separately worked. my opinion is still that iphoto can only process/import so many items before needing a restart or a repair.  very time consuming to add all these media files back after a clean install of mavericks, but now i feel like a have a clean profile without unused junk carried over from multiple upgrades, that may have been slowing down my user experience.

     

    again, good luck guys!

  • FlagonW Level 1 (0 points)

    I had the same problem of .MOV files being unrecognized.  After trying to rebuild my library database to no avail I realized that only the .MOV files I had renamed were unrecognzied.  I had appended the date to many of my .MOV files.  After removing the date and basically restoring the filename to the original, I was able to import movies.

  • MacHeadVB Level 1 (0 points)

    one more thing... there is a "Auto Import" folder in the contents of the iPhoto Library.  With iPhoto closed, I moved/copied Master files to new library. When move/copy is finished, open iPhoto, files are imported with none of the issues I mentioned in previous posts. You can monitor the Auto Import folder to make sure all picture and videos are imported.  When completed, iPhoto will keep trying to import "DS Store" files. Close iPhoto, db will update, then check Auto Import folder for any residual photos/videos. If none, you can then delete the folders you moved/copied into the Auto Import folder.  To ease your mind, do a test run with a "copy" instead of a "move" of your files.  Take note of the number of media files placed in the Auto Import folder and compare that number with the number files in "Last Import" after opening iPhoto.

     

    Happy, Happy, Happy!

  • tallyt Level 1 (0 points)

    I have been receiving an error importing MOV files into iPhoto 9.5.1

     

    After digging around my console I found the following error:

    10/6/14 11:23:33.001 AM iPhoto[1062]: Failed to communicate with qtkitserver: Connection invalid

     

    The solution after reviewing was to rebuild a cache file, which is required...

     

    I found this note here:

    https://jamfnation.jamfsoftware.com/discussion.html?id=6745

     

    The command:

    sudo /usr/libexec/xpchelper --rebuild-cache


    Restored my ability to import MOV files.


    Hope this helps folks.

Previous 1 2 3 Next