2 Replies Latest reply: Aug 23, 2013 10:22 AM by Brandon2184
madelynbyrne Level 1 Level 1 (0 points)

I have a Mac Pro Dual Core, 3 Ghz, that I purchased in the Spring of 2007.  What is the latest OS that i can upgrade to?  And is that OS compatible with Logic 10?


Mac Pro, Mac OS X (10.5.8)