3 Replies Latest reply: Sep 1, 2013 12:01 PM by trix_gal
trix_gal Level 1 Level 1 (0 points)

Two days ago, I copied a lot of videos & photos into my macbook without checking the available hard drive left. I also had a problem with the trackpad that keeps forgetting my settings, so I searched for solutions online. I read somewhere that said that I could try to change permissions for users in the system folder (right click on Home > get info > permissions) from Read only (for everybody) to Read & Write.

 

After i clicked that, it ran for a while and just as I was about to turn off the mac, there were a series of error popping up one after the other. I didn't pay much attention to it so I pressed 'close' on most of the warning pop-ups. But because there were a ton of them non-stop, I force shut down the mac. Then I went to bed (Argh bad choice)

 

Anyway, the next morning as i turned on the machine again, it got stuck in the apple logo with spinning wheel page, and I've tried several times even letting it run for the whole day.

 

Safe Boot did not work, as I was unable to enter safe Boot mode. The progress bar would appear for a while and then it would vanish and again i'm left with the logo and spinning wheel.

 

Nor does recovery boot, which gives me the option of choosing only the hard disk (no recovery hard disk?)

 

I've tried doing fcsk in terminal. After which it failed to shut down/restart after I typed in 'exit'. It got stuck at "AirPort: Link Down on en1"

 

I've also tried this: http://macs.about.com/od/MacTroubleshootingTips/qt/Troubleshooting-Mac-Startup-P roblems-Stuck-At-The-Blue-Screen.htm same result.

 

I also saw something along the line of "Audit space low" which I assume is caused by my stupidity of letting the harddisk get too full.

 

I had my iphone share the internet wifi and i can hear it 'ding' (signalling that someone/thing has connected to the wifi) when my mac turns on, even when it couldn't get through the apple logo. I guess this means the airport works?

 

Then what..? Why won't it continue start up? Why can't I go into safe mode? Or recovery mode..?

 

I've also tried resetting PRAM (Command Option P R) three times in a row, to no avail.

 

HELP!


MacBook Pro, Mac OS X (10.6.8)
  • brenden dv Community Specialists Community Specialists (4,555 points)

    Hi trix_gal,

     

    If you are having issues with your MacBook Pro not booting past the Apple logo, you may find the following articles helpful (if a standard Recovery boot does not work, you may be able to boot to an Internet Recovery as described in the second doc):

     

    Mac OS X: Gray screen appears during startup

    http://support.apple.com/kb/TS2570

     

    OS X: About OS X Recovery

    http://support.apple.com/kb/HT4718

     

    If the issue is being caused by a lack of available hard drive space, you may also be able to access the drive in Target Disk mode:

     

    Apple Support: How to use and troubleshoot FireWire target disk mode

    http://support.apple.com/kb/HT1661

     

    Regards,

    - Brenden

  • trix_gal Level 1 Level 1 (0 points)

    Thanks! I've tried everything except the disc utility from the install disc. I finally got my hands on one, and tried the disc utility step.

     

    I did the Repair Disk Permissions, and it found a lot of permissions to fix. I think that's the main problem because the SMART status is verified. I'm still in progress but I feel that this should be it. I'll be rebooting soon and *fingers-crossed* hope that this fixes it.

     

    Thanks!

  • trix_gal Level 1 Level 1 (0 points)

    I FIXED MY MAC!! YEAYYY!!

     

    So i think this is what happened:

    1. I changed the permissions of the start up disk. DON'T DO IT. EVER.

    2. No. 1 starts ruining my mac, causing it to create errors in the folder permissions etc. so when it starts up, it was stuck in the apple logo.

    3. Couldn't get into safe mode...

    4. Pressing alt after reboot and selecting the hard disk choice provided didn't work

    5. NVRAM/PRAM (??) reset did nothing

    6. Going into terminal mode, typed in fsck. Didn't work

    7. Finally I got my hands on a DVD of the Mac OSX Lion.

    8. Restarted using disc boot. Did disc utility. Repaired disc permissions.
    9. Reboot again. Kernel panic. I stay calm. Reboot. Kernel panic again. I panic.
    10. Reboot, pressed shift to go into Safe Mode. I got in. Deleted movies laying on the desktop hoping it'll free up some space (bye-bye Game of Thrones).
    11. Reboot, gray screen, apple logo, spinning wheel. Light blue screen appears! Yay! Sakura flowers appear!! My wallpaper! yayayyayayayy
    12. There still seems to be some problem with some start up items having security issues. I don't know why but it seems to do nothing but pop up a warning that says the items weren't running. So, for now, my mac is safe.

    PHEW!

     

    PS. my start up items are:

    FujitsuLauncher

    HWNetMgr

    HWPortDetect

    MobileBrServ

    StartOuc

     

    All of them have issues. I have no idea what these start up items are. But now after reboot, a pop up (for each item) will appear saying

    Insecure Startup Item disabled.

    ("/Library/StartupItems/[item name]") has not been started because it does not have the proper security settings.

     

    I read here http://support.apple.com/kb/TS3493 says that I should drag them into trash, but it wouldn't go it because it's being used. So I don't know how to deal with these pop ups.