Previous 1 2 Next 27 Replies Latest reply: Sep 18, 2013 7:14 AM by Ernie Stamper
michaelgc Level 1 Level 1

Since the latest RAW compatibility update, previews of RAW images (Nikon D90 NEF) are displaying in either red, green, or cyan monochro in Aperture 3. This issue also effects Preview and iPhoto.Photoshop displays the files correctly however, indicating that it is not a system-wide problem. Has anyone else had something like this?

 

Mountain Lion

Aperture 3

Solved by hdskullfire2 on Aug 27, 2013 6:30 AM Solved
Pascal, Your workaround worked however, instead of going all the way back to 4.01, I was able to find 4.07 which is the last one before the problem started.. Users need to follow the instructions on the link above and remove a couple files, then install this 4.07 update to replace the problem one.. http://support.apple.com/kb/DL1666 Steve..
Reply by hdskullfire2 on Aug 27, 2013 6:43 AM Helpful
Just a little about what two files I needed to remove.. RawCamera.bundle & RawCameraSupport.bundle Once those two were removed I applied the 4.07 update and restarted Aperture and everything is back to normal..!!! Good luck.. I know this from now on... I won't be so quick to install these packages, since Apple failed badly on the the Quality Assurance/Quality Control review of this update before sending it out mainstream..!!!  Steve
Reply by Pascal Gosselin on Aug 27, 2013 6:12 AM Helpful
Just found this link which seems very similar to our own problem ! I will give it a try this evening : http://www.flickr.com/groups/sony_alpha/discuss/72157608585434388/

All replies

  • hdskullfire2 Level 1 Level 1

    Just like above, I have the same issue.. Started right after the newest RAW update.. Nothing on my secondary monitor in Aperture displays correctly hard color cast just a few seconds after the image finishes loading. Primary monitor is showing same issue issues as well..

     

    Anyway to reverse this update?? My images are all Nikon D90 and D7000 RAW files.. I've even tried Fixing the permissions and no luck.. Side note thpough.. I;m seeing ACL's related to the RAW & Printer Updates that constantly need fixing of permissions by bon't seem to have any affect..

     

    OSX 10.7.5

    Aperture 3.4.5

  • hkeirc Level 1 Level 1

    I had a similar problem after the update.  The strip viewer and large view went blue then blank.  After I rebooted the syetem it all works again.

  • michaelgc Level 1 Level 1

    Then with respect it wasn't a similar problem, as in my case the screen does it every time, and stays as a monochrome picture no matter what. Other Apple image apps ie Preview and iPhoto are displaying the same problem so it's not just confined to Aperture. And yes it does it between reboots. Several.

  • Pascal Gosselin Level 1 Level 1

    Exactly the same problem here...

  • hdskullfire2 Level 1 Level 1

    OK, this is not just a simple problem.. I'm totaly dead in the water..!!! Aperture, iPhoto are all compromised..!!  I can't edit anything on any of my MacPro/MacBookPro's.  Everything is messed up big time.... My MacBookPro's are running Mountain Lion and even those are compromised..!!!

     

    Apple needs to fix this asap and in the mean time give us instructions on how to remove the last RAW update or something..!!!

     

    Steve

  • Pascal Gosselin Level 1 Level 1

    Just found this link which seems very similar to our own problem ! I will give it a try this evening :

     

    http://www.flickr.com/groups/sony_alpha/discuss/72157608585434388/

  • hdskullfire2 Level 1 Level 1

    Pascal,

     

    Your workaround worked however, instead of going all the way back to 4.01, I was able to find 4.07 which is the last one before the problem started..

     

    Users need to follow the instructions on the link above and remove a couple files, then install this 4.07 update to replace the problem one..

     

    http://support.apple.com/kb/DL1666

     

    Steve..

  • hdskullfire2 Level 1 Level 1

    Just a little about what two files I needed to remove..

     

    RawCamera.bundle & RawCameraSupport.bundle

     

    Once those two were removed I applied the 4.07 update and restarted Aperture and everything is back to normal..!!!

     

    Good luck..

     

    I know this from now on... I won't be so quick to install these packages, since Apple failed badly on the the Quality Assurance/Quality Control review of this update before sending it out mainstream..!!!

     

    Steve

  • Fernleigh-NYC Level 1 Level 1

    +1 to this thread!  Thanks!  Have spent the better part of the day trying to figure out what was going on.  By process of elimination, I determined it was not Photo Mechanic, new installed and configured, and not Capture NX2 (which I sometimes prematurely blamed).  Then I remembered this recent RAW update, and then focused on that.  This was helpful in clarifying how to uninstall the old.  As hdskullfire2 notes, waiting to update this app seems advisable....

  • KCChem83 Level 1 Level 1

    Same problem here.  Thanks for providing a workaround.  It sure would be easier if Apple would fix the problem and release a update of the Nikon RAW profile.

  • michaelgc Level 1 Level 1

    Thanks for the workaround!

  • Alphonse G Level 1 Level 1

    Your workaround seems to have got me back to editing.... 

     

    Might add that the files are under the path Macintosh HD > System > Library > CoreServices

     

    Of note is that this compatibilty issue is affecting RAW files imported by way of the Nikon Transfer application That was implied by something in another discussion group (sorry I did not save the link!).  Before I tried your workaround I had imported photos from last night in two ways.  I used Nikon Transfer (with the delete files after transfer feature turned off).  Then I did a straight forward copy from the memory card to hard drive.

     

    The files created using Nikon Transfer did not display correctly, the ones created by copying from the memory card displayed OK!

     

    Also - There was no problem with files from my previous camera, a Nikon D70

  • Ernie Stamper Level 8 Level 8
    expertise.video
    Video

    What, exactly, is the file type that is outputed from Nikon Transfer here?  I am trying to relate this to something else involving .DNG files.

     

    I only import to Aperture from the memory cards used in my Nikon cameras.

     

    Ernie

  • Alphonse G Level 1 Level 1

    Ernie,

     

    The file type in this discussion is Nikon's .NEF (the extension for Nikon's proprietary camera RAW images).

Previous 1 2 Next