3 Replies Latest reply: Aug 29, 2013 4:30 AM by nbar
FrederikaPa Level 1 Level 1 (0 points)

I need help! I bought my macbook in early 2009 and my battery stopped working about 2 years ago and in the meantime I updated the system to Snow Leopard so now it is Mac OS X version 10.6.8. I bought online a genuine apple battery model A1185 (i pulled out the original battery and that was the model number) . Now i have put in the new battery but my computer doesnt recognise that its there and has a X in the battery symbol on the top of the screen. The power cord is a green colour except for when i turn it off and then it turns orange. So I left the battery in and the cord connected overnight while it was turned off with the orange light on thinking that the new battery must be charging but today when i checked it (over 12 hours later) the battery symbol still shows an X and when i disconnect the power cord the computer loses all power indicating that it is not registered that there is a battery there.

Also when I remove the new battery and press the small button only one of the five green lights, light up. I also have been browsing this issue online and saw some reference to the old macbook battery not working with the new system 10.6 so i did a software update but still not working. Any help greatly appreciated!

 

 

 

 

Hardware Overview:

 

  Model Name:          MacBook

  Model Identifier:          MacBook4,1

  Processor Name:          Intel Core 2 Duo

  Processor Speed:          2.1 GHz

  Number Of Processors:          1

  Total Number Of Cores:          2

  L2 Cache:          3 MB

  Memory:          1 GB

  Bus Speed:          800 MHz


MacBook, Mac OS X (10.6.8), battery A1185
  • nbar Level 5 Level 5 (6,975 points)

    The battery is either not being recognized or it is bad:

     

    1) Try reseating the battery

    2) Try an SMC reset

    3) The battery is most likely bad:

     

    From the Finder Menu Bar, hold down Option and click the Apple Logo > System Profiler > Hardware > Power

     

    Post the output in your reply.

     

    See here for detailed instructions:

     

    MacBook, MacBook Pro, MacBook Air: Battery not recognized after ...

  • FrederikaPa Level 1 Level 1 (0 points)

    Thanks nbar for your reply but unfortunately its still not working after doing the SMC reset and following the other suggestions. Also below is the battery info from the Finder Menu Bar, hold down Option and click the Apple Logo > System Profiler > Hardware > Power

     

     

    Battery Information:

     

      Charge Information:

      Charge remaining (mAh):          0

      Fully charged:          No

      Charging:          No

      Full charge capacity (mAh):          0

      Health Information:

      Cycle count:          0

      Battery Installed:          No

      Amperage (mA):          0

      Voltage (mV):          0

     

    System Power Settings:

     

      AC Power:

      System Sleep Timer (Minutes):          77

      Disk Sleep Timer (Minutes):          10

      Display Sleep Timer (Minutes):          20

      Automatic Restart On Power Loss:          Yes

      Wake On AC Change:          No

      Wake On Clamshell Open:          Yes

      Wake On LAN:          No

      Current Power Source:          Yes

      Display Sleep Uses Dim:          Yes

      Battery Power:

      System Sleep Timer (Minutes):          10

      Disk Sleep Timer (Minutes):          10

      Display Sleep Timer (Minutes):          2

      Wake On AC Change:          No

      Wake On Clamshell Open:          Yes

      Display Sleep Uses Dim:          Yes

      Reduce Brightness:          Yes

     

    Hardware Configuration:

     

      UPS Installed:          No

     

    AC Charger Information:

     

      Connected:          Yes

      ID:          0x0100

      Wattage (W):          85

      Revision:          0x0000

      Family:          0x00ba

      Serial Number:          0x00a0caf9

      Charging:          No

     

    Power Events:

     

    Next Scheduled Events:

     

      Type:          Wake or Power On

      Scheduled By:          Repeating Event

      Time:          30/08/13 12:00 AM

     

    Repeating Events:

     

      Type:          Wake or Power On

      Time:          12:00 AM every day

  • nbar Level 5 Level 5 (6,975 points)

      Battery Installed:          No

    Okay, so the machine is not even recognizing the battery as present. . A1185 is the model of the CPU, not the battery, but it would be fairly obvious if you ordered a battery not compatible with your machine (it would either fit correctly, or it wouldn't).  If you  already tried reseating the battery, there is nothing you can do besides taking the machine in servicing. The problem is either with the battery itself, or the computer's battery connection.