8 Replies Latest reply: Sep 8, 2013 2:42 PM by Pondini
ethermom Level 1 (0 points)

We have a Toshiba  USB 3.0 & 2.0, 750 GB/Go External Hard Drive storing our TM backups that was unplugged  by mistake without turning it off/ejecting, and it will not back up. Message states that "files can't be copied onto the backup disk because it appears to be read only". Tried several recommendations: turning the external drive off, and removing the USB cable, restarting mac. Also went thru several cycles in Disk Utility of trying to verify and repair the disk. The last time I tried, there were several messages, including 'DU can't repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files" , as well as "you may need to repair or reformat the disk using Disk Utility. If the disk can't be repaired, you must use a different disk for backups. Open T.M. preferences to select a different backup disk." 

We have already spent several hours reading and working on this without success.  BTW we also have Carbonite backup for extra protection. OS is Snow Leopard 10.6.8.


Questions:  is the Ext. HD likely damaged by this?  So far, most of what we read is that it is not. For example:




We are able to click  the T.M. backup icon on desktop and see past backups, but just cannot backup anything more.


What is the best plan of attack here?  I do not know the first thing about partitioning the Ext.HD, but read about that. We only have one partition dedicated to T.M. backups .

Considering my elementary knowledge, is it best to erase the existing BackUp's and start from scratch? there is an Erase tab with several options but I don't know what to select.  Thank you very much!

iMac, Mac OS X (10.6.8)