Skip navigation

Bootcamp Windows 7 - Missing Operating System

653 Views 0 Replies Latest reply: Sep 2, 2013 12:23 PM by ruchanziya RSS
ruchanziya Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 2, 2013 12:23 PM

I had a MacBookPro with Snow Leopard and Bootcamp with Windows 7 all working well. In order to blow some more life into MBP I replaced my DVD drive with  a SSD. Reinstalled Snow Leopard. And then when I get a hold of a Windows 7 iso image decided to move Windows to SSD. I partioned the drive using Disk Utility. And installed Windows 7 using a USB Stick and rEFIt.  

 

At the end of the process I was able to boot into the new Windows 7. Later I decided to get rid of the old boocamp partition and notoced that it was not bootable. I did not care about it and went ahead and deleted the bootcamp partition using Bootcamp Assistant.

 

However this process rendered the new installation unbootable, So I went ahead and tried a few installations by partioning with bootcamp assistant and disk utility. However no matter what i tried I am getting the black screen "Missing Opeating system" message. It boots fine with Parallels.

 

My guess is previously the boot information was on the first bootcamp partition and somehow it was pointing to the second partition.

 

In the meanwhile rEFIt displays 2 macOS volumes (correct) 1 unknown volume(no idea) 1 Windows Volume (correct) for the internal disks and two windows volumes for my USB installer volume. So I am a bit confused about the extra internal unknown and external windows volumes. So I am bit confused about that too.

 

Can anyone direct me  to fix my bootcamp volume?

 

Ruchan

MacBook Pro, Mac OS X (10.6.8)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.