14 Replies Latest reply: Jun 20, 2006 12:53 PM by Eric Kracinski
Tuffy Nicolas Level 2 Level 2 (170 points)
I have an iMac G4, flat-panel, 700MHz, 14" screen. When I start it up, it makes the normal "start-up sound" (chimes). I want it to start up silently (as I can do with my PowerBook). But if I "mute" the sound, and turn all the settings in the "Sound" System Preferences to "mute" and/or down to zero, it STILL makes the chimes sound when starting up.

How do I make my iMac G4 start up silently?

iMac G4, Mac OS X (10.4.2)
  • Eric Kracinski Level 6 Level 6 (15,925 points)
    Since you are running Tiger, take a look at StartupSound.prefPane. It is a utility that will allow you to turn down the volume or mute the startup sound entirely.
  • Tuffy Nicolas Level 2 Level 2 (170 points)
    Actually, Eric, I'm not using Tiger on that iMac -- it has Panther 10.3.9. I made this post from a different computer that IS running Tiger, so that setting appeared under my question.

    So, the question remains: If I'm running 10.3.9 on my iMac G4, how can I start up silently?
  • Nick Stearns Level 3 Level 3 (850 points)
    Eric is right on.

    I installed startup sound around January and it works great!

    I've got mine set for about a fifth of the way and it makes a gentle noise. You know it's starting up but don't get startled by the sound.

    You can also mute it completely if you want.

    Here are the System Requirements . It looks as if 10.2 and up.
  • Tuffy Nicolas Level 2 Level 2 (170 points)
    Nick --

    But StartupSound.prefPane is for Tiger only. I'm running Panther 10.3.9 on that iMac. Is there any solution for that?
  • Nick Stearns Level 3 Level 3 (850 points)
    Sorry I edited my above post when I noticed you had posted.

    Look again and you will see a link to their system requirements.

    It said 10.2 and above but check for your specifics.
  • Eric Kracinski Level 6 Level 6 (15,925 points)
    The link I gave at MacUpdate.com says Tiger only, so that is what I went with. If you follow Nick's link to the developer's site, you will see that it works with 10.2 and above.

    BTW, these boards do not pickup what OS you are running. You have to make that change in "My Settings" on the right of this page. It would appear that you have it set for Tiger. If you could change that, it would help eliminate the confusion.
  • Tuffy Nicolas Level 2 Level 2 (170 points)
    Eric + Nick:

    I just downloaded installed and used StartupSound.prefPane, but unnfortunately it didn't work at all. When I adjust the volume in StartupSound.prefPane in the System Preferences, SSpP gives me an error message about PRAM, saying the startup sound volume cannot be adjusted because it cannot access the PRAM (whatever that means). In the "Read Me" file for SSpP, it lists this bug fix for a previous version:

    "• Bug fix: The "Startup Sound" pane will display the improper message "An error occured during PRAM access...," if the program run by the pane can not have root privileges because of corrupted permissions. This problem has been fixed."

    However, it seems that the problem has NOT been fixed.

    Also -- perhaps this is relevant:

    I downloaded and installed the version linked to in Nick's comment -- which is version 1.04. I did not download or install the version accessed by Eric's top link, 1.1b1, because it seemed to be custom-designed for Intel Mac, and says it requires Tiger.

    So -- Should I take the plunge and download the newer version anyway? Or is there an entirely different solution that doesn't involve StartupSound.prefPane? Or should I give up and just endure the startup sound?
  • Nick Stearns Level 3 Level 3 (850 points)
    Being that I am an adventurous sort of soul, not always good, I would probably download and give it a try.

    That is definitely up to you. Before you do have you tried restarting and seeing if it works?

    Edit:After looking at the download release notes it says 10.4 and above. Maybe not.
  • Tuffy Nicolas Level 2 Level 2 (170 points)
    Nick --
    Yes, I forgot to mention: I tried muting the startup volume and then RESTARTING three times with SSpP and every restart still produced the same "chimes" at the same volume. In other words: tested, and didn't work.

    Plus, as you note, the version 1.1b1 specifically says for Tiger. Don't want to take the chance.

    So, I guess there is no solution. I had assumed that there was a self-evident way to turn off the startup sound built-in to either the iMac itself or to 10.3.9. I'm surprised that the only solution is a third-party download (that doesn't apparently work in every instance). With PowerBooks, muting the overall volume means that starting up is muted too. I didn't realize that this was not the case with iMacs.

    Oh well. My ultra-low-tech "solution" is to put a pillow over the base of the iMac when I start it up in the morning, so the sound is muffled and doesn't wake other light-sleeping household members. Primitive, but mostly effective.
  • Eric Kracinski Level 6 Level 6 (15,925 points)
    While I understand why you want to mute the startup chime, it is there for a reason. Depending on what is wrong with your Mac, different tones will sound, so it is an important diagnostic tool.

    I seem to remember other tools that will mute the sounds - Tinkertool System comes to mind - but I can't remember any others.
  • mrtotes Level 6 Level 6 (11,825 points)
    The other low tech way is to plug head phones in to the iMac.


    I'm using startupSound.prefpane on both my iMac 10.4.6 and on my TiBook 10.3.9. Both work fine. The authors say 10.2 is all that is required..

    Have you repaired permissions on your Start-up Volume Boot Disk? (poor choice of phrase for this subject).

    Go to Macintosh HD > Applications > Utilites > Disk Utility. Select Macintosh HD and hit "Repair Permissions" this could well fix the issue that StartupSound.prefpane can't access the PRAM settings.


    Are you logged in as the Administrator of OS X when you are trying to set the start-up volume?



  • Eme Level 5 Level 5 (5,635 points)
    Here is more on the Start up sound just as a
    fyi to Tuffy & anyone who may find it interesting i know i did .

    Eme: )
  • Tuffy Nicolas Level 2 Level 2 (170 points)
    Eric --
    Tinkertool System is a commercial product -- I'm not prepared to have to pay money to get this problem solved quite yet.

    mrtotes --
    Of course! The old headphone trick. I actually used to do that in the old days with an old PowerBook 155 running System 7 -- it was the only way to not have a loud startup sound. I had totally forgotten about that.

    In fact, one doesn't need to plug the whole headphone into the sound-output hole on the computer -- one only needs just a little end-plug -- the wires and the headphones themselves are unnecessary.

    Luckily for me, I had a leftover audio plug (about half an inch long) in a box of old stereo components; I plugged that into the sound hole in the back of the iMac, and -- voila! -- as expected, it "absorbed" all the sound and the startup was silent.

    So, I'll consider this my solution.

    I will say that I did indeed try your other idea -- repairing permissions, then seeing if the Preference pane worked. While I did indeed have a lot of permissions that needed repairing, even after running Disk Utility, I still got the same error message from the Preference pane, and subsequent startups still had the startup chimes.

    So, giving up on that, I uninstalled the StartupSoundPreferencePane.

    I'll just go with the low-tech audio-plug solution. It's a step up from my pillow solution. But I still think it's odd that there's no native way to turn off the startup sound on an iMac, as there is on a PowerBook.

    Thanks mrtotes and everyone. Issue resolved, as far as I'm concerned.
  • Eric Kracinski Level 6 Level 6 (15,925 points)
    "Tinkertool System is a commercial product -- I'm not prepared to have to pay money to get this problem solved quite yet."

    I certainly understand. It is not worth buying if that is all you want it for, but TTS does serve many purposes. If all you want is one, then it is a waste of money.

    I was going to suggest the headphone trick, but forgot about it when I got involved looking up TTS. Sometimes the best solutions are right in front of us - LOL!