Previous 1 2 Next 17 Replies Latest reply: Oct 24, 2014 2:25 AM by Eddie in Prestwick
thomas bananus Level 1 Level 1 (0 points)

Hi Mac Mail is showing the recipient of the email (invariably me ) in list of emails the middle pane rather than the sender. How do I chnage it to show the sender other than revert to Classic layout. Seems a silly way of laying out essential summary of list of emails sent to me.

 

Maybe I am being dumb!

 

Best

 

Tommy Banana


OS X Mountain Lion (10.8.4), Logic Pro X
  • braden85 Community Specialists Community Specialists (3,695 points)

    Hi thomas bananus!

     

    I believe you are referring to the Message Attributes in Mail for Mountain Lion. More info about this can be found in the following article:

     

    Mail (Mountain Lion): View messages

    http://support.apple.com/kb/PH11705

     

    Specifically, I think this section of the article will point you to the features you desire:

    Show more information:
    Choose View > Message Attributes, and then choose the information you want to see, such as Size or Mailbox.

    Thanks for using the Apple Support Communities. Have a good one!

     

    -Braden

  • Eddie in Prestwick Level 1 Level 1 (0 points)

    I have this problem too, but in Mavericks. Annoyingly when I click on my inbox it intially shows correctly all the senders. However after a few seconds the page seems to refresh and suddenly all I see is the recipient - me - in most/all messages. if I click to another mailbox the problem goes away, then returns after another few seconds!

     

    I am on a mid 2012 MacBook Pro 15in Retina with Mavericks and Mac Mail. All updates are complete.

     

    The mailbox is one of several Exchange Boxes but I do not have these symptoms on the others.

     

    Hope someone can help.

     

    Best,


    Eddie

  • murraytodd Level 1 Level 1 (0 points)

    Same or me. Mavericks as well. If I restart mail I see the list properly for less than a minute, then things "blink" and it's all Fubared again. This is killing me! I can't restart mail every damned minute!

  • Eddie in Prestwick Level 1 Level 1 (0 points)

    As an update to my original post I am still having this problem and it is now affecting all Exchange inboxes. It also affects spotlight searches within Mail - which is probably the most annoying aspect. During a search when the screen "refreshes" and then shows only the recipient address (almost always me), the spotlight search disappears and I have to re-enter. Another annoying feature is that any attachment I am "quick viewing" disppears and a blank "loading attachment" screen appears. This is now very disruptive. I am a JV member and have had several discussions with the JV team. The latest involved doing a re-installation of the OS but this did not help. I was told the next stage involves a similar process but requires user data to be moved away and then manually restored. Not something I want to do unless absolutely necessary.

  • CaptainMarvel Level 1 Level 1 (0 points)

    i had the exactly same problem after i activated keychain on my MBP (running on maverick) earlier today. as i did not find any other solutions online, i finaly had to deactivate keychain again to get my email displayed correctly.

     

    i wish there was a propper solution to use keychain and have exchange folders displaying the sender's name correctly.

  • Eddie in Prestwick Level 1 Level 1 (0 points)

    Yikes. I am a bit of a novice with Keychain so don't want to mess with this. My biggest complaint is the damage this does to spotlight. With each "refresh",  my search disappears. Disappointing Apple. very.

  • twsager Level 1 Level 1 (0 points)

    Exactly same problem here after upgrading to Mavericks!!!

  • twsager Level 1 Level 1 (0 points)

    On another thread, I got a good suggestion to rebuild the mailbox index. First time was within Mail (select mailbox, them Mailbix - Rebuild).  Second time, shut down Mail, rebuild the index by directly deleting the Envelope index files (I forget the exact names), then re-open Mail. This forces a full rebuild. Sadly, same symptom.

     

    Any ideas welcomed. Thanks!

  • twsager Level 1 Level 1 (0 points)

    I still cannot find a solution to this weird problem, any ideas welcomed.

     

    This came up after upgrading to Mavericks.   Using Mail.app, multiple mail accounts. It only happens with my sole Exchange account.

     

    Upon opening mail, the display is correct for several seconds. Then the screen seems to 'refresh', and the sender's name in the middle pane is replaced by the name of the first recipient. If I switch to a different mail account, then back to the Exchange account, the display is again correct for a few seconds. This phenonenom also affects spotlight search by sender in an irritating way, since when the display changes, the result of the search clears.

     

    Have tried: rebuilding mail index, both from within mail and brute-force (deleting the files); deleting the Exchange account from within mail, then adding it back in.

  • twsager Level 1 Level 1 (0 points)

    Oops - final detail. The problem seems to go away by de-activating the iCloud keychain on this machine, as someone noted above. This is irritating for different reasons of course.

     

    Thanks!

  • Eddie in Prestwick Level 1 Level 1 (0 points)

    Hi all,

     

    After many weeks of bouncing back and forth between Apple JV and finally leaving my MacBook with the Apple Store Genius team - all without success - I believe I know what is causing the problem.

     

    I am as certain as I can be that it is indeed keychain which is the culprit. I deleted all my Exchange Accounts and re-entered one at a time but still had the same problem. However when keychain is turned off - bingo! No more emails showing recipient rather than sender and, more importantly, no more screen refreshes with search criteria being wiped out. All Exchange accounts perfect. As a small aside when entering email details into the Accounts section of preferences in Mail, the screen refresh was happening and wiping these as I entered them too. Weird. So, reluctantly, I have turned off keychain on my MacBook. Now, instead of having this problem between 1 and 10 times a minute, it has 100% gone.

     

    So I guess I am having to draw a line under this as Apple seem not to be able to resolve it and don't acknowledge it as an issue - which is a shame as they MUST know that it is. Slipped a notch in my estimation guys. Eddie.

  • buddy patch Level 1 Level 1 (0 points)

    After being irritated by this behaviour for months, I have also disabled iCloud keychain access and can confirm that the headers are displaying correctly now. What a bizarre bug.

     

    Apple: I want my iCloud keychain access back, so please fix it!

  • Bell233 Level 3 Level 3 (670 points)

    The following threads shows multiple solutions, have a look:-

     

    https://discussions.apple.com/thread/3966824?start=15&tstart=0

  • buddy patch Level 1 Level 1 (0 points)

    Thanks Bell233. However, I had tried all of those suggestions before finding this post.

    The behaviour where the sender address displays correctly for several seconds and then "refreshes" to my own address only occurs with iCloud Keychain on. This is a unique problem...

    Shane

Previous 1 2 Next