2 Replies Latest reply: Sep 5, 2013 5:55 PM by 1jennifer
1jennifer Level 1 Level 1

I have OX X 10.5.8 and just purchased and IPhone 5.  I want to download my itunes but it won't let me as I need 10.6.8   I have tried many times but there doesn't seem to be a download to update 10.5.8 to 6 or higher.


iMac
Solved by Niel on Sep 5, 2013 5:23 PM Solved
There isn't one. The next step is to buy a Mac OS X 10.6 DVD; Mac OS X 10.6 requires an Intel Mac with at least 1GB of RAM. (88457)