Previous 1 2 3 Next 42 Replies Latest reply: Apr 29, 2015 9:43 PM by Laurainunez Go to original post
  • Sherniqwa Level 1 Level 1 (0 points)

    I am having trouble with the sent and receive setting. My email is the only option selected. When I sign out, my iMessage is saying: "waiting for activation." I've tried logging out of my apple id account, turning imessage off and on, and restarting my phone. I still cannot select my number as the "sent and recieve" option.

  • Iammelissageee Level 1 Level 1 (0 points)

    This helped me so much!!! Thank you

  • Strive268 Level 1 Level 1 (0 points)

    I have tried all the given ways and none have worked my number is still faded and my email address is still checked

  • Richard Gaitskell Level 1 Level 1 (55 points)

    iMessaging on my IPhone has also stopped working while I am abroad. I tried the above solution while on WiFi and Cellular voice, but unfortunately it didn't work - the phone reports Trying to Activate but it never resolves. (I haven't tried turning on cellular data, since I want to avoid the additional charges.)

  • Richard Gaitskell Level 1 Level 1 (55 points)

    Update: Overnight the iPhone was authorized - it just took a few hours .... So the technique outlined here did work. Very many thanks.

  • dom_v_e Level 1 Level 1 (0 points)

    What method did you use exactly? The one posted by Sarge10709?? Did you ever turn on cellular data or just cellular voice? Thank you! Also does yours appear to remain connected to your number or does it go back to email??

  • UTChris Level 1 Level 1 (0 points)

    Noahwhite2014 wrote:

     

    gjn6595, Try this:

     

    Go into your phone settings
    Go to Messages

    Go down to Send & Receive
    Next to it it should say "X Addresses" (1 Address, 2 Addresses, etc)
    Go into that setting pane and look at the addresses.
    Make sure your Phone number is checked and that "Start New Conversations From" is set to your Phone number (Scroll down in that settings pane if you can't see it)

     

    If that doesnt work, In the same settings pane, tap on your apple ID at the top and sign out and back in and try repeating the process. If that doesnt work, go to the icloud settings pane and log out and back in and let me know how it works out!

     

    Good Luck!
    Noahwhite2014

    This help me get things working again, thanks!

  • lukescarpenter Level 1 Level 1 (0 points)

    I have an iphone 5 that I used with AT&T in the states. I moved to Uruguay a few weeks ago and had no problems using imessage until I bought a SIM card from a local carrier and inserted it. My iMessage number changed to the new Uruguayan number but when I put my AT&T SIM back in I can't change the number associated with iMessage. I've tried everything on these forums but even when I successfully log in, it says "waiting for activation"  and in the Send & Receive > you can be reached by iMessage at pane it shows my email address ticked and the Uruguayan number in a lighter shade and unticked. I'm using my AT&T SIM and I have international service.

    Ideas?

  • aphni Level 1 Level 1 (0 points)

    i have been struggling with this for months. the only thing i didn't try was noah whites step "6. Go to the PHONE settings pane, and change your number from +1 (123) 456-7890 (the numbers are place holders for your phone numbers digits) to (123) 456-7890. And tap Save" this along with switching FaceTime/iMessage off and on worked like a charm. props to that guy!

  • alexismoreno.boyce Level 1 Level 1 (0 points)

    I am currently living abroad for about a month now and my iMessage had been working just fine! Then just this morning i noticed i wasn't receiving any messages and when i sent them they were getting sent from my email and not my number. When i checked the "send and receive" it only had my icloud email checked off and my number was in not checked of but it was faded grey therefore not allowing me to check it off. Ive tried almost everything from resetting my phone to logging on and off...nothing is working. "Waiting for activation" is all thats there...i figured since my cellular has been off that this maybe one reason that i cannot get connected to my number. But i don't have the slightest idea on how the number became unelected. Help!? p

  • rangeela_z Level 1 Level 1 (0 points)

    I tried this one. Still it doesn't work: in fact, the phone number isn't checked and I can't 'check' it - it stays grey.

    The message under iMessage reads "Waiting for activation" and stays the same ...

     

    Also, I can't activate text message forwarding. When I try, it asks for an activation code which my MacBook Air isn't giving ... it used to give, but from January 5th it is not working.

     

    HELP!

  • Pop Rouge Level 1 Level 1 (0 points)

    I had this same issue while traveling in Mexico and the most important thing for me was realizing that you must give it time for the grayed out number to become active. After a while hassling with my settings according to several of the suggestions in this forum, I walked away from my phone when it still said "waiting for activation" and when I came back 20 minutes later it was fixed. The number is still gray but now it has a check mark next to it and iMessage is working through it again. I had cellular data turned on while I left it sitting.

  • Laurainunez Level 1 Level 1 (0 points)

    I had a similar problem trying to activate iMessage and FaceTime after coming back to my residence country. I just couldn't get both of the to work with my phone number, just with email addresses. I did all kind of resets and hard resets, settings configurations, etc... and after months of trying unsuccessfully I gave up. Today, I was managing my Apple ID settings and verifying all my data and saw that my mobile phone country code was not right. (appleid.apple.com/account/manage/phone). I wrote the right one and voila! iMessage and FaceTime started working on my iPhone, iPad and MacBook Pro with my mobile number.

     

    Hope this helps!

Previous 1 2 3 Next