Previous 1 2 Next 22 Replies Latest reply: Dec 9, 2014 6:50 AM by strick33702
tlhintoq Level 1 Level 1 (5 points)

Ever since I replaced my household router with a new D-Link 655, the AppleTV's (I have more than one) have had a really hard time.

They can the server, then they don't... they can make changes like "Show as watched" but can't start video streaming... I can't start a show from the AppleTV but can 'push' it to that unit from the server iTunes... Meanwhile the unit surfs the internet just fine. And all other network services are fine including things like wi-fi streaming from a laptop to my network enabled bluray player.  All of that I can half blame on the router doing weird stuff.

 

What I can't blame on the router is...

As part of my diagnosis of the problems I tried putting the living room apple tv 3 on ethernet to see if it the above problems got better.  Nope.

So I put it backin the living room, meaning its on wi-fi again... Only it won't flip back to wi-fi.  It still thinks its on ethernet even though there is no Cat6 plugged into it.  No amount of restart or resetting will get it to change to wifi.

 

Is there some way to force it back to wi-fi?  Leaving it unplugged from power for 2 weeks didn't reset it.

  • diesel vdub Level 7 Level 7 (21,980 points)

    Restore the device via iTunes.

  • tlhintoq Level 1 Level 1 (5 points)

    How do you propose I do that, when it won't get on the network?

    You can't restore from the iTunes store if you can *see* the iTunes store.

    To be clear... No networking.

    It won't auto-recognize there is no ethernet cable and auto-switch to wi-fi.

    When it is on ethernet, it doesn't actually get on the network - either by DHCP or manual IP config.

    When restarting the router doesn't even show ethernet activity/connection for the AppleTV3 for about 3 minutes. Then eventually the router shows a device connection LED, but the AppleTV doesn't actually see the internet or the local network.

  • diesel vdub Level 7 Level 7 (21,980 points)

    tlhintoq wrote:

     

    How do you propose I do that, when it won't get on the network?

    Restoring via iTunes has absolutely nothing to do with the ATV recognizing the network.

     

    Physically connect the ATV to a computer running iTunes via a USB cable.  Restore the device.

  • tlhintoq Level 1 Level 1 (5 points)

    Sorry. I thought you were referring to the option on the AppleTV itself: Settings | General | Reset | Restore.  Which is through the iTunews store.  I'll give the USB cable a try and report back findings.

  • tlhintoq Level 1 Level 1 (5 points)

    Heaven for f***ing bid they use a normal mini USB jack that we all have 100 cables for that fit cameras and every other device.  Or even choose to use a lightning connector so it matches the new phones and iPads..... NOOOOOoooo that would make life easy on us poor consumers.  They have to go off and use some OTHER itty bitty cable that I probably have to order out of Hong Kong to get (its a USB micro according the the Apple site. Now I'm just a loley software engineer with more tech than god, numerous digital cameras, blutooth headphones, several smartphones and tablets, PC with 6 screens and KVM to 4 more computers... and I don't have one of these in my several tubs of cables.  Who expect John Q. Public to have one laying around?).  I guess including a cable with the $100 device would have destroyed all their profit margin.

     

    Couldn't put a recessed 'Reset' button on it to restore it to factory like routers and other devices... ?  Would that have been so tough?

     

    I've had a Mac since MacOS 6... Classic up to QuadTower... Owned several including an Xserve with RAID for personal use.  But this is the kind of stuff that makes people leave and go to Windows boxes where simple expectations don't require having a complete IT department full parts in my garage just to hook up a little device.

     

    I'm going through all this because I like iTunes.  I have years of media in it and I like the UI of the AppleTV and simple remote for the wife and kids.  But its getting to the point where "It just works" no long applies to Apple devices, and there are plenty of other makers of similar boxes.  "WDTV live" anyone? Not only does it stream, but has a USB port in the front for easy thumbdrive play and plays more than just MP4/M4V format.

     

    <end rant>

     

    I guess I'll special order a cable and give a try to resetting once Amazon delivers.

  • tlhintoq Level 1 Level 1 (5 points)

    <calmer now>

     

    Sorry about the rant.

     

    Turned out my wife's 4g mobile hotspot uses that cable. 

    I connected the AppleTV3 to my laptop. 

    Drivers installed

    iTunes saw it and went directly to "Restore and Update".

    Did that.

    Successful restore.

    Returned it to the living room (Wi-fi environment)

    Cabled it back in.

    Powered up and was truly as if just purchased.

    With the exception that it still thinks there's an ethernet cable plugged in.

    Will not accept that it is *not* on ethernet.

    Will not find/connect to a network if I swap it for the one in the master bedroom that is cabled and works fine.

     

    Looks like its just a unit gone bad and I'll have to send it in.

     

    Thanks for the help.

  • tlhintoq Level 1 Level 1 (5 points)

     

    As we all, everyone gets busy.  I have not yet sent this unit in for replacement.

    In the mean time, another update was rolled out.

    I updated the AppleTV3 via USB.

    It still stays stuck in ethernet mode even when there is no cable.

    It still does't see the network, even when manually configured.

    Yet the router see it and shows it as being on the LAN.

    Any other ideas of how to force some kind of deep reset, or how to force it onto WiFi?

  • Rudy386 Level 1 Level 1 (0 points)

    7/10/14  I have the same issue.  Ethernet settings in my Apple TV went to some unknown IP address and will not connect.  Unplugging the Ethernet cable has no effect, the device is still set to Ethernet.  I tried resetting the IP address to the assigned in my router's setup but no joy. I tried resetting the Apple TV  through iTunes but that worked no better than the Apple TV reset option.  There is nothing wrong with my router, switch or Ethernet cables.  The Apple TV was running fine and other devices still work when I plug them in to the same cable.  The Apple TV is barely two years old and Apple support will not talk to me without charging $20 an hour. 

     

    Does anyone know of a possible solution to this issue?         

  • øivind Level 1 Level 1 (0 points)

    Hey.

    Still nothing?

    I am also stuck on "Ethernet" no matter what.

  • Rudegar Level 7 Level 7 (22,215 points)

    could be dirt in the ethernet port or could be a broken detector in the port

  • Rudy386 Level 1 Level 1 (0 points)

    It ain't dirt.  My Apple TV is kept in an enclosed cabinet but I checked just to make sure.   I wonder at what version of broke the device might be.  I doubt anything is physically broken as the Ethernet cable was plugged in once and then left alone.   I was thinking that some type of software glitch occurred and thus was looking to see if there was any resolution to tlhintoq's issue.   I have found references to the issue on the web but no true diagnosis or resolution.   It's odd that the device defaults to an Ethernet IP address of 169.254.121.181.  I would expect an error message if the device had a physically broken part.   The only information I have been able to find on Apple's support site is that unplugging the Ethernet cable will cause Apple TV to revert to wireless mode and/or to reset the device.    

  • Rudegar Level 7 Level 7 (22,215 points)

    with the iOS devices many people end up having problems with dirt or a physical defect detector making their iOS devices thinking there is a headset connected all the time or never conected

    I would assume much the same technology was used to detect if the ethernet cable is connected or not

    as much the same thing happens with wifi when the enthernet connector is connected as it does with the speaker of iOS devices when headset is connection

    then I would think it by far more likely that it's a hardware issue with the Apple TV then a software issue

    and that hardware issue could be

    1. temp as in dirt or sand or the likes blocking the detector (people report that a lot with iOS devices)

    or

    2. a defect detector in the ethernet plug

  • Rudy386 Level 1 Level 1 (0 points)

    Yeah, I can see dirt becoming an issue with carry items like iPods and iPads.   But not a well treated Apple TV.  What has me thinking software problem as opposed to broken hardware is the odd IP assignment rather than an error message.

  • øivind Level 1 Level 1 (0 points)

    It seems I’ve found a solution!

    This weird workaround works as a «selection button» between the Apple TV´s network modes; wireless or ethernet.

     

    Ethernet cable in + restart = switch network mode.

    Ethernet cable out + restart = switch mode again.

    (Note that nothing happens before you have done a restart.)

     

    When you get your desired mode, witch by no doubt is «wireless», remove ethernet cable if you have to, and do not restart.

    Yeah... weird. I know. But this works for me every time. 20+ times tested now.

     

    It´s taken me quite some time to figure this out, and I´m kinda curious to know, is this a fix for my unit only, or a «global» fix.

    Let me know if you get the same results?

     

    Good luck guys, hope this solves your problems too.

Previous 1 2 Next