Previous 1 2 Next 23 Replies Latest reply: Sep 11, 2013 2:53 PM by freudsigmund Go to original post
  • Linc Davis Level 10 Level 10 (177,680 points)

    Back up all data. Don't continue unless you're sure you can restore from a backup, even if you're unable to log in.

    This procedure will unlock all your user files (not system files) and reset their ownership and access-control lists to the default. If you've set special values for those attributes on any of your files, they will be reverted. In that case, either stop here, or be prepared to recreate the settings if necessary. Do so only after verifying that those settings didn't cause the problem. If none of this is meaningful to you, you don't need to worry about it.


    Step 1

    If you have more than one user account, and the one in question is not an administrator account, then temporarily promote it to administrator status in the Users & Groups preference pane. To do that, unlock the preference pane using the credentials of an administrator, check the box marked Allow user to administer this computer, then reboot. You can demote the problem account back to standard status when this step has been completed.

    Enter the following command in the Terminal window in the same way as before (triple-click, copy, and paste):

    { sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -R $UID:staff ~ $_ ; sudo chmod -R u+rwX ~ $_ ; chmod -R -N ~ $_ ; } 2> /dev/null

    This time you'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning to be careful. If you don’t have a login password, you’ll need to set one before you can run the command. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.


    The command will take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.

    Step 2 (optional)


    Take this step only if you have trouble with Step 1 or if it doesn't solve the problem.

    Boot into Recovery. When the OS X Utilities screen appears, select

    Utilities Terminal

    from the menu bar. A Terminal window will open.

    In the Terminal window, type this:



    Press the tab key. The partial command you typed will automatically be completed to this:



    Press return. A Reset Password window will open. You’re not  going to reset a password.

    Select your boot volume ("Macintosh HD," unless you gave it a different name) if not already selected.

    Select your username from the menu labeled Select the user account if not already selected.

    Under Reset Home Directory Permissions and ACLs, click the Reset button.



    from the menu bar.

  • freudsigmund Level 1 Level 1 (5 points)

    first I walked through step one. I had to enter my password three times actually and it took a little over two hours to do the task. It ended in nothing more than the line that is also quoted when starting in Terminal.

    sigmund-imac:~ USER$


    since step 1 didn't have any effect on the problem (slideshow screensaver works only with a single directory (not being able to select an Aperture or iPhoto library) until either iPhoto or Aperture is started, then it crashes again), I walked through step 2 also. The result after step 2 was identical to step 1... no change at all.


    Have you got any more options as to why Aperture and iPhoto change some settings causing the screensaver to crash and why neither Aperture and iPhoto libraries can be selected as source?

  • Linc Davis Level 10 Level 10 (177,680 points)

    Move your photo library aside and create a new, simple one as you did in the Guest account. Test.

  • freudsigmund Level 1 Level 1 (5 points)

    This seem to have solved the problem.


    Would it jeopardize to import the images from the old libraries? I had done that already in the Aperture library (creating a new library and importing the images from the old library) prior to posting the question here. But that didn't help obviously. I really wouldn't likt to be handling the 80.000 images (55000 aperture and 25000 iphoto) again when it comes to tags faces and other information.

  • Linc Davis Level 10 Level 10 (177,680 points)

    You could try rebuilding the existing library in Aperture or iPhoto. Back up first. If that doesn't work, you're in uncharted territory and I don't know what else to suggest. Maybe your library is too large for the screensaver to handle.


    Rebuilding the iPhoto library

  • freudsigmund Level 1 Level 1 (5 points)

    I'll try that rebuilding of the libraries... thanks for all the help and suggestions... the library wasn't a problem for the screensaver to handle over the past few years, so I doubt whether that is the cause. But I know that now it does work... again.

  • Linc Davis Level 10 Level 10 (177,680 points)

    To clarify, you put the original library back, and now the screen saver works?

  • freudsigmund Level 1 Level 1 (5 points)

    No. Like you suggested, I moved the Aperture and iPhoto libraries to another folder, created new libraries in iPhoto and Aperture and filled them with a few photo's and now everything works as it should. Ergo, the trouble must have been caused by errors in these old libraries. Now that I know how to deal with it, if it happens again, I can safely try to import images from the old libraries to the new one and see if that still works or if there is something truly messy with the old libraries. I can only report in a few days whether importing succeeded or failed completely, since importing (and creating thumbnails) of the old Aperture library into a new one takes 2 or 3 full days on this 2,66 GHz IC2 duo iMac. I am curious to see whether all goes to smithereens again, or that creating new libraries and importing not just the Aperture library but only both iPhoto and Aperture libraies is the solution... I'll report when done.

  • freudsigmund Level 1 Level 1 (5 points)

    The true cause has finally come to light...ish


    Both the iPhoto and the Aperture libraries were corrupt in such a way that even importing the images from an old library into a new library caused the issues to resurface. The only unanswered question is how come that both libraries get corrupted at the very same moment in the very same way...

    but since it has all has solved: who cares.


    thanks again for all the help.

Previous 1 2 Next