5 Replies Latest reply: Sep 9, 2013 9:31 AM by brighteyes00
brighteyes00 Level 1 Level 1 (0 points)

i'm having trouble loading certain sites such as outlook, and a help thread on their site has said that my current version of safari isn't supported or something of the sort. i've tried updating safari before but i've gotten too advanced versions for my computer that i couldn't use. so what is the highest version of safari that i can install on my macbook? its a snow leopard 10.6.8 and i'm currently running safari 5.0.5


MacBook, Mac OS X (10.7.3)