12 Replies Latest reply: Feb 27, 2014 4:46 AM by Matthijn
rascally_rabb1t Level 1 Level 1 (0 points)

"Could not join (wireless network). A connection timeout occured"

 

My MacAir is acting strangely, It doesn't want to connect with my home wireless network. Other computers, and my ipad, connect to the same network no problem. I can also access other Wifi networks, such as my work, Starbucks, and Tim Hortons free wifi. I can be in the same room as the router, it is not an issue of being too far away from the access point. All other computers accessing this wifi network can get an IP and access internet, just not my macbook air (Mountain Lion OSX 10.8.4)

 

Here is what I have tried, to no avail:

 

- My home network is WPA-2, I've checked and re-checked the security settings and passwords. 

 

- I have used my husband's Macbook pro, and copied his internet advanced setting so that my Macbook Air has the exact same settings. Still not working.

 

- I looked at forum solutions, and tried copying my Mac address (advanced menu of the network preferences) into the TCP/IP tab DHCP Client ID box, which seemed to work briefly (I made it as far as the facebook homepage) before it dropped the network and I couldn't connect again.

 

- I reset the router, no change.

 

- I reset the modem, and had my tech support from my ISP walk me through setup again.

 

- I have restarted my Mac with wifi on, and wifi off, neither made a difference.

 

- I have deleted my home network from the keychain access and the preferred network lists, restarted, and tried connecting again.

 

My only thoguhts is that maybe it was caused by a conflict after a recent Mac OSX update. I have no idea how to solve that problem if its the case.

If anyone can help, or offer any ideas as to what may have caused this (it's been about 2 weeks since symptoms started), I'd be happy to hear any possible solutions right about now.


MacBook Air, OS X Mountain Lion (10.8.4)
  • sheila_m. Community Specialists Community Specialists (3,275 points)

    Hello rascally_rabb1t,

     

    Thank you for providing the details of the issue you are experiencing with your MacBook Air.  You have taken some really good troubleshooting steps already. 

     

    I recommend following the steps in this article:

    Troubleshooting Wi-Fi issues in OS X Lion and Mac OS X v10.6

    http://support.apple.com/kb/HT4628

     

    Follow the steps in the section labeled, "Symptom: My Mac does not connect to the Internet."

     

    Thank you for posting in the Apple Support Communities. 

     

    Best,

    Sheila M.

  • tmdd46 Level 1 Level 1 (0 points)

    I am having the same issue. My MBA started doing the same thing about a week ago. The computer had no issues 3 weeks ago when I purchased it.

     

    I've taken a lot of the same steps as you have had no luck figuring out a solution.

     

    - Turning on / off computer

    - Turning on / off wifi

    - Removing from favorite network

    - Using "Join other network" and adding all the information manually

    - Joining other networks and then joining my network

    - Deleted the keychain access for the network and tried adding it again

     

    Eventually I am able to connect, but it takes about 30 minutes and I haven't been able to figure out what actually allows me to get on. But everytime my computer sleeps or I turn off WIFI it takes another 30 minutes or so to connect.

     

    This is happening on my network at work. No one else is having the same issues -- there are about 15 others who are able to connect to the network without any problems.

     

    MacBook Air

    13-inch, Mid 2013

    Software  OS X 10.8.5 (12F37)

    Graphics  Intel HD Graphics 5000 1024 MB

    Memory  8 GB 1600 MHz DDR3

    Processor  1.7 GHz Intel Core i7

  • martindolce Level 1 Level 1 (0 points)

    I have exactly the same issue.  It's only on one location, and works fine everywhere else.  But my other devices all connect to this wireless absolutely fine - so presume that the wi-fi settings for this location have got themselves in a bit of a muddle?!?!

     

    I've followed ALL the possible fixes that I've found on the advice and community forums, but none of them work.

     

    I'm on an older machine that rascally_rabb1t, but allof mysoftware is up to date and everything else runs as it should.  I regularly fight the fight for Mac amongst my colleagues who run windows based machines - so am desperate to get this fixed so that I can return to the morla highground! (and do my work also!)   Help!!!!

  • jlim1996 Level 1 Level 1 (0 points)

    I ran into the same issue at one location. The macbook air 2013 used to work there over the past few months. Today it didn't. A windows laptop was successfully connected to the wifi. The air connects to wifi in other locations. I will apply a patch and try again next weekend.

  • jlim1996 Level 1 Level 1 (0 points)

    The problem went away. I don't know why. I did update the OS.

  • jennyd60 Level 1 Level 1 (105 points)

    This has started happening to me too.

     

    The steps which seemed to fix it were - deleting all the passphrases in the keychain, deleting all the network adapters in the sytem preferences. Then re adding the network adapters, unticking remember networks, restarting and reinputting the passphrase. Then re-ticking the remember networks and re-starting again.

     

    However as I only did that yesterday I cant be sure it wont re-occur

  • jennyd60 Level 1 Level 1 (105 points)

    (PS - to my main reply below in the thread)

     

    Oh and sheila_m. your suggestions, while undoubtedy helpful, unfortunately do not solve the issue. There is some sort of bug here. My personal suspicions lie with some sort of keychain corruption.

  • martindolce Level 1 Level 1 (0 points)

    This problem became increasingly worse for me, and I resigned myself that I'd have to contact Apple Support and pay to have it resolved.  However, when I did so, they 'suggested' that i may want to consider upgrading my iOS to OSX to see if that resolved it, as even if it didn't, I'd be entitled to free support to get the issue resolved! 

    I did so, and it seems to have resolved all of the wireless issues, as well as giving me some new neat Apps such as Maps & iChat.  Thanks Apple - you're the best!!!

  • juzac911 Level 1 Level 1 (0 points)

    Go to keychain in Spotlight and delete the network that is not working

  • Reitffunk Level 1 Level 1 (0 points)

    I am also experiencing this problem. For me it comes down to the Mini-Display port. As soon as I am connection my external monitor via a Mini-Display-Port to HDMI-Adapter the WLAN starts to do weird things. Sometimes it disconnects completely. Then the signal shows, that I am connected, but I can not go to any webpage. When I delete the connection and recreate it, then it gives me this "timeout" error.

     

    But as soon as I remove the HDMI-Adapter it is working.

     

    And sometimes the internet is working properly, but it's very slow. I made speedtest.net with HDMI-Adapter on and got 9 mbit. Then I removed HDMI-Adapter and got 24 mbit.

     

    I have MacBook Air late 2013. The adapter is no apple original, but also not the cheapest, about 15 Euro.

     

    I even tried to remove the Thunderbolt-Bridge from System-Preferences at Network, but didn't helped.

     

    It's really annoying..

  • sms49 Level 1 Level 1 (0 points)

    What OS update did you apply to the Air to address the connection timeout issue?

    Thanks.

  • Matthijn Level 1 Level 1 (0 points)

    You just can't make **** like that up. I have the same problem, and every other device I (iPad 1 and iPhone 5s) have has full reach here. So I thought I'd give your resolution a try. As soon as my internet dropped again, I pulled out my monitors (2 through unoficial displayport to DVI connectors) and my internet was back instantaniously.

     

    It seems that having the monitors connected is the problem.

     

    First I thought that it might be that I'd have my lid closed (and since the antenna is in the screen part) that would lower reach, but even with my lid open the same problem occurs.

     

    There is no particulair reason, it works for like an hour, and then every 5 minutes the internet is gone. A reboot, and you might be fine for another 30 minutes, but no guarantees. Well, thanks for your reply, I would have never thought that that could be the problem. I guess I'd be off to buying original adapters and hope the problem doesn't occur with those.