7 Replies Latest reply: May 30, 2015 3:27 PM by nightswallow
reeseypiecee_ Level 1 Level 1

how do you unblock a blocked plug-ins safari? when i go to the updated version to install it, it still tells me "blocked plug-in".


MacBook Pro
  • Linc Davis Level 10 Level 10
    expertise.desktops
    Desktops

    I'll assume you mean Flash. If you're sure you've installed the latest version of Flash, take each of the following steps that you haven't already tried. After each step, relaunch Safari and test. For a "missing plug-in" error, start with Step 5.

    1. If you're only having trouble with YouTube videos, sign in to your YouTube account and load this page. You may see a link with the text "Leave the HTML5 Trial." If so, click that link.

    2. If you're getting a "blocked plug-in" error, then from the menu bar select

     

     ▹ System Preferences… ▹ Flash Player Advanced

    and click Check Now. Quit and relaunch your browser.

     

    3. Triple-click the line below to select it:

      
    /Library/Internet Plug-Ins
      
    Right-click or control-click the highlighted text and select
      
    Services ▹ Open
      
    from the contextual menu. A folder should open. Delete the following item, or anything with a similar name, if present:
    • Flash Player (failing).plugin  
    You may be prompted for your login password.
      
    4. Re-download and reinstall Flash. Download it from this page:
       
       
    Never download a Flash update from anywhere else.
        
    5. If you get a "missing plug-in" error, select
     
    Safari Preferences... Security
      
    from the Safari menu bar and check the box marked Enable plug-ins.

     

    6. Select

    Safari Preferences... Extensions

    from the Safari menu bar. If any extensions are installed, disable them.

    7. In the Safari preference window, select

    Privacy Remove All Website Data

    Close the window. Then select

     ▹ System Preferences… ▹ Flash Player Advanced

    and click Delete All. Close the preference pane.

  • Klaus1 Level 8 Level 8

    If you still get a ‘plug-ins blocked’ message:

     

    http://support.apple.com/kb/HT5271

  • Neverendingtale Level 1 Level 1

    Sorry to say... I followed these instructions to the letter and it doesn't work.  When the Flash installer runs when it comes to Step 3 of 3 it just shows another "plug-in blocked" message.  I've deleted the old Flash, I've confirmed all the settings, still no joy.

     

    Can you spell F-R-U-S-T-R-A-T-E-D ?!?!?!

     

    All because I *upgraded* to a new iPhone > which wouldn't sync > which forced me to upgrade iTunes > which forced me to upgrade my iOS > which forced me to upgrade Safari (because Photobucket stopped working) > and now Flash won't work.  All in all, my overall Apple experience has been *downgraded* - and for that I paid a premium price!

     

    Just in case anybody at Apple cares, since they are making money hand over fist - for now anyway.

  • pattyann62 Level 1 Level 1

    Thank you. This worked like a charm. A little confusing, but was able to navigate my way through and re-install Flash Player successfully.

  • davidpsd46 Level 1 Level 1

    Just fixed seemingly the same issue for my mother on her MacBook, and hope it may help.

     

    The issue we hit was that, by default, the flash update process was trying to take place within Safari. So the new version would download, open itself to install, but then hit an open copy of Safari and show the blocked plug in warning again.

     

    All I did was check the downloads folder to make sure we had the new flash update; quit Safari; launch the flash update from the disk image in the download folder; then relaunched Safari. It took a couple of goes ( she had never updated anything!) but I got her back onto Jacquielawson and iPlayer and she is very happy.

     

    of course ymmv, but it may help someone out there.

  • LeiLeilani Level 1 Level 1

    This was the easiest to follow and best advice of all.  The steps worked for me the first try. Thank you, thank you, thank you.  I guess my downloading of the newer Flash was not working, as you noted, because my computer system was showing I already had it downloaded, but it was just seeing my old version in the download folder. 

  • nightswallow Level 1 Level 1

    Number 3 worked for me, thank you for your help today!