3 Replies Latest reply: Sep 11, 2013 11:12 AM by BDAqua
Paul Quemades Level 1 (0 points)

Situation and problem description:

administrator forgot password. shut out of system. lost admin password is same as login password.

Logged on using another account which has no system privileges nor most applications nor utilities (a child's account).

Time Machine Back ups on separate hard drive are obviously not accessible.

Can not use installation CD as this account has no privileges - so can not use the option to reset password holding down C key.

There is a key logger installed but again it is tied to the administrator and so hot key cannot be used (the key logger will have recorded the new password which has caused this problem - together with lack of foresight, obviously.

 

Any solution considered including ways to initialize disk even if content is lost -  currently the computer is only good enough for my 5 year old.

 

I need a hacker!

 

Hypnosis an option? (joking...then again, maybe not!)

iMac 20 intel, Mac OS X (10.5.8), Grape imac, ipod nano, ipad wifi
  • BDAqua Level 10 (122,276 points)

    Hi, it really depends if this is a Firmware Password, a Filevault PW, or what, if a simple login PW...

     

    Reset OS X Password Without an OS X CD...

     

    http://theappleblog.com/2008/06/22/reset-os-x-password-without-an-os-x-cd/

     

    Admin Hack...

     

    http://www.hackmac.org/?q=node/4

     

    Starts up like the first time you buy a new Mac, but after filling in all that info again, you should have access to the computer and the other Users & files will still be there... give the new User a different name than an existing one.

  • Paul Quemades Level 1 (0 points)

    tried to send this yesterday but had some trouble, this is a recovered version

     

    - hi Thanks for the response - it's a simple log in password

     

    I'm just reading the different ways this can be resolved / can be done but there is some variation so I'm waiting to know what I'm doing first. -

     

    in the end using single user mode in the terminal and entering dscl . -/User/ etc and entering new user and new password did not do the trick although I tried several times but entering the rm / var / db/. setupdone code and not deleting it as in the link but simply entering reboot, allowed me to go through the registration again and so open a new admin account

  • BDAqua Level 10 (122,276 points)

    Good work.